Engine DJ v3.0.0 Database issues when using third-party tools (Lexicon, De Cu)

I just updated to Engine 3.0 from 2.4 and now I get this error message and the application just shuts down and when I reopen, the same message comes up and shuts down again.



so this is going to rebuild my entire database? will I lose all my cue points?

Deleting Database2 makes for an empty collection, so not a good solution. Same problem here and can’t even submit a ticket. Oh well.

I just opened a support ticket, lets see how long it takes for them to respond. dead in the water now!

I’m having the same issue too

Downside is trying to rebuild with Lexicon doesn’t work either, it gets past the error, shows playlists, just no content.

Same issue here on MacOs. Additionally trying to sync from lexicon to EngineOS library on my SC6000 leads to the error: “Database of Denon_SSD (internal) is from a newer version of Engine and is not compatible with this version.”

This is with SC6000 on firmware 3.0.0

1 Like

Yes, these are the problems you may have when you use third party software to manipulate the Engine DB. You will have to wait for a new release of Lexicon to get the new compatibility. :person_shrugging: :man_shrugging: :woman_shrugging:


I was hopeful but also knew deep down lexicon wouldn’t work. May in the end be easiest to just nuke and rebuild.

I’m working through this, I moved my Engine Library folder and restarted Engine DJ to get a fresh 3.0.0 library going. Now if I sync from lexicon to Engine DJ I’m seeing my playlists recreated in Engine DJ. So Lexicon is working with 3.0.0, but I had to re-initialize my Library as mentioned. I’m not clear if this incompatible library issue is present for people not using 3rd party library management software.

Edit: This seemed to work when I exported a single playlist to Engine DJ, however doing a full export put the library back into the broken state.

Renaming my Engine Library Backup (2.4.0 backup not used with lexicon) to Engine Library seems to resolve the issue. So to DjAj’s point, this seems like maybe just an issue with lexicon and it’s exports to Engine DJ being incompatible with 3.0.0

I do not understand all these bugs encountered, how and with what are your databases built?? All my 2 Prime 4 drives are in Exfat (MBR) format, they all have internal SSD drives (except my Prime Go which has an SD card).

In my Mac… I authorized access to all my disks for the Engine Dj Desktop application!

It happens in:

In System Preferences, then Security and confidentiality then I authorized access to 2 places:

And for Windows 10/11 I disabled the firewall and antivirus !

Remember to eject your drive from the Engine Desktop application after each modification, Use the “Run Cleanup” button sometimes it improves the stability of your library and remember to make a Backup!

I tried reinitalising my Engine library too, and then syncing from Lexicon, but this hasnt worked. I have managed to revert back to 2.4 and sync that way, but not got it working with 3.0. Judging by the number of Lexicon references here, I wonder if that is the connection? Seems odd though that youve got it to work?

Yeah, I just edited my comment, it worked when I exported a single playlist, but doing the full export did not work.

Guys, from what they have written, the Engine DB has been modified, and this is demonstrated by the fact that the conversion of the DB from 2.4 to 3.0 takes place So it means there is new stuff in DB 3.0

These innovations could not have been known by the Lexicon developers, as they do not work in collaboration with the DDJ Team. So obviously there won’t be complete compatibility of Lexicon with DB 3.0.

We have to wait for the Lexicon developers to make the necessary changes and release a new version compatible with DB 3.0.

It will be compatible until a 3.1 DB comes out and so on!! :woman_shrugging:


If I sync my library in lexicon to 2.4, then open 3.0 and convert the library, it works without issue.

As with all database updates, any third party software will need to be updated to work with the new database.

Backwards compatibility is for the engine OS software, not 3rd party library management.

Make sure to voice your concerns on the lexicon discord. I’m sure there will be a lexicon update to fix it soon, as the dev behind lexicon is usually pretty quick to fix things like this.


Same issue!!! Please let me know how to solve it. I wrote to the support already. Unbelievable :frowning: I uninstalled the 3.0 from my laptop (mac) and reinstalled 2.4… and at least all my music (all external drives) is there.

I hope they fix this problem soon, I have a major gig Saturday. :frowning:

1 Like

Same issue here, i downgraded to 2.4 to use this software.

Same to me! No chance to get it running. Going back to 2.4 and anything is ok. Puh! Luck! Denon: Please fix it fast!

Have you all read the release notes properly before updating?

Important Notes

  • The Engine DJ 3.0 database has been refactored to improve performance.
  • On the first use of Engine DJ 3.0, Engine DJ will migrate earlier databases to the new format while maintaining the collection structure. This process can take some time depending on your collection size. For larger databases on removable drives, it is recommended to use Engine DJ 3.0 on the desktop for faster database migration.
  • Be sure to upgrade well before you are in a performance environment.
  • Engine DJ 3.0 databases are backward compatible with Engine DJ 2.x.x versions.

It was in the release announcement not to upgrade straight away if you had immanent gigs coming up.