Engine DJ v3.0.0 Database issues when using third-party tools (Lexicon, De Cu)

I often wonder how many ‘issues’ in life would be resolved by people acting in a pragmatic manner when addressing a task.


So, assuming the common thread here is Lexicon users, I’ve raised the issue with Christiaan the developer. He’s aware and is going to issue an update within next week or 2. You can Che k the forum there for any updates.

In other words, I don’t think this is a Denon thing at all, unless anyone has never used Lexicon and had the same issue?


Updated the title to better reflect the actual issue.


uninstalled 3.0 and went back to 2.4, now all my playlists are present but no tracks in any of the folders. :rage:

1 Like

The initial issue is with opening the engine database with version 3.0. not with Lexicon or another third party app.


I have been having database issue, after having upgrading (installing) 3.0 on 2.4. I have uninstalled everything with Revo uninstaller, deleted engine library in music folder, and reinstalled 3.0 from scratch. And now, eveything works. Even on Prime4 (did a usb update) May be it can help ?

Do you use lexicon?

No. I don’t use lexicon. Before I made a full backup of my 2.4 ssd and 2.4 music folder engine library. But no use, everything works. Didn’t had any sort of message of database upgrade.

For those using Lexicon; next week will be all hands on figuring out what changed in the Engine 3.0 database and making sure Lexicon is compatible. I expect to release an update a week after that at the latest. So please stay tuned!


you would think that Denon would have beta tested the new version before its released and not use the community as its beta testers!

I’m pretty sure everything is being tested before each release.


Just renamed my Library fro “Engine Library” to “Engine Library 2.4” in the Music Folder and Engine 3.0 startup correctly! Weird!

1 Like

OMG! My problems with Denon & Music Library on Engine Desktop and on SC6000 never stops to increase. I am about to let go of this and go back to the main player for twice the cost… too much time waisted… Gawd.

After upgrading to 3.0 I also got the database incompatibility warning. It did not initiate any migration to the newer version


Same problem here

1 Like

Same problem!!!

1 Like

I’m having this problem just trying to boot into 3.0. Worked fine this morning but when I opened again. Not. : (

No migration took place when it originally booted this morning either.

Has anyone tried exporting to serato from lexicon and then from serato back into Engine?

Ill give this a crack when I get home

Are all of these on Mac OS?

Honestly, I just nuked the entire database / music folder.

Exported from Lexicon → Serato DB

Re-enabled Serato on Engine after nuking that entire filestructure.

At this point you have all of your songs back, unfortunately I was unable to save playlists so I made some basic genre filtered playlists to get back playing

Good luck

1 Like