SC Live 4 overworking?

Using my SC live 4 in stand alone mode , all is updated!!

If I have say 3 tracks in the mix and and start looking to cue a 4th the music starts slowing down and sounds strange , also I was playing 2 tracks and needed to edit the 3rd tracks beat grid as I was just off , I had the same ! It sounds like the unit is having to work to hard and starts to lag out a little…

Anybody else having a problem like this ???

That storage media are you using? Tried using something else? Tested with wifi off?

I was using a USB the 1st time then switched to a new SD card , I have not trued with the WiFi off as I use Beatport Link a lot

I started paying attention and noticed the same on my SC live 4. This is unacceptable tbh.

2 Likes

I hope the problem is something with the software and with an update can be fixed !!!

1 Like

Today, I could replicate a similar issue. With only 2 decks active + Ableton Link with Sync and jumping between tracks with the << and >> buttons, the system seems to have some audible issues to properly buffer the track in the first 2-3 seconds. Listen for yourself:

If I may add, the software of the SC Live 4 should be monitored more closely in general. After some boot ups, the jog displays remained blank or displayed the numeric values only without the blue and white lines. Another time, all LEDs remained off until you pressed them once. Dunno if 2.4.0 improved the stability here, since I just updated it. But it shouldn’t happen.

Another bug, I might have to open a separate thread for that, even if you force the system into 2-deck mode, starting a playlist playback will ALWAYS switch the deck view into 4 deck mode, which is very annoying. 4 deck mode is too crammed on that 7" screen, I want it to remain in the two (active) deck view, no matter what.

1 Like

Hey @Skaratak It looks like the issue you’re seeing is the synced tracks being nudged into the phase of the link tempo. This is expected behavior if you have an active Link connection going.

@Mark_Beedham
Can you be a bit more specific in the steps to reproduce the issue you are seeing. It’s not clear what “start looking to cue” means - are you scrolling through your library our are you loading a track to deck, for example…

Okay, thanks so far. I had suspected the same, but wasn’t sure because of the short delay.

However, what I certainly observed yesterday were two bugs happening right after another. The first was Vinly Mode which stopped working on deck 1. When touching the platter, the deck would stop, but further manipulation wasn’t possible. Also, the LED segment ring didn’t display the needle position anymore, unless you started the deck, so it’s certainly not some grounding issue (leaving alone deck 2 was perfectly fine, same for deck 1 after a rebooting). Footage:

The second bug was the already mentioned LED issue after booting. Once again, ALL lights minus the main screen and jog screen background illumination failed to initialize:

When I loaded tracks into the decks, the set hot cues and bpm/time returned, and once I started them, the play LED as well as the needle ring returned to the displays:

My guess: When you boot the device, all LEDs cycle through while the EngineDJ logo is shown on the screen, right? Exactly at the moment the popup appears ‘Load User settings from USB/SD?’, all LEDs go off for a split second, before switching into the correct standby status. Maybe there is a software glitch, which prevents them to switch into their correct status form, and then they simply stay off entirely, until you engage each one manually. In total, I have booted my device around 20 times until now and this LED bug happened the second time. I just tried it again and everything was fine.

Please advise me if I should open a separate thread or ticket for those issues.

1 Like

Same glitch again yesterday evening. This time no media inserted. LED Lightshow as usual during booting, then as the EngineDJ logo + version number refresh a final time and prepare to fade out for the browser, all LEDs die, minus the jog screen background illumination.

Rebooting solved the issue.

Could a mod speak up if the dev team is aware of this problem? Otherwise, I will have to open a ticket. Another user shares similar issues here.

1 Like

Skaratak, got ya. This strange thing happens I think around 1 time out of 6 times when switching the device on. Also has happened two times in a row, but then doesn’t happen at all. And it’s always only when switching the device on. Once it switches on correctly, it never crashes or slows down, works just perfectly, even when 4 tracks playing at the same time -my experience.

That’s what I was thinking also - although I’d only test one usb stick against another usb stick rather than sd card , which seem to have their own issues when it comes to sustained data flow

I’ve also experienced the LED’s off on start up issue a couple of times, does seem to be an intermittent bug. I’d say it occurs maybe 1 in 10 boot up’s.

I’ve not experienced any “overworking” issues, however I did have problems with freezing and glitchy wavelength’s when I first got the Live 4. This was down to a slow (albeit new) USB stick. I’ve since bought a SanDisk Extreme Pro SD card (music library) and a Samsung Fit Plus USB stick (recordings) and have had no further issues.

I’ve just got my SC Live 4 and it did this LED problem on its first ever use.

Has been OK since though

More issues which I have encoutered…

  • …multiple times so far: overview waveforms don’t load. Usually only for one deck, rarely for both. The rest of the operation is totally fine.

  • …twice so far: left jogwheel stops working, no matter if in vinyl mode or not, pitch bending is not possible. This happened after ~4hrs in my set. Somehow, I managed to fix it by swapping the pitch bend buttons’ primary function (from ‘+/- range’ to ‘pitch bend’).

  • …repeatable (every time): when navigating within a playlist of long mixes (30-60min) the whole unit freezes for several seconds when jumping between tracks with the << / >> buttons. The audio keeps playing, luckily, but all LEDs (including the VU-meters) and the GUI temporarily stop moving. This is no biggie as I don’t need them for my gigs, but annoying nonetheless, probably a buffering issue.


My audio files (256-320/CBR mp3, some FLACs) are perfectly fine and work flawlessly in Serato DJ Pro. Same for my SD card (SanDisk Extreme, 90Mb/s).

None of these (in total 4) glitches affects the actual audio playback, which is good. But they need to be monitored and addressed. So far, there is still no moderator reply. I consider opening a ticket and just link this thread to the support team, so the dev people become aware. Open for your suggestions.

2 Likes

If you hadn’t mentioned the SanDisk Extreme, 90Mb/s SD Card then I would have put money on it being a slow USB/SD. I had very similar issues when I first got my Live 4 and it was down to the slow USB stick and SD card I was using.

Since upgrading to;

SanDisk Extreme Pro SD, 90Mb/s (Write) 200Mb/s (Read) - For Library

Samsung Fit Plus USB Stick, 30Mb/s (Write) 300Mb/s (Read) - For Recording

…I’ve not experienced any freezing/pausing/waveform issues at all.

Do you by any chance also have any USB sticks inserted even if just for recording to?

Also what is the write speed of your SD card? Are you using any cloud services while these issues occur?

Source: https://cdn.inmusicbrands.com/denondj/PRIME%204%2C%20PRIME%202%2C%20PRIME%20GO%2C%20SC%20LIVE%204%2C%20SC%20LIVE%202%20-%20User%20Guide%20-%20v2.3.3.pdf

This has (and should have) nothing to do with my SD card speeds. Even my SD card with 50Mb/90Mb is like throwing pearls before swine, heck it’s actually more meant for serious tasks like 4k60 recording rather than being required for music files which have a FAR lower bandwidth demand. Afaik the USB-readers on all Denon and Akai devices (except the blue ones) are ‘only’ USB-2 bus speed which equals to 480Mbit ≈ 30Mb/s in real life.

Oh, and Class U1 SD cards only have to reach a minimum of 10Mb/s writing speeds. Pretty much any SD cards nowadays is at least U3.

No, I don’t use cloud services at the moment. If I do, then never more than one at a time.


  • The LED issue even occurred with no media inserted at all (just the demo tracks). It’s a boot routine error for me: Sometimes it glitches out and then only the Engine GUI loads.

  • The overview waveform bug is inconsistent, only 5-7% of all tracks in my last sets were affected, and the rendering animation of the main waveforms remained flawless. So it’s not a buffering issue either, more like a routine/check failure, similar to the LEDs.

  • The (rare!) jog wheel failure seemed to be an isolated event which ‘self-healed’ during my set. No idea about that. I have Vinyl Mode deactivated most of the time. Potential grounding issues only affect the capacitive surface, not the pitchbend mechanics, which also didn’t work. But pitchbend with -/+ buttons is a workaround, so no biggie.

  • The long tracks = freeze issue only happens when using the track skip buttons, but not with the navigation encoder. A clear software issue, but again no biggie, just weird.

Hopefully the next x.1 or x.2 updates gonna kill those small hiccups.

Managed to grab a photo of my Live 4 with the LED’s not lit after boot issue. The only LED’s lit are the ones I’ve interacted with since boot up. This occurs approximately 1/10 boots.

1 Like

Hey. I had my SC Live 4 delivered today (love it; been using it all night :smile:) but have experienced the LED issue 3 times despite updating to 2.4.0. Was present before and after the firmware change sadly. Must be software related though so presumably we just need to hold out for a fix and I (we) don’t have a defective unit…

2 Likes

Aye, exactly the same symptoms which I had.

Also, 2 days ago, the left jogwheel stopped working again after around 1 hour. Neither Vinyl no Pitch Bend mode were operational. This time, I didn’t manage to hot-fix it by swapping the Pitch Bend button’s primary function. So for the rest of the evening, I had to phase adjust with the right jogwheel only, which was pretty annoying.

They better gonna fix those issues, the sooner the better. I don’t want to return my unit. I really like the overall design and concept of the Live 4, it is exactly what I had been looking for, but reliability is crucial.

1 Like