Rough Waveform Scroll / Stutter with EngineOS 2.3.0 & 2.3.1

First of all, massive thanks to the EngineOS devs & management for keeping the updates and improvements coming!

Now as the topic says, I updated both my SC6000M’s to the EngineOS from 2.2.2 to 2.3.0 this morning… After loading a few tracks and mixing a bit, I noticed the waveforms of each track weren’t scrolling on 2.3.0 as smoothly as they did on 2.2.2.

When i looked closer, it seems that every few seconds, the waveform was missing frames in the animation and was jumping forwards on the horizontal axis. This almost looks like a rough scroll or a random stuttering effect. It almost seems like the processor is getting held up with some other process behind the scenes and struggling to refresh the waveform on the display.

I recorded this happening on my phone… Putting aside the difference between camera frame-rate and display refresh rate, you can still see this scroll lag happening about 6 seconds into the video (07:04.7 to 07:04.9 on the display/track) and 13 seconds (07:11.9 to 07:12.1 on the display/track)

If you actually look closer at the second/millisecond counter on the display you can see that it goes from 07:04.5, 07:04.6, 07:04.7, skips 07:04.8, and goes to 07:04.9. Same thing for other skips/stutters.

Now you might say who cares about a 0.1s skip every few seconds, but if you’re actually looking at the waveform to help with mixing and setting FX, these skips make it really annoying on the eye.

I also rebooted, reset settings, reinstalled 2.3.0… Tried various tracks from USB and SSD, nothing fixed it! Any track played on both decks show this scroll stutter.

Can others please verify they’re having the same issue? Wondering if it’s just a problem with the SC6000m’s or across the whole product line.



can second this experience. Just updated and get major skips…


2.3.0 SC6000m, SSD, .WAV

Yep, I can confirm this also. When at max. zoom, it does skip every so often. Reducing the zoom a little seems to improve the problem.


Thanks for confirming guys! Glad I’m not the only one and it seems to be broadly impacting the SC6000 & SC6000Ms… possibly the other players too if others can confirm…

@JWiLL / @Reese - Your help with capturing this issue and sharing with the dev team would be greatly appreciated!

In prime 4 i have got the same problem, i downgrade previous version to solve it and i will wait for solution

1 Like

having the same experience on both of my sc5000s. and I have a “Prime Go” coming in the mail, I hope it’s not going to happen that either lol!!! (I also downgraded them back to 2.2.0)

I also reverted back to 2.2.2. There’s no feature in 2.3.0 that would justify me using it when a core UI function like scrolling waveforms is messed up. Hope the dev team puts out a quick 2.3.1 to fix this!

Yup same here waveform stutters. Not as bad on vertical but still there none the less. Horozontal stutter on some tracks is horrendous


So glad I waited on updating as the stutter would drive me nuts and there’s nothing in the new release worth that PITA.

1 Like

Same here, also on pitch adjustment when the waveform is resized, there is significant jitter.


Same, will revert to 2.2.2 for now, it was painful to mix yesterday.


(posted this in the wrong spot, moving it to this post) I’m now to the point where I’m 90% sure the stuttering could be due to the wifi. If I’m connected to a wifi source or if I turn wifi off, the stuttering is minimal. If I have it on but not connected it freezes a lot (I live in an area with lots of wifi signals). Yesterday while walking around and using the Prime Go, after about an hour of mixing the freezing would up to close to 10 seconds before resuming. Audio playback keeps going, but hotcues and nudging doesn’t work at all while frozen.


Yeah that’s unbearable! I have my SC6000M decks hardwired via ethernet and my Wifi is always off… So I never noticed that bad of a lag or freeze, but even with them using hardwired connection, it skipped like I shared in the original video!

This issue really needs to be addressed in the next minor release the team puts out.

1 Like

Same thing in a Prime Go, the jump from home a few seconds is horrible.

The interface is also generally slower.

Another thing I see is that sometimes you see two images at once, i.e. if I turn off the off message appears on the playlist or another screen and you hardly see the message.

Back to 2.2.2!!!

I had the same issue (stuttering waveform) on one of my two SC5000m after upgrading to 2.3.0.

Turning off WiFi fixed the issue.


To my surprise, EngineOS 2.3.1 was released this afternoon as a hot-fix to address the known issues in 2.3.0. I didn’t see any comments in the release notes about the waveform scrolling issue, but I figured maybe the “Other various stability enhancements & improvements” would have captured this issue and so I updated one of my SC6000M’s. After rebooting, the deck started smoothly and I loaded a brand new unanalyzed track from an external USB drive, waited for the analysis to complete and pressed play…

The track started fine but a couple seconds in, the waveform started stuttering again every couple seconds! Based on my findings, release 2.3.1 does not appear to address this issue for the SC6000M. I then loaded a pre-analyzed track and played it… Still stuttering! Disappointed, I reverted back to 2.2.2 and stuttering went away and scrolling was super smooth again. Through all this, I kept WiFi OFF as I use a LAN connection.

@JWiLL / @Reese - Thanks again for capturing all the feedback of the owners and to the devs for putting these fixes out… But, I’m not sure if 2.3.1 was meant to address this scrolling issue… If it was, the issue still persists. Could you please have the team investigate further. Thanks guys!

(updated subject of thread to include 2.3.1 based on my findings)


Hey Everyone,

Thank you for the feedback and apologies for the trouble. This was not addressed in 2.3.1 but the team is looking into it. We’ll let you know if we need more info and keep you posted on any progress.


Interestingly I’ve not had any stuttering or slowdown if the frame rate on my Prime Go.

I’ll keep an eye out but it’s not done it yet. Maybe it’s a different hardware revision?

Thanks for confirming that you guys are reviewing this issue! Happy to help if you guys need more details or need someone to test a fix.

1 Like

Wow, I love how 2.3.1 practically bricked my Prime 2. Thanks Engine DJ devs. Thanks for setting my controller back a year. :roll_eyes: