Engine DJ v2.3.1 Now Available


I posted an issue in an existing thread about freezing decks on the prime 2, I’ve had to revert back to 2.1.0 for the time being.

Is this being looked at? The platter is still able to be manipulated but the cue, hot cue and play buttons are all disabled. You also can’t load a new track because the player thinks the existing one is still playing, only a reboot will work.

Sorry to hear of the trouble @STU-C.

Are you saying your decks only freeze in versions later than 2.1.0 but goes away if you are in 2.1.0 or earlier?

When you say freeze, is it behaving like the platter touch is always being detected? Similar to how it would behave with a hand in the platter.

Have you contacted technical support? I ask because I get the feeling the issue may be hardware or environment related.

I just installed 2.3.1 and now my Engine won’t load.

I have tried repairing the install and reinstalling.

I keep getting this error. I am using Windows 8.1.


Wow, I love how 2.3.1 just practically bricked my Prime 2. Great job Engine DJ devs… Awesome… :roll_eyes:

So we used to be able to scrub/search through tracks with shift/beatjump. This is no longer possible. Is ther a new key combination?

It’s worth mentioning that Engine DJ isn’t supported for Windows 8.1 anymore. Therefore the OS is no longer tested.

Hey @Tristyn Sorry to hear that, have you tried updating again? If you provide a little more info the community can often help to resolve these issues. And failing that you could contact technical support for further assistance.


Thanks guys for working so quickly to address these issues! We DO appreciate it!

1 Like


The only problem I had with version 2.3.0 was the irregular movement of the audio waveform. With this new version 2.3.1 the problem still persist. The movement is not continuous or steady.

Had to downgrade to ver. 2.2.2 on my Prime Go

1 Like

@Edgar_Espinal See this comment from another topic

1 Like


I haven’t contacted them, basically during a couple of gigs recently (one on 2.2.0 and one on 2.3.0) there was a situation whereby the left deck locked up, you could scratch the platter but couldn’t select play or cue. The only way to resolve was a reboot which was embarrassing in both scenarios (At the venue).

It only did it once each time and the rest of the 4hr set was flawless, which makes it even weirder. Different tracks each time too and definitely not corrupt.

One thing that was consistent, I do a lot of beat matching so usually both decks are constantly playing… but on both occasions here I was just basic mixing so the track was stopped at the first cue point waiting to go, almost like not having it moving created the issue.

I only went back to 2.1.0 because I’ve played loads of gigs on that and never had it happen. I’ve since done a gig on it with no issue.

Bang on it with another quick fix! Much appreciated :ok_hand:

Being able to view playlists in folders and correction of the beat grid issue, where the cue point won’t set from start of track unless quantize is off… This would be brilliant! in a future update please guys :crossed_fingers:

I have reverted back to 2.3.0 on desktop but will my Engine USB work with 2.3.1 if I update?

Yes, all 2.x database versions should be compatible. But if you have had any database issues it’s best to have the same version for desktop and hardware.

Hello . I am having some issues updating my prime 4 to the latest version witch is the 2.3.1 . Currently I’m using the 2.2.2 . I’ve tried updating the prime 4 by using the wi-fi as usual and by pc with the usb cable, nothing worked. In order to be updated the console must update the mixer , right display and left display right ? My prime start updating the mixer and after the update is done , it shuts down without rebooting. I’m turning in back on but it Stucks ( freezes) black screen with the engine prime logo for a few seconds ( in the right corner appears the 2.3.1 version ) and without touching any button, it shuts down automatically by itself. No sd, ssd, stick plugged in, tried updating, downgrading it and nothing worked. I have no idea what could be the problem. :man_shrugging:t2:

Shift + Skip :next_track_button: :previous_track_button:

Similar behavior on my Prime 4 over LAN. Update from 2.3. to 2.3.1 is not possible. Download and install process starts as usual but doesn’t reboot or the update message appears again. Tried 3 times. But 2.3.1 will not be recognized. The incompatible drive message is back again too.

Ok … I understand but after a week I still have no answer for my Problem and I’m still using my prime 4 with 2.2.2 software instead of using it with 2.3.1 :man_facepalming:t2:

Hi, does this version of engine support the MCX8000 controller? I recently installed a newer (not sure if this one though) version to find that it doesn’t support the MCX8000 so had to downgrade the engine software to an older version, running Windows 10.