Some tracks won't add to playlist

I recently trashed my entire Engine Prime library and started over from scratch.

Last night I was trying to create a new playlist in Engine Prime 1.2.2 on Windows. When click-dragging from my collection into a new playlist, some of the tracks that I tried to add to the playlist were not being added - the number of tracks in the playlist did not increase. Engine Prime doesn’t report that there’s a problem, it just doesn’t add the track.

I tried to narrow the problem down to a specific format (my music is a mixture of FLAC and WAV) or a specific disk on my PC, but there didn’t seem to be a pattern. Even some tracks from the same album would behave differently - some could be added to the playlist, while other tracks could not.

One possible pattern was tracks that had been part of a playlist before I trashed my library seemed to be the ones that now cannot be added.

Anyone else experienced this? It’s very frustrating!

1 Like

Were any of the tracks touched by non-Denon written software ? Like re-taggers or conversion ? Did some have cue points from other DJ software formats eg: traktor cues, Rekordbox loops and so on?

No - all of the tracks I tried have only ever been imported into Engine Prime.

I copied some of the files over to my Macbook and I could add them to a playlist using Engine Prime 1.2.3 on macOS, so the problem seems to be with Engine Prime on Windows, rather than the audio files.

This had happened to me on Mac a few times. The last time it happened I was trying to drag and drop a history playlist from a USB drive to the main library. I selected all 73 songs on the list but only 68 transfered. The 5 that didnt transfer were fairly new additions to the library. I was able to to select the 5 that didnt transfer and copy them over in a seperate select/drag action.

I was trying to move the tracks one at a time.

What’s weird is if I plug in my USB drive, and use Engine Prime to create the playlist on the USB drive then I can add the tracks without any problem! That’s my workaround for the moment.

I have the same problem. About half the tracks does in my latest crate does not export. (The crate it self didn’t export either, I had to manually create a new one on my drive) The same happens when I try to export it as a playlist as well. Seems like I can select and export one track at the time, but this takes a lot of time.

I answered this topic here Serato Crates Not Correct as I go through that experience

I too am having problems I can’t batch drop songs onto my crate I am having to one track at a time

1 Like

I noticed this last week when I finally decided to use crates. (I’ve only used playlists up to now) I created basic crates by genre in EP and when trying to copy them to my external for use on my SC5000’s not all tracks would transfer when batch dragged. The process of figuring out which becomes even more difficult when EP sees the copy on the external and the copy in the database as separate and doubles the track count of the database. Stoopid.

Thank you all for your feedback - I’ve read each comment and passed back to the dev team.


I have the same problem on Mac ver: 1.2.3. Its a random thing, some tracks, won’t add to playlist. and when I select all songs in a crate and drag them into a playlist, it fails to add them to the playlist.

I have the same problem, I have mearly 95K songs and it transfered just 26K, it’s very frustrating

Hi, I have the exact same problem with a playlist imported from Rekordbox with Engine Prime 1.5.0 on MacOS 10.12.6

  • when importing the playlist as a playlist tracks are added until a track that won’t add to the playlist. All tracks are correctly added to my collection. Trying to import the track manually from my collection to the playlist also fails

  • when playing the track from the collection it plays correctly

  • when right clicking on the track in the collection, everything is greyd-out, except “Show in Finder”

  • when importing the playlist as a crate all tracks are added to the crate

@Jay_DenonDJ did you get any update on this one. I’m happy to provide more details if needed. I couldn’t find the application logs :disappointed_relieved:

Every track needs to be in a crate first, then playlists can be made/imported , at least, that’s how it seems to me.

Only tracks in crates can be included in playlists - at least, that’s the rule that I go by and it seems to work for me

That isn’t my experience. You can use both almost interchangeably.

Tracks can go direct from collection or folder to crates or playlist

There are differences between Playlists and Crates though…listed some here

Hi thanks for your replies.

I think that the issue was really linked to the files themselves, something was preventing me from adding them to playlists.

I’ve ended up converting to another format and I was able to import them directly to the playlists (without adding them to a crate first).

1 Like

What was the file format that you had to convert out of ?

I went from AIFF to WAV.

What’s weird is that the AIFF file were playing fine when playing them from the collection. So maybe it was linked to their metadata / potentially failed analysis.

As said previously the UI prevented me to do anything on these files while when right clicking on them (except showing them in the finder). Perhaps, Engine Prime prevents you to add a song to playlists when something goes wrong during analysis.