Prime Go 1.6 Firmware Update Failed - Device Now Unresponsive

After a failed attempt to upgrade firmware from version 1.5 to 1.6, my Engine Prime GO is stuck on the firmware update screen. I cannot get my unit to boot or respond. During start-up it displays version 1.6 then displays the firmware update screen. Image below.

When I connect my Mac via USB, the Update software says a Prime GO is not detected. A screenshot of the Mac Software is linked below.

Steps that produced this state:

  1. I attempted to update Prime Go from 1.5 to 1.6 firmware using the Mac Updater software. The update proceed through steps 1 of 3 and 2 of 3 then began step 3 of 3.
  2. During step 3 of the update process, my Mac screen went to sleep, when I touched to wake it up, a message appeared saying the firmware update had failed.
  3. I rebooted my Prime Go and tried to start the process again. It boots to a screen that looks like the firmware update mode, but my mac update software will not detect the Prime Go.
  4. I also downloaded the 1.6 update to USB and tried the USB update process, but in its current state, the Prime Go is not recognizing anything.

I have reviewed several threads about Prime 4’s failing to upgrade and getting “bricked”. I can’t find a clear explanation of how to revert to a previous version or how to manually factory re-set my device when the OS won’t even boot up.

I have a private outdoor performance this weekend; so, I am pretty upset about this.

Thread’s I’ve read:

  1. Updateing Firmware for Prime Go
  2. Firmware update 1.5.1 bricked prime 4 - I can’t find the threads @Julianus refers to in the solution.
  3. After update to 1.6.0 Prime4 ENGINE will hang on ENGINE OS screen and not boot completely

@NoiseRiser @Reese

How to force firmware update mode?

@DJ.Thumper there is a button combo that will force the unit into the USB firmware update mode. I don’t know what it is, but hoping either of those folks I tagged do.

Hang in there

Connect the power adapter and press the ON button while holding LOAD > and LOAD < buttons. You will see the update screen


DJ Thumper, Ethan Allen here started the 3rd listing you referenced. After update to 1.6.0 Prime4 ENGINE will hang on ENGINE OS screen and not boot completely

So, I have a Prime 4 and how I was able to get my Prime 4 in to update mode is: after trying 3 - 4 times to push power button - starts Prime 4 and gets stuck on Engine OS screen. I would HOLD power button down until the machine turned off. Wait 1 minute and then power on again. Finally, it would start properly. I then would attach my computer to the Prime 4 - then put the Prime4 in to update mode. Then choose the v. 1.5.2 file and roll back the v. 1.6 update. I have done this twice and it worked both times. I have Engine OS 1.5.2 mac version if needed. Sorry, no windows version. Hope this gives some resolve. It may take a few more than 3 tries to have it properly loa properly. I think the key is NOT to have your computer connected when initially trying to boot up the machine.

1 Like