Open Source Sync Tool for macOS Ventura

Hi there,

I was too dumb to look at the EngineDJ website before upgrading to macOS 13 (Ventura) and bricked the internal SSD of my SC6000 while trying to sync some new music (the application works as usual until you try to sync) and don’t want to wait or transfer my library to another machine.

So I wrote a small golang tool that syncs my library (using the library backup engineDJ created) including soundswitch on macOS Ventura.

The tool works by showing a UI that has buttons for selecting the a Engine Library Backup folder, optionally also a SoundSwitch project folder, and of course the target drive/folder to sync to.

When “start sync” is clicked, the application first creates necessary folders at the target location, copies the soundswitch project, all the engine database files and finally reads the copied database to copy all the files that are mentioned in it and then chaning the paths to what the are in the target location (it just puts everything in one directory for now).

Please note that I only have tested it on arm64 (M1) hardware, but there is a build for amd64 as well and you might be able to compile it yourself for other architectures (as well as windows or linux :blush:) if you ever see the need to.

Also keep in mind that this is not a replacement for Engine Desktop! You’ll still need to manage your library there first, then create a backup using the Engine Desktop preferences, and finally use the tool to sync.

You can find the project on GitHub:

Click on the release version to download prebuilt binaries that can be launched using alt+open (I don’t have a valid developer certificate :pensive:).

Make sure to read the README and the disclaimers in it before using the software. I created it as an emergency solution, and it can’t do the same as EngineDJ Desktop.

I hope someone finds this useful.


Nice :grinning: Short question:

There are two Versions to download: arm and amd- what is the difference?

Arm64 is the architecture of the M1/M2 chips, while amd64 is the architecture for the Intel CPUs :slight_smile:

1 Like

Hi again,

another update is out, concerning the issues raised in this thread:

You can download the latest version here:

1 Like

Hi Lerk, if I want to sync again after a sync, will the old data just be overwritten and do I have to delete it first? Otherwise great work!

Hi, it should just get overwritten, unless you delete tracks or have a library on the drive that was not made with the application.

In those cases you will have leftover files that waste space but are not in the database (you should still be able to play them using the file menu though).

1 Like

After intensive use, I have unfortunately found that the synchronization is not 100% reliable for me.

About 20% of my tracks show up as “RED” on my SC Live 4 even though the tracks are all there.

I don’t have the problem in Engine Desktop. No red entries, all tracks can be played.

The “red” traces are physically present on the stick

I already checked the tracks for errors with 3Vise - all fine.

I tried both sync options - with and without the “missing tracks” tick

USB stick (Sandisk Extreme Pro) reformatted

unfortunately it did nothing

Do you have an idea/solution?

Many Thanks

I want to reinstall the program (Intel Mac).

Does your program write entries to the Mac system library, or is it just deleted and reinstalled?

I have now completely deleted and reinstalled engineDJ with all databases and re-read all tracks.

Everything is fine in the Engine Desktop Software. No red marks.

Unfortunately, about 20% of the tracks (out of 6,000) are RED again in the player.

All tracks are physically on the stick

New addition:

I once manually copied some of the “red” tracks to another USB stick.

These are recognized in the player’s folder view and can be played back without any problems.

So it’s not because of bad files.

Somehow the tool seems to have an error in the database assignment - my guess - I’m not a programmer

I hope this helps

1 Like

Hi, thanks for the feedback.

The application only writes to the specified target folder and modifies nothing else on your system. There is no way to uninstall it, since it’s not installed in the first place, simply delete it to get rid of it.

Would you be willing to send me the exported Database2 folder and maybe one or two of the broken song files as a zip archive via DM just so I can check what kind of corruption we got?

It could also be caused by m.db not being the only database I have to modify, there are a few databases in the library folder, but only two of those had entries and only one of them had valid paths in my case.

Hey Lerk,

Thanks for continuing to update this tool! I’m still getting the directory resolution error on 1.2.0. I’m gonna try to take a look at it this evening, but if you have any ideas where to start in the code, let me know. Or if there’s anything I can send to help diagnose the issue.

Maybe my Engine library is just hosed. Wouldn’t be the first time. ¯_(ツ)_/¯

I swear, the quality of Denon’s software. I’m gonna switch to Pioneer gear as soon as I can. (I know rekordbox isn’t great either…)

I added some log lines to see what the incorrect values were. Here’s what I got:

baseDir: /Users/toph/Music/Engine Library Backup/Database2
src: /Users/toph/Music/Engine Library Backup/trm.db
dstDir: /Volumes/Hi-Voltage/Engine Library/Database2

[Edit] I was able to get it to sync successfully by deleting the outer set of database files, the ones outside Database2. (I did delete `Database2 and re-upgrade at one point during this process too, so I’ve definitely lost some cue points and tempo corrections in there.)

1 Like

It’s about time that Denon finally releases the Ventura update!

How long do they need?

The Ventura beta’s have been available for testing for a long time

Even if there was always a warning about updating to Ventura - what do the customers who have updated their Mac to Ventura before the release of SC 2/4 Live??

They can’t use their device!

1 Like

As far as I understand this is not an issue with Denon/EngineDJ, it’s a bug in QT (the GUI library they use) and it has to be fixed there, there’s nothing Denon can do (except maybe contribute to QT, no idea if they do).

Ah yes, I thought it would be a good idea to keep the directory structure in the exported drive, worked for me but caused a lot of issues for others, sorry for that.

I’m currently working on an additional checkbox that brings back the behavior from v1.0.1 (put everything into the Music folder, without subfolders).

ps: I just wish they’d own up to their not so great software quality and let the community help with that. I really like my Denon hardware, but the software issues annoy me. I’d really like to try to fix them and since the SC6000 seems to be just another ARM Linux box, I probably could if I had access to the flash tools and source code.

1 Like

Hi again,

I just updated the tool to have a toggle for keeping the directory structure on the target drive.

You can find the latest version on the release page:


Just tried it with an Intel I7 MacBook Air.

The synchronization cannot be started!

Whenever I press “start sync” the cursor jumps to the field and puts the blue tick next to “Keep directory structure”

Any idea ?

1 Like

That happened for me too, I hoped it was because I was debugging.

It seems that the position of the cursor is off by a few pixels in the Y axis (top/bottom). I’ll try to fix that but in the meantime you can try to focus on the hover effects off the buttons, a click will trigger the button/checkbox if that “highlighted” effect is visible.

If I do NOT want to take over the complete directory structure - is there something different in practice in 1.30 or is it the same as in 1.01?

Any advantages in the 1.30?

1 Like

v1.0.1 has no working SoundSwitch support. The files are copied but to a subfolder named like the project dir, while the player expects the project folder contents to be put into the “SoundSwitch” folder.

If you don’t use SoundSwitch, you can keep on using v1.0.1 as long as it works for you.

I have released an update that fixes the cursor offset issue (at least on my machine):

1 Like

I think the files are missing…

1 Like

You’re right, sorry for that :see_no_evil:

1 Like

Hi mate, it’s just me or when i open the folder and click on Alt + open nothing happen? Am i missing anything?