MacOs Ventura

Any word on when we may have compatibility with MacOS Ventura?


FYI. Error on all attached drives. Error is [Drive-Name] is incompatible with Engine OS device. Reformat the drive to exFAT or FAT32 to use. This is irrespective of the fact that the attached drive IS formatted with either filesystem type.

1 Like

Other than not being able to sync, everything else seems to be working OK :slight_smile:


I have the same problem, I hope its sorted out very soon!

On the first page of release notes for Ventura, this notice was made

However, this change does seem to have a fair few app developers out, so it looks as if Apple may have changed something that people weren’t expecting. I can’t find the exact change right now.

1 Like

Hey Thanks for the Info , is any solution for this problem there?

That wouldn’t be the first time Apple just went ripping through things without any consideration to the end user, or backward compatibility.

1 Like

Did a bit of further digging around. Looks as if they use as a cross platform tool to write the app. If this is the case, then it may be that they need qt to update their platform (if they haven’t already) before they can write a fix for us poor end-users. Bit more bad news, as of today, DOES NOT support MacOS 13 (Ventura) - see Qt for macOS | Qt 6.4 , so us poor Mac users could be SOL for a little while yet.

1 Like

If you happen to have a bricked library and can’t DJ right now (like me until a few minutes ago), this tool I made might be helpful to you:

Please read the instructions and disclaimers carefully as it is only an emergency solution!


When to expect compatibility with ventura?

1 Like

We need the Ventura Update quickly please- sync to USB Sticks is not possible now- how to use my new SC4 live with Ventura if I can’t transfer Tracks to the medium??

1 Like

When the release is announced. I don’t have any further information

see the link I posted above, the application can do exactly that (and only that, lol)

1 Like

Tried the tool for sync- runs fine. For the moment it‘s Ok. Hope we get the update soon

Thanks for the tip :+1:t3:

1 Like

It worked for me. Great work-around. Thank you.

Thanks for making the work around tool! I’m getting an error message and the transfer won’t complete.

open/Users/…(file path).mp3: no such file or directory

Any suggestions or fixes?

Thanks in advance for any help you can provide.

1 Like

I resolved this error by editing the code so that it skips the missing files instead of erroring out and then I recompiled the app. You can open an issue at the author’s Github page and I’ll try to submit a Pull Request the coming days, if he doesn’t have time for it.


I was able to work through the “no such file or directory” error by deleting all the missing tracks (red files) from my Collection. It took many, many tries. But as I kept trying to run the program, the error would tell me where the missing file was, then I would go and remove the problem (missing / red) files, I eventually removed all the missing files and the program was able to run successfully, without any errors.

Thanks again for making this tool! Much appreciated :slight_smile:

1 Like