Engine Prime doesn't add tracks to playlist

This started happening yesterday just out of the blue. The last time I used Engine it was working without any problems. For some strange reason, Engine wont add any music to new playlists I create (or old ones for that matter). It allows me create a playlist by manually clicking the + button, not by the usual drag & drop folder that I normally use. Once the playlist is created, if I try to drag & drop any files into that playlist nothing happens, the playlist remain empty. I decided toi try this on another mac & I had the same problem. I tried a different drive too, but the same thing happened again. Im soo confused as to what is going on. Any help will be appreciated.

  1. Check that you have given Engine Read and write access + permissions etc

  2. If that fails, a database rebuild may be needed

2 Likes

Thanks for the info. I was just looking to see what permissions the drive has. Strangely I see it says “you have custom access”… What is that? & how do I change it?

Sorry I think I misread. I thought you were talking about read & write permissions on the drive. How can I check Engine’s read & write permission?

That’s an example

2 Likes

Thanks for the link. I checked it, but Engine already had full disk access. I’ve now uninstalled & re-installed, but its still the same. Engine just refuses to put any music into the playlists that I create. It’s driving me nuts!!

Is there anyone else that might have an idea what I can do to get this working again? It’s driving my crazy!! I need to have this working by the weekend for my regular gigs. Any assistance will really be appreciated.

hello, I have same issue. I can’t make update to new Engine DJ because I have MacBook late 2011. someone can confirm if I will have new version this problem will be solved?

Im not so sure that this is related to the macbook though. I have 2 macs. An older 2010 i7 & a 2013 retina i7. This has suddenly started happening on both of them. I almost feel like it’s related to a setting on the drives, but I can’t figure out what it is. Both my external drives say I have “custom access” - but I don’t have a clue if thats good or bad.

I was ready to go buy new MacBook… but I think this is not a problem. something happened at some point and nooo idea why and what. sure same was with you that all was working and exporting playlist was not a problem suddenly I can’t export this what I create.

Perhaps try checking the permissions of the drives affected. Maybe it has something to do with “custom access” like mine?

Did you try with a new database?

Not yet. I’ve been trying to avoid that coz my library is really massive. Thanks for the linked example. I’ll try rename the Engine Library & see what happens. Thanks for the suggestion.

@mufasa So I tried as you suggested, renamed my Engine Library folder to Engine Library - old. Opened up Engine - exactly the same thing. I can add tracks to the collection, but it wont allow me to add any tracks to the drive. I thought it might have something to do with the drive saying I have “custom access” . However Rekordox can create playlists on this drive without any problems. Im also able make a new folder on the drive, so I don’t think it’s a permissions thing. I just dont know what to do anymore. 2 out of my 3 drives are doing this. The 3rd one, Im still able to create playlist on. Im soooooo confused.

@Logan Please can you get a member of staff to assist with this issue please. 2 weeks & no staff have tried to help at all.

  1. Did you try reformatting the non-working usb stick eg if it was Fat32 try reformatting to ExFat of vice versa

  2. If one usb works then one should be able to figure out why the other 2 are not

@mufasa Thanks for all your help here. I haven’t done any reformatting as it’s not really an option for me. The 2 backup drives that are suddenly not working properly with EP, are also my 2 drives that I use on my regular Saturday gigs where I play on cdj’s. So they are basically my rekordbox drives as well (they still work perfectly fine with Rkbx). So I can’t be deleting & reformatting these drives just because EP suddenly doesn’t populate my playlists. There has to be another reason why this is happening. I have noticed a couple of other people on FB also complaining about the same issue, where out of the blue, EP just refuses put music into playlists. I really do appreciate your help here, but I honestly feel like someone from Denon needs to officially look into this.

1 Like

Hey @crazycraig, thanks for tagging me. I’m not sure that I’m the best person to help, have you tried to contact support about the issue? They have a live chat feature where you should be able to talk to someone during office hours EST. This is the link to use to get in touch. They should be able to guide you through some troubleshooting steps and get things up and running for you!

1 Like

@Logan Thanks for the Link. I haven’t tried support yet (dunno why I didn’t think of that 1st :man_facepalming:). I’ll try that right now. Much appreciated. :facepunch:

2 Likes

Hi @crazycraig did you hear back from support? I’ve just moved over to a Mac and I’m experiencing the same issues. The tracks are in the collection but it won’t let me add it to a playlist. Have you tried to export to a USB/SD card? If so has the new music show up on it?

Thanks mate!