Denon prime 4 left jog wheel issues

Hi hello ive a problem with my prime 4 left fog wheel,i just purchased it and upon inboxing and testing the left jog wheel doesnt work at all.

I upload a video in case someone could help me pls

Hi @Dean, welcome to the forum.

I think you mean the right jog does not work?!

What happen is strange indeed.

Is the unit brand new? Did you take off the protective plastic that came on the jog wheel, mine seemed unresponsive then I realised I hadn’t taken that off.

My thought also, but I don’t see them in the video. @Dean, you should see a blue-ish peel-off, if I remember correctly. On an SC, it’s more obvious, as the peel-off has a red label.

Also don’t touch the platters when powering on. It will do a calibration.

Hi yes i did remove the plastic and yes the unit is brand new i unboxed it and this issue happen.

Okay. If the unit is properly grounded and still doesn’t work, you should contact the reseller.

Another option is, but I would go the reseller way as it is a new unit.

1 Like

This could potentially work:

  • Press and hold the VIEW button to access MENU
  • Click UTILITY
  • Click CALIBRATE (and do not touch platters untill calibration is complete (about 3 seconds).

If calibration does not work then check grounding as mentioned before (maybe different power cable, different power outlet). Or else contact reseller or support. Good luck

Hey what’s up Dean, Did you ever figure out what was wrong with it?? Mine just did the exact same thing with the same Jogwheel. It’s frustrating as i’ve been using mine great for a week or two but now it just started doing that today.

Well mine is still doing it but weve locate the issue its a software issue,the software gets corrupt and thus this create the problem. Im still tryingto find solution denon support hasnt reply me at all regarding this eventhough ive sent them email 2 times.

1 Like

Interesting, I figured it would definitely be software related. I wonder if it’s possible to reinstall the older OS and then see if that would fix the problem? It’s crazy how i have the same exact problem on the same side too. haha I also tried contacting Denon via email and have yet to hear anything back. That’s pretty sad as I always thought denon would have better customer service. Maybe we should try contacting technical support via telephone? Have you tried that? Keep me updated. It’s frustrating but i can still dj on it but it’s kind of an inconvenience. : /

There is Covid19 ya know.

You can tag a mod here

Hey any luck on urs im still waiting on support but nothing im really frustrated even if its covid at least a simple email could be enough.

Hey there.

I’m facing the exact same issue with my brand new Prime 4. Engine OS 1.5.2. Unable to scratch in Vinyl mode on the left platter. Right one works perfectly.

I noticed that the left one also works when I touch the Prime 4 with one hand while scratching with the other one. It also works when I touch the grounding terminal on the back. So it seems to be a grounding issue and therefore hardware related? But why is the right platter not affected?

BTW I’m using my Prime 4 in a Magma flight case.

Did you guys get the issue solved?

Thanks for a feedback!

Same problem for me on the right side :weary::weary::weary:

Hi guys - I have just uploaded the same issue I’m having with my new prime 4. Unboxed yesterday - version 5 firmware and the right hand platter won’t scratch. Left hand side is fine.

Installed the older version 4 firmware and it’s totally fine?

So, have since discovered that the scratch feature only works on the right hand side IF you are touching the unit with your other hand. Clearly a grounding issue with the right hand unit of some sorts.

This is not good - earthing in my home is perfect. New build and I am an electrician - socket tester verifies earth.

I’ve uploaded it to YouTube - can see it here;

This is what I also tried and recognized. With Engine OS 1.5.1, 1.5.2 and 1.6 beta no scratching possible on right jogwheel. Going back to OS 1.4.1 it works perfectly but I recognized other bugs like stuttering while plackback on deck 2/4 instead. :cry:

@Dean: Did you find a solution with Denon DJ Support meanwhile?

I contacted my reseller and they asked me to return the Prime 4 in order to get it fixed by Denon DJ, but I’m not sure if it is a real hardware failure and worth sending it back or a bug which could simply be fixed by an OS update. It’s frustrating… :thinking: :face_with_raised_eyebrow:

Yes with version 4 I was noticing bugs too like the track skipping too far when trying to nudge with the side of the jog wheel and skipping on its own.

I don’t know if I want it fixed - it’s brand new! But if they give me a brand new one won’t it do the same??

I don’t know, in Germany and I guess in Europe in general the supplier has the right to choose how to handle claimed products. They can repair or replace it. Yeah, you’re right, mine is one month old and I also would expect them to send a new one.

I also doubt if a new one wouldn’t be faulty either. But then I would also expect more Prime 4 owners to claim this specific bug, not only a few ones. If it is OS caused, every single owner should have the same problem, right?

I guess you’re right - but, the issue blows my mind as to why it only does it with the new firmware. If you watch my video it looks to be a completely physical problem in that it only works when it’s getting an earth through your other hand.