Denon prime 4 left jog wheel issues

That’s exactly what I described in my upper post. Maybe Denon DJ knows about the grounding issue (hardware) and created a workaround with the OS and forgot to implement from 1.5 on! :sweat_smile:

1 Like

BTW, how old is yours? Did the shipping (outer) box have a small green dot (label) on it?

Mine is brand new in that it only arrived yesterday. There was no outer box - it came wrapped in a bag. Bought it from getinthemix. Where was yours from?

I had this same issue with my Prime 2… Things seemed ok on 1.4 but after the update things went bad on my left jog wheel in vinyl mode… the platter would randomly simulate me holding my hand on it by itself… impossible to scratch… and as time went on (turning vinyl mode off on the left) I’d be scratching the right side, if I get to carried away into my scratching routines, I’d gain the same problem on my right deck… I’d then be stuck only cuing in songs with the cue pads… I hate that!!! I’m so disappointed… I contacted support… they asked I send the controller back (saying they will replace it… I had it 1 1/2 months before I had the issue… dealt with it for another month and I had to continue calling in for support and got no help the first three weeks… finally I’ll be able to send it in but they specifically let me know…

Pending availability of parts, our repair facility’s turnaround time is currently 2 to 4 weeks (not including shipping time). Within this turnaround time, status or progress updates are not available. However, if the turnaround time, and time necessary for return shipping to you has passed, and you haven’t yet received your product, please contact us at<

so I’m just sitting here waiting and Djing my gigs on a Numark DJ2Go touch until then…

I bought this controller to replace my DDJ-SX2 that I had for 4+ years and now I’m feeling like I should have spent my money elsewhere… My performance has suffered a bit due to not having all the functionality of a professional controller… I tried to give Denon a chance because on paper the specs and features really impressed me… but paying more than $1,000 to have a controller fail me not 6 months later hurts my feelings and pockets… I can’t show up to a wedding with a mini controller… I have to hide it when I’m working my clubs and bars as it is…

Be aware of this issue before updating to 1.5 or even going to this product if you haven’t purchased it already…

1 Like

My unit is being picked up tomorrow by UPS and refund issued once it’s received. Sorry Denon, I really had high hopes for you but it’s destroyed my confidence. Back to Pioneer me me. Shame, as it’s a cracking package

@dave-b I’m sorry to hear that. DDJ-SX2 is no option for me as I prefer a real standalone 4 channel unit.

@JWiLL Can you confirm that Denon DJ is aware of these issues? Will the official release of Engine OS 1.6 address this bug or is it a hardware failure which needs to be repaired by Denon DJ support? I would highly appreciate a feedback by a Denon official? Thank you!

@coffeebean - I know what you mean. The XDJ-XZ could have been an option but you need additional external units to use it as a 4 channel - very disappointing. If I had the cash I’d go for their new CDJ 3000 as they look very tasty. But, I’m only a ‘bedroom DJ’ so can’t justify it. I have heard that they might be coming out with a new standalone unit later in the year that will be based on the CDJ3000 so might hold out for that

Hi all, i just unpacked my Prime 4 today, and indeed the left jogwheel is not responding. Only when I put my full hand over it, it stops and I can find a cue point like on vinyl. I hope I don’t have to send it back and that it can be fixed with software… look forward to response of Denon staff. @DenonDJ_Support_DE

@Sbroest to summarize possible solutions

  1. Remove plastic protection film

  2. Check grounding of the unit. Try a different power cord and other grounded power outlet

  3. This could potentially work:

  • Press and hold the VIEW button to access MENU
  • Click UTILITY
  • Click CALIBRATE (and do not touch platters untill calibration is complete (about 3 seconds).
  1. Try install firmware again (or even one from the archive)

  2. Contact reseller or support

Thanks, changing grounding and removing plastic works, although still less response than right platter. But it works. Can the connection of two turntables (incl grounding) also have an effect on it (related to grounding)?

Thanks for the quick response, Stephan

The protection films have to be removed but are not the reason for this issue.

Did you try Engine OS 1.4? I guess this will work but causes other issues.

Where did you buy your unit in Germany? Maybe our units are from the same production batch.

It’s quite sade that Denon staff is not responding to this topic as it seems to be a wide spread fault.

1 Like

Did anybody got this problem solved? Engine OS 1.6 didn’t make it. :cry:

Wondering why this topic has gotten so quiet and none of the officials from Denon DJ support responds to it? I’m getting more and more unsatisfied with my first Denon DJ gear!!! @DenonDJ_Support_DE & @JWiLL What’s up, guys? This is no open failure culture and doesn’t strengthen customers’ trust in Denon DJ and their innovative gear…

1 Like

interesting, I am having the same issue with mine that i just ordered a month ago. Im interested to see if there is any comment back from Denon about this anytime soon as venues are starting to open back up and things will start getting busy.

Hi, had anyone found a solution, please? I have had the same issue on and off since I bought my controller a few months ago. It was working fine for a month and yesterday it started happening again. A complete nightmare as I use it to DJ at a bar and have to use a numark mini controller as a backup which totally defeats the reason why I bought a standalone deck in the first place.

What’s going on with these units? I just got my Prime 2 and the right jog does not display any information and does not show up in the menu. The plastic is off, firmware updated. And everything else on the unit works. The jog does respond to touch etc. it just does not display any information, not even the Denon logo. It stays lit with the default circle of lines.

Heeeeeeelp denon, do you even care about it? They just couldn’t care less

Same problem, nothing help(