Cannot Update SC5000

Hello, all.

I have four SC5000s. I have updated them once before using the PC method. This one particular player is having issues. I have uploaded the image showing what it is doing. I have done what the links below have suggested. Nothing has worked. The good news is that will boot back up, but now I have three players running 1.4 and this one stuck at 1.3.1. The other three were updated this time using the USB option and had no issues. This one attempts the update but flashes back to 1.3.1 suggesting the USB update option failed and failed safe back to the current version. This player also has had issues in the past where the platter would stop functioning correctly (a reboot fixes the issue), and on numerous occasions has stayed stuck after the power button was pushed and requires the power plug removed to the unit to power completely off (replacing power and turning it back on results normal operation). Unless there is something that these other three links have not offered as a way to update this player and based on its past history, I am pretty certain that a RMA is required. Will someone give me some new advice that has not already been offered or please provide the best way to RMA and get a replacement player. Thank you in advance. Cheers!


Bump to the top because this is an issue I want solved before I directly to support.

USB drive method instead of cable didn’t work also?

No, and that is stated in the original write-up. When attempting the USB method, it appears to try to start the update but appears to restart showing the current version running indicating the update failed. This same USB drive was used on three other players running the same version as this one player that is having all the difficulties.

Thank you for your reply!



Continuing the discussion