My sc5000M doesn't want to reboot in firmware updade mode

I try to update my SC5000M to v1.3.1 so I click on “Updade Firmware → Reboot”, then it shuts down but it doesn’t reboot.

What am I doing wrong ???

Is there a procedure to factory reset the unit ?


Hi @Djkom, there are 2 ways to update the player:

NB: Firstly make sure you have downloaded the SC5000M update as the SC5000 one will not work.

  • Download either the USB option or the App
  • If you download the USB follow the instructions to add the correct file to a USB drive to put into the SC500M before you select REBOOT.
  • If you download the APP, connect the player to your laptop via USB cable provided and the APP wil walk you through the steps.

Keep us posted how you get on.

Thanks @Jay_DenonDJ for your reactivity :wink:

1 Like

No problem, the update brings some amazing new features!

@Djkom did you manage to update you unit?

@JWiLL Yes, I’ve used the usb key method.

But still cannot use the computer method. When I click on “Updade Firmware -> Reboot” the unit only shuts down. Also noticed there is still the “UPDATE AVAILABLE” next to the 1.3.1 68d40761 version number instead of “CHECK FOR UPDATES” like in my 2nd unit updated my mac.

I only ever use the USB thumb drive method with the img file to update the players, as I have Windows 7. You go into the preferences at the bottom and it says something like reboot to firmware updater and will tell you it’s found the img file on the drive. Denon DJ is now naming the img files correctly, so a lot less work. You just need to download the correct package for it.

[Moving to general area as this is not a bug]

I’m sorry @JWiLL, but it is a bug ! I still cannot update one of my deck with the computer and the usb cable, I have to do it only this a usb key. Since I cannot hard reset the deck, I will never be able to update it the my macbook ! I hope I will not have issues when I will use it in controller mode or through wifi.

Hi @Djkom, I think we have a different understanding of what a “bug” is but that is ok. Let’s see if we can figure out why you’re unable to update you SC media player via computer.

  1. On your SC media player hold the VIEW button for 2 sec to open the Utility.
  2. Swipe down to the bottom of the menu where it says Update Firmware.
  3. Tap Reboot.
  4. You will see the message “Reboot into firmware update mode?”, tap YES.
  5. The media player will restart into Firmware Update Mode and the display should look like below.
  6. Connect the USB cable to SC media player and the other end to your computer.
  7. Download the latest Firmware update file for computer updating. These will have (Mac) or (Windows) in their file name.
  8. Unzip and run the update application.
  9. Click the green update button. 14
  10. The update process will start and the device will reset once the update has completed.

Let me know which step you’re getting stuck on.

Hi @JWiLL ,

I confirm the deck doesn’t reboot after I tap Reboot

Here is the video of the deck having the issue:

And the video of the deck having no issue:

Hi @Djkom,

The video link says I need permission to access. Can you send new link?

@JWiLL permissions updated :wink:

Apart from the reboot problem, both units are already up2date.

Thanks! I was able to review the video. That is odd behavior. The unit should reboot into update mode but it clearly is not. I doubt that will affect the performance of the unit but still not working as expected. I’ll shoot you a PM now to collect some info so we can get you a replacement unit.

Hi guys…HELP! I have two sc5000m’s, bought a week ago. I’ve decided to update the firmware to 1.3.2 and now i have no decks. For the first deck i went via my macbook, it went alright with the firmare but now it’s stuck on the motor udate and it keeps rebooting to “updating sc5000m motor to 04.04” then back to home screen wich displays the firmware update 1.3.2. Second deck, i said i’ll go via an SD card, press reboot to update and it shows the download icon but nothing happens .

Is there any way out of this or return the whole lot?

Have you tried putting the IMG-file on a USB drive and update with that?

Press and hold eject while powering on or via utility > reboot.

What’s the current firmware version? Perhaps it was very old stock and then the leap would be to great.

Thanks for the quick answer @Reese

Ok, of them worked via the app on my macbook and is on 1.3.2

The first one, still the same, it says is on 1.3.2 but it keeps rebooting to the motor update. I’ve tryied to hold eject but it goes right back to the same cycle

Okay, what happens if you reset the player by holding the power button for more than 5 seconds?

It shuts down. When i power it back on, home screen, no lights on, just the display and back to the same thing. The bar for the motor update comes on, it goes 10% and then it reverts to the home screen