WiFi connected but tidal not connecting

Only just got my Go and it’s been great till this evening. I’m connected to WiFi (strong signal and connects to Soundcloud) but when I log into Tidal as I have previously it tries to connect then after a while it comes up with another box ‘No Connection, No network connection was detected’. I’ve tried reloading the software and re connecting to WiFi but still no joy. Even tried another WiFi connection and still the same. Is this a Denon or Tidal issue ? Possible it’s even my own. Any help would be appreciated.

I have a PRIME 4 same issue with Tidal, only been tonight so assuming it’s a Tidal issue.

Hi there Denon Support,

Also only just got my Prime GO a few weeks back so: Connected to strong WiFi - ‘No Connection, No network connection was detected’. I’ve tried reloading the software and re connecting to WiFi but still nothing - Any help would be appreciated.

I’ve pm’d Tidal via Twitter and there looking into it apparently! I’ll let you know me when/if they get back to me. Hopefully be resolved soon…very annoying!!

1 Like

Same issue for me on the Prime 4. There’s quite a few posts going up on the various FB groups so must be a general problem.

Same here. Thought would be an beta issue. In additon same problem for soundcloud. Can anybody confirm the issue also for soundcloud.

Therefore seems to be a problem on denon infrastructure? Maybe authentication servers?

Maybe it’s coincidence but it’s the only time the streaming services have been down …and… it’s near virtual NAMM week sort of.

Maybe there’s some change added like analysing whole playlists or advanced sorting of streaming songs or offline storage of xx songs

same im using sc6000s both players cannot connect.

+1, “no network connection”. prime 2 here (latest official firmware, Germany)

(of course with 5/5 wifi and 100M Internet connection).

Tidal is down - They have a server “thing” according to people chatting on social media about the same thing

Confirmed on SC6000 and 5000.

The message could be different on the units. I’ve raised that as an improvement.

Can’t confirm a general Tidal issue. Working perfectly on PC and smartphone and this indicator appears to be normal:

Any updates?

Still not working for me :frowning:

Have same issue,it happend in new years eve at 00:00 gmt,must be something to do with certificates…

Hey Brothers,

Just dicovered the same issue.

I brought my Prime to a frind right now And we wanted to do a set toghether Only using Tidal. At home everything worked fine so far the last year, exept known issues like the lost network connection sometimes.

I dialed into the network here, no prob but Tidal shows the Error No Network detected.

The only thing i changed the last week is i had to put a cheap USB Stick in cause i lost my loved Patriot. But yesterday I played home with the other Stick and it worked.

Maybe its the Routersettings here.

Now we play from her USB Stick and have also our fun😁

Just want to let u know.


Some advice on a FB strand suggested a hard reset (keep finger on off button when turning off - did not work) or selecting NO when turning on and being asked to use a user profile. This did work for me. But only once (it’s now not working again).

Yesterday Tidal worked. Today not.

Beatport and Beatsource all work.

It’s a Tidal issue to my knowledge.

But only on the Primes? My Phone App works well and preparing Playlists and stuff… I have the beta OS. Anybody running the latest official version with the issue? :+1:

I’m running the latest beta and nothing has changed on my devices.

This is an external thing. Might be the API or certificate that’s needed to talk to Tidal, but I don’t think it’s something an owner can do about it at the moment.

Btw, Ubisoft Connect is also down during their “friends for free weekend”. :wink: