USB not recognised by SC5000

Hi All,

Im having problems with my sc5000 players…again.

I’ve currently got 3 usb sticks which i have different music on, They are Sandisc sticks, 2x 16gb and a 128gb…more often than not when i plug them into either player nothing happens…so i have to eject them and put them in again…over and over…until the players realise they have a USB stick in them. Then all is fine

Has anyone else had this issue?

1 Like

Hi Paul. There are, of course, many many USB sticks so this will be quite generic advice, rather than specifics.

Firstly, some USB sticks use data encryption. Other sticks have splash screens or show as dual drive letters when plugged into computers

Whilst these can be great features for secret spreadsheets and bank details etc, it’s not good in media players. In such situations you could try different memory sticks or look on the website of the USB sticks manufacturer and see if they have software to download to remove the encryption and bloatware.

The other thing to watch for is whether the sticks are usb2 or usb3. If usb2 they can go into the front USB port of the player. If the sticks are usb3 then they must only go in the rear ports.

Give that a go and let us know how it goes

A USB3 stick should (in theory) be backwards compatible. I only use the front port on my players and haven’t hit any issues yet (Kingston 128gb Datatraveller).

Do they have the U3 software on them? If yes, remove it.

Best advice is to ALWAYS (re)format your USB stick before us (HP USB Device format tool is best). This will prevent most of the things mentioned above from happening.

first of all sorry for my bad english i have the same problem but with the corsair survivor usb sticks I have several brands of usb sticks and with non of them i have any problem at all, as soon as i plug them in they are recognized by the player and anything goes well. I have 3 corsair survivor usb sticks and all three of them aren’t getting recognized, they just simply don’t show up on the screen and I don’t understand why. I tried anything, for me it seems as there is a communication error between the corsair survivors and the players, the format doesn’t matter it is just that particular brand and model that just doesn’t get recognized. Has anyone experienced problems like that before with the corsair survivors before or can anyone help me out? thanx in advance!

It’s possible that the USB sticks encrypt the data, which is bad news for most devices apart from PCs or Macs.

The other likelihood is that the sticks are usb3.

The front USB port on the SC5000 is usb2 only, whilst the rear USB ports are for USB3 sticks.

Some sticks claim a certain anount of usb3/2 backwards compatibility, but that’s often patchy, not just for DJ use but for all sorts of situations.

Give the sticks a try in the usb3 sockets on the rear of the players, if they don’t work there either, I suspect it’s some odd data encryption or some deep “feature” on the USB sticks. When you plug the sticks into a main pc do the sticks create a pop-up splash screen announcing themselves, or show up as more than one drive letter eg: you plug in one stick and get two drive letters (like G and H) appearing on the computer? If so, there’s some odd dual/hidden partition doing odd things.

Thank you for your quick answer! The sticks are indeed USB 3.0 but even in the rear USB ports they don’t even show up on the screen of the players. literally nothing happens. I would be really surprised if their would be some odd encryption on the USB sticks because on other DJ devices they are recognized immediately and they work just as they should. Can this be a problem specific for this player or am I doing something wrong? I don’t really know what you mean by a ‘pop-up splash screen’ but If i plug them into a main pc the sticks just announce themselves in the same way as my other brand USB sticks do. the stick’s ‘name’ shows up and i can select several options such as ‘show content’. Nothing seems to be wrong there. I would like to use the corsair survivor usb sticks so i would be happy if this problem could be solved! thanx in advance for all possible solutions!

Hey Vanathic, Are the drives formatted in a compatible format? We don’t support all formats, so please make sure that the drives are formatted appropriately.

The drives are formatted in FAT32 which I thought is a compatible format, could it be a solution to reformat them to exfat? I would like to upload a picture for proof but I can 't because I am a new user

FAT32 or EXFat should both be fine.

I would suspect that any remaining issues would be with something “odd” and deep on the sticks. Some manufacturers of sticks put their own bloatware and utilities onboard the stick. There may be a small software app on the stick manufacturers own website which can be used for removing all the bloatware, hidden partitions etc and just leaving the stick as one, big, ordinary storage space, which is ideal.

Different media players look at storage devices differently, shallower, deeper etc than others, so whilst a stick with certain hidden areas might have those sections ignored by some media players, others might not.

Hi All, Recently I have bought 2 SC5000 Prime players and an x1800 mixer. I have the same issue. I have 6 USB sticks. All working well on my PC and formatted (full) in the right format (fat32). The player is only capable to see one usb stick of the 6. How is that possible and how to solve this ?

Try them in exFAT and see if that works.

1 Like

I have the same problem on two SC5000 players with firmware 1.4.1. It will not read certain (older 8gb or less) usb sticks. This is kind of a big deal as i have people come over with their usb’s all the time and it’s kind of embarrassing when the pioneers from my flatmate read the same usb and the denon doesn’t. I’m trying to advocate here haha. Please look into it, compatibility is a deal breaking issue if it’s not right. Really happy with everything else

I remember that when I had this happen I was told that the front USB port is for usb 2 only and the back USB ports were usb 3 only. I don’t know what the prime 4 ports are (usb 2 or 3 )

This is why there’s a usb extension lead in the box with the sc5000 — to give easier front access to the rear usbs when you have a usb 3 flash drive.

But, if you’re sharing dozens of usb flash drives around, no ones gonna know if their flash is usb 2 or usb 3

The front is usb 2 only, the back is usb3 but backwards compatible. I’ve already tried all the ports. Usbs that work work in all ports, usbs that don’t work in none. And its on both players too. Tried formatting fat32 with the proper tool etc.

@Enlight, I know this is a really late response, but do any of the drives that don’t work, have any type of splash/start up screen when plugged into a computer, or have more than one drive letter on it (usually used to store a back up utility that can be used with that stick), or a “Secure Access” feature? Some may even have a hidden drive letter (that stores that backup utility software/program) so you may not see it when the drive is plugged into a computer for viewing it’s contents. Any of those things could potentially cause the issues you had.

A long time ago (on the old Denondjforums), it was found that some companies (like Sandisk and Lexar) had this type of stuff factory installed on the drive, and even when trying to do a full format of the drive, that stuff was still there (it was write protected). Sandisk finally came to their senses and released a program that could properly wipe/format the drive so that everything (including their back up utility program) was wiped clean… but til this day I was told that they are still producing thumb drives with that stuff on it.

Here’s some info about the Sandisk utilities.

 Yea, the FAT32's stop at 4GB's, at some point, and wont work beyond certain amount of tracks, & data,you see. Not exactly sure why my & the  64 GB" exFAT's ", will hold like 5,000 tracks, & also will let you utilize both Mac, & Windows, & some other features, as well. exFAT is A more modern supported file system these days, rather than the widely spread, and widely known FAT32s, which for some reason, especially on music driven devices or media players, they freeze up or stop at 4 gigabytes of data or tracks lets say. So I guess the " 64 GB exfat " flash drives are more compatible, And don't stop you at 4 gigabytes either......🔥💯 👍💪🙏🎶🌎

Hi, I was wondering how to seek help with my Denon SC-5000M, im very new to Denon, & thought everything was all set, I moved all music to my Scandisk Extreme GO Flash Drive USB 3.1, from my phone, & all was well. Plus, I had made sure that it was formatted in either exFAT or FAT32, wich the website said they come in exFAT or FAT32 format. And, I also had checked into it, as well, & MoJaXX, on DJ City even recommended this flash drive specifically for Denon DJ. And when I stuck it in the USB slots, its not reading it at all, & where I dont own a computer at all, wich was why I went this direction, with the USB stick, now my phone, or the Denon SC-5000M wont read it anymore, I’m lost. And, if I cant figure out whats going on with this flash drive, my music is gone, my whole collection of the last 5 years. Im losing my mind over here, cause this was all my music, digital, at least, that I had. And, of course it will read the other shitty flash drive that I have, but not this one? I tried everything, I read the manual, Iooked on youtube, & also, I downloaded the firmware update onto my older flash card, as well as the one that has all my music on it, and its not reading the firmware update on either. Im officially lost, & also new with this digital side of things, where im usually using records or vinyl… Lol… Hoping I can fix this, or I’m gonna have to send this back to Denon, cause everything I thought would be great has turned against me, and possibly now I’ve lost all my music, as well. Please help, much thanks, and appreciation…

How did you get allowed your files into it without using a computer?

1 Like