Unable to create playlists

For some strange reason I’m not able to create playlists! Just had my decks a couple of days and just started using engine software. image

Please expand on “not able to”…

Clearly the option is there in EP. What happens when you select that menu option?

Have you added music (from your hard drive) to Engine Prime yet?

Yes I’ve add 5000 tracks showing in a crate in my collection. How ever I need to create playlists when O select playlists and right click to create new playlists nothing happen a new playlist isn’t created the tracks were load in from m iTunes folder by clicking on the iTunes folder then selecting update library. I may have to start again and add the tracks by dragging and dropping them in.

That just updates what is read by Engine that is in your iTunes. You have to add tracks to your Engine collection. When you click that box with the records icon at the top it will show your entire Engine collection and any crates you’ve created will be below that. If you don’t see any tracks then you haven’t added anything to your collection.


The engine prime software is still not allowing me to create crates or playlists, I am right clicking on crate then selecting crate but it doesn’t create the crate. I am also having an issue dragging and dropping tracks from a folder but it will allow me to drag and drop from my iTunes library! Not sure what is going on it should be a simple to do but there seems to be an issue with the software on my machine :frowning: Am am so excited to start using my decks but I can’t at the moment due to this issue :frowning:

You’ll need to give more detailed info.

Thank You PK Basically I have dragged 200 tracks from my iTunes library to Engine Prime, it has analysed the tracks in the main collection crate, I want to create a new crate to put these into as they are a particular category (disco Edits) when I right click on the plus icon in crates the choice to create comes up, then I click on that in the hope a crate will be created, but it doesn’t create a new crate. I hope that makes sense? Have a look at the screen shot, I am clicking on create crate, but the crate is not created. Because I am unable to create Crates or Playlists I am unable to export tracks to my USB Please see screenshot. I really hope I can get this sorted out as I want to start enjoying the decks.

The plus button should be clicked with left mouse button. Not sure why You click the right one. The lower photo shows sync manager (sync to external drive). That is not needed for creating playlists and crates locally.


Thank you yes I right click to bring up menu then left click the + sign to select and create a crate. But a crate doesn’t get created :weary:

  • What computer are you on?

  • Try uninstalling engine prime completely

  • Also delete the Engine Folder in your computer default Music folder.

  • Download Engine Prime again

  • Install and Launch it.

  • Before adding any music try creating a crate or playlist again. You don’t need music to create a crate or playlist

Left Clicking on the Plus sign :heavy_plus_sign: should create a crate

1 Like

Left click on the plus. No need to right click

1 Like

Many thanks I’m using a Mac running Mojave OS Will give this a try later.

Fingers crossed this will do the trick.

I’m a Mac user. I’m on Big Sur though.

I just confirmed that “right click” does bring up a list that does nothing but “left click” on the plus will create a crate. Using Mac OS Mojave.


Still not working for. I have tried everything recommended here and still having the same problem Here is the screen shot, when I just click the + sign in playlist nothing happens hovering over the + sign The top message appears to create a playlist folder right click, when I right click I get the menu create playlist and create playlist folder, left clicking on those should creat the playlist but it doesn’t, nothing appears.

Screenshot 2021-08-29 at 07.16.11

Check your security & privacy menu on the Mac.

Check if Engine prime as the necessary access

  1. Accessibility
  2. Full Disk Access
  3. Files and Folder

Screenshot 2021-08-29 at 08.04.58

Than you Mufasa just tried your suggestion still not working :frowning: Screenshot 2021-08-29 at 08.31.46 Screenshot 2021-08-29 at 08.31.14

Maybe bring @KDonaldson in to be sure what’s going on?

1 Like

Thats a bummer.

Okay lets try this


Download and install that. Start the AppCleaner program.

Open Applications Folder in Finder

Drag your EP into Appcleaner and check all the boxes. It will remove EP completely.

Now download and install EP again

1 Like

Ok uninstalled from App Cleaner reinstalled the software and still not working :frowning: not sure what els I can do?