Touch screen sometimes not responding

Firstly just want to say I absolutely love my SC6000Ms and the new functionality I’m enjoying with them. When I go to clubs now I don’t want to use the CDJs anymore but sadly still need to in a lot of venues. :hot_face:

Anyway just wanted to ask about an issue I’ve had a couple of times. I’ve had these decks for about a month now and last night at a gig was the second time I encountered this particular problem. The other time was while I was mixing at home. Part way through a set, one of the screens stopped responding to touch. The display still worked fine but there was no longer any response to touch. Each time it happened, it worked fine again next time I turned the unit on but re-starting the deck is not really an option in the middle of a set. Especially since in both cases the USB drive I was using for both decks was plugged in to the one that had the issue.

I’m wondering if it’s a problem anyone else has had and if there’s a way to sort it out without re-starting the deck. Most of the functionality is still there without the touch control but there are a couple of things I couldn’t figure out how to do without the touch screen. Such as typing in to the search box or changing the way a list is sorted (by bpm, key etc).


You can add in a USB keyboard, until you trace what’s causing the touchscreen to lock up

@DJSteil Indeed what @DJ_Sontag says, you can plug in a USB keyboard and try if that works when the screen is unresponsive. This way you can be sure it’s not the screen hardware.

Some questions that might lead to a quicker solution:

  • Did you leave the player in this state for a little time? Theoretically the unit should (soft)crash when something in the software is unresponsive for > 1 minute and reboot the software itself.
  • Is it always the same deck with the issue?
  • Can you try to capture the issue on video?
  • On what firmware (and build) are you experiencing problems (found in Utility)? I would also suggest to reinstall the latest firmware (even if it is the same number). You can find it here:

You can reboot the deck with connected USB and the other linked deck (with no USB) will continue to play the track buffered in it’s memory. To ensure yourself this works try this at home first :slight_smile:

1 Like

I always wondered why Denon did not include calibration for the screens and jog wheels.

It is auto-calibrating during power up, that’s why You are not supposed to touch it when powering ON.

Got it. It still should be an option to recalibrate both without having to turn off/on the player.

The first time it happened I didn’t take note of which deck it was. The second time I did so I’ll be able to see if it’s the same if it happens again. Both times it remained like that until I turned the deck off. Since in both cases it was in the middle of a set / mix that was quite a while. Actually I wasn’t real sure how to turn it off since normally the button to confirm you want to shut it down is on the touch screen. I couldn’t figure out another way to do it and ended up just having to unplug it. That’s also a major reason i was hesitant to restart it during a gig since I had wondered if the other deck had the track buffered but wasn’t sure how I’d actually restart.

You can force shut down by holding the on/off button for longer time.

1 Like

I am not sure what is included in a fw update but would imagine the touch software gets overwritten when you do a firmware update so try to load the suspect deck’s fw again. What you are describing sounds like a sw issue unless it’s something on the touch board that is going/locking up.

And just out of curiosity, do you have the screen film still on the screen or you took it off? I know mine has been on my SC5000 since unboxing and I have not had any issues so I doubt that’s the issue anyway but still curious about it.

I thought that might be the case. I did try holding it down but obviously need to do it for longer.

It more or less a computer so 5 seconds should be enough.

I updated the firmware to the latest as soon as I bought them just over a month ago. It could certainly be worth doing the update again. I keep the film on the screen while they’re not being used but take them off when I’m using them.

1 Like

This happened to me couple of time with the latest firmware, it doesn’t happen often. Button controls continues to works so the deck is still usable. Once I ignored the touch screen and only used the button and it eventually unfroze. Pressing the power button will result in a stalemate since you won’t be able to confirm the shutdown by pressing on the screen.

I wish I had repro steps so I could fill out a bug report and help the devs to fix this problem. This is not some remote control issues with the X18-- which i’ve seen elsewhere on the forum.

If you’re in the middle of song on your other deck and got a good space 30 sec, you can easily reboot the deck. Even though the storage is attached to the rebooting deck, the playing deck will have all the track into memory so you can continue your performance on that deck while it’s rebooting.

A mitigating fix would be to enable to confirm a clean shutdown with buttons so you won’t do a hard reset which can potentially corrupt your database.

Still… i’d much prefer for all this not to happen.

1 Like

The same thing happened to me the other day. It never happened before that. After navigating my crate with the physical buttons, it eventually unfroze. I’m on 1.5.3 if it helps, SC6000, players linked. The player screen that froze is reading music off the other player’s SD card. Don’t know if that makes a difference but that’s how I’m setup.

It happened to me again tonight. From now on I’m taking note of which player is which so I can see if it’s only happening to the one player. Previously I hadn’t really tried to keep track of which one was which. I suspect it’s been the same one each time but now I’ll make sure I know. Tonight it happened after a couple of hours of use in a 5 hour gig (new years eve gig). Once again it was the deck that had my USB drive plugged in. When it happened I did as one person suggested and turned it off and on while the other deck played the stored song. The screen worked with touch again when I turned it on but only a couple of songs later the touch stopped responding again so I just dealt with it for the rest of the night. The deck is still useable with no touch screen but it’s annoying since there are some things I can’t figure out to do without touch. Like change the sort order of a list or add a track to the play later list. I updated to the 1.5.2 firmware as soon as I bought them in October. That’s the latest version it shows when I check for updates.

Are You using a scroll bar on the display in playlist view? My friend has a similar issue with the sc6000. It only showes up when he uses the scrollbar.

@JWiLL I think this issue can have something to do with the problem I also reported to You.

I’m thinking you might be right. The last couple of times it’s happened it seems to have locked up right when I started to scroll (by touch) through a list. It doesn’t always happen so it’s real hard to pin it down. Since it doesn’t always happen I’m also a bit hesitant about taking it in for a warranty repair or anything like that since they could very well look at it and say there’s nothing wrong.

What source are You using when it happens? Are You on the SD card or ssd drive, or using USB?

I don’t think this is storage related, I had it with the internal SSD, external usb SSD on both unit directly plugged or through link.

It’s a clearly screen bug where it stop processing touch event.

So far it’s happened with a usb drive and an external ssd. I just installed an external ssd but haven’t used them for a gig since I put that in. I haven’t yet determined if it’s only happening on the deck that has the storage device connected or if it’s happening on the linked device also.