Start Up Black Screen!

first: sorry for the english! ive had the same problem with one of the players, but now anything seems to work now - i hope… So i hope this is a firmware issue :confused:

I did following to bring the player back to life: You need to Disconnect the Powercord, then put on the player with the “black screen” issue, he starts and then after few seconds he will be shut down after the intern USV have lost the loading voltage in it, to make the player completly offline/undervolting so you did a art of “Reset”. Bring back on the Powercalbe and Start it again, for normaly he should be work again! Hope this is a bit helpfully :slightly_smiling_face:

So far, Roland


the power up - down cycle I performed was indeed taking out the power cable and wait till it powered down completely.

@DenonDJCorey; any developments from Denon tech team on this specific issue?

1 Like

Hi, @djprosac and @polderboy! If your SC5000 is not powering on fully, you’ll want to contact your nearest support team to determine your best options for service. I can’t say what a dealer will or will not do in these circumstances.

As you mentioned, the behavior is rare, intermittent, and difficult to reproduce on command, so it’s more than likely evidence of a failing component.

Nevertheless, thank you for bringing this to our attention!

Thanks @DenonDJCorey

What would be the position of Denon towards the dealer, exchange the unit or repair. As often Dealers execute the advise from the supplier, Denon in this case.

thanks again and I assume that within Denon this issue is not activly being investigated, is it to be expected an hardware or a software issue?

just a small note: djprosac did it a little differently, not sure if you noticed the exact sequence.

thanks @SlayForMoney I indeed did it differently the method from @djprosac is a bit diff and makes more sense.

So the following process is to be followed if you want to do a reset of the SC5000:

  1. Player is powered off
  2. take out the power cable
  3. start up the power on the player (without the power cable inserted)
  4. start up will not be completed due to lack of power.
  5. insert the power cable again
  6. do a normal start up.

then all should be OK again.

will try that when/if it happens again.

Would be good if someone from the @DenonDJCorey team can confirm this is the correct “reset” method or is it method that is not to be used…

thats right in this direction of pullin down all of the voltage, this seems to a full reset for the unit!

I am on a testing parcour at the time since i had the issue.

At now, i never had the problem so far but i will test and if the error is back again i will tell you all here so i need to send the unit return then and hope for a positive resonance ;/

so far…

just for update: Sended back the Unit to Repair… they have pulled out the PCB and replaced it with a new one…

So, the Player comes back, pulled anything on and pushed the ON button, Booting as well, but then i detected the player cant connect to Network with the Mixer, to they are useless while i cant get my musicstuff and other things as they should to the player and between the players and to the mixer too… i dont know why the network port failed but i think this could be a problem during the PCB replace and/or MAC adressing trouble with the new pcb board…

so, i send it back for a second time and telled the shop (Thomann) to get a completly new one… Now they send a new one (many thanks) and now all working as well as they should, now iam happy…

just for information for all the can have the black screen issue as well, make sure you get a new one and dont let change the PCB board… i think its not a good idea :wink:



1 Like

Yesterday i did have The same Problem. First by Sound Check went everything well … and then 10 min before my gig couldnt get it working… 10 times Restart … no results… after 40 min without power it did start normaly again :frowning: i own that Player for 1 week…. buyed totaly New from store

I have the same issue… Suddenly without reason at home.

Hi @vnem,

Sorry to see this issue. Does the black screen happen immediately after powering on or sometime during use?

What firmware version are you running?

Does the issue still occur if you isolate the SC5000 from all other devices (remove network cable)?

Just got 2 sc5000 today. Is there any way to factory reset the unit? I’ve tried draining it. (Pull the chord and pressing power on, then reattaching the power) But it doesn’t work. The screen es tiled in white. The controller beneath seems to sill work, but the display is basically gone.


  1. Unboxing
  2. Patching the 2 units from 1.2.2 to 1.3.1 via usb with the same usb for both.
  3. Playing a short set over the network.
  4. Ejecting the usb was unsuccessfull so i just plugged it out.
  5. Played another few tracks from the usb on the other deck.
  6. Turned off.
  7. Turned on, now the screen glitches the whole time.

Is there any potential solution or do I need to send it back?

Cheers, Nicco

IMG_2302.mp4 (5.9 MB)

Could you try to re-install the former firmware? And then maybe try to install the latest again…

1 Like

I would love to. That was my though too, but how? the display is unusable unfortunately.

Maybe if you press and hold EJECT while turning the unit on, it should restart in update-mode… And if you then connect the pc/ Mac and do the install that way, you can activate the install from the pc/Mac

Thanks for the suggestion, but it does not work. The glitched screen stays. Also the computer does not recognise it.

:thinking: Dont have any better suggestions atm, but will see if something pops up.

Maybe @Nekoro_DenonDJ is the best advice at this point :slightly_smiling_face: :muscle:

1 Like

@Engell: Holding EJECT on a Prime4 works for going into update mode, but not on an SC5000.

The correct combination for an SC is: EJECT+SOURCE+LAYER and then powering on. :wink:


Thanks for the tip! Why are those not in the manual? :see_no_evil: I managed to flash it successfully, but the glitch in the screen remains, so would guess it’s a hardware problem :confused: I tried both with installing the v1.3.1 & v1.2.2 firmware.

1 Like

Yes it probably is.

The key combination was in an old firmware update manual, but things are mostly automated now.