Serato DJ Pro Recording Signal

Has anybody had an issue with the recording signal? I never had a problem in the past with recording my sets using my NUMARK NV II but since I change to the MCX8000 my volume level when recording is low and my meter is not working in the software. The master meter is working but not the record meter. I am using a MacBook Air as a laptop


prior to recording how are the signal levels in serato

  1. each track signal level if not using autogain (serato software vu signal in the GUI)
  2. the recording bar signal level in serato as well (when you choose the record tab, the horizontal meter) - scratch that i just saw this

What version of Serato DJ do you have?

Just updated to the newest version 2.3.1. I’m using auto gain in Serato DJ Pro. The signal levels prior to recording are excellent.

Could be a bug.

Try it with an older build eg 2.1.1 or summat

You can have multiple versions of serato installed on the same mac, just rename the app file of the currently installed on prior to installing the older copy eg “Serato” to “Serato 2.3.1”

Done I still have the same problem

Can you share a photo of your 8000

Photos of what levels u get In serato the record bar, VU meters of the channels

Photos of your serato settings

Or a video uploaded to YouTube showing all that

IMG_1123 IMG_1124 IMG_1125 IMG_1126 IMG_1127 IMG_1128 IMG_1129 IMG_1130

Just had a look at the video

Not sure what the situation is

You have the correct source selected for recording yet the VU meter is not even moving

I’m scratching my head here.

Do you have access to another laptop/PC?

No not at the moment.

Try toggling the view to horizontal mode

Try toggling the recording source.

Just tried changing view as well as the source. Nothing changes

Toggle off the Streaming services

Nope still nothing.

Only thing left is to try a different computer or a different controller with your current laptop

I’m out of ideas :bulb:

I just tried it in standalone mode, without the controller and it works. I believe its the controller. My NUMARK NV II worked fine.

Do you still have the Numark NV?

Its at the store being repaired it started looking for a firmware update all of sudden??? I then purchased a new controller MCX8000. All that to say no not at the moment.

Ok im going to tag @kradcliffe whom i believe has the MCX8000, maybe he can test his with serato

Ok sounds good! I’m also on another forum with Serato and some others have had similar issues

Just tried it and change the setting to 20db and nothing still.