SC6000s randomly rebooting mid set

Hi Guys,

i’m experiencing an issue with my brand new SC6000/X1850 PRIME set up. When using the internal SSD I’ll be mixing for about 20 minutes when the players lag and then just restart stopping all the music playing. I’ve health checked the SSD, all good there, reformatted and resynced and that didn’t help, and i’ve redone the 1.6.1 firmware update.

Both SC6000s on 1.6.1 X1850 on 1.3 all linked via X1850 Kingston A400 SSD Sata 3

Any advise is much appreciated.

1 Like

Although I can’t think they’d cause a full reboot, have you taken the clear plastic films off of the platters?


Have you exported your music through Engine on your SSD?

I had something similar with with a Rekordbox stick but never when I exported with engine.

Did the player reboot or did you see a message on the screen that said player resetting and and emptied your tracks on the deck without shutting down?

So what happens is it’s all working fine 4 tracks across two players, then I’ll go to load a new track in, the player lags after I swipe/ click to load closing the track menu, and the player just says shutting down player and then it restarts and opens up as normal.

This looks like a corrupted music file. Had that happen to me once. I deleted the faulty file and all went good after that.

Before this happened did you plug and unplug anything to the USB ports on the back of the deck?

All my files are fully located though and worked on rekordbox prior to me switching everything over. Is there any way I could identify a faulty file that isn’t red with engine prime?

UPDATE You’re 100% correct. I checked the files i was loading in and when it rebooted tried again and it did the same thing. I went on Engine Prime and the track isn’t red (unlocated) and the actual MP3 file on my mac is working absolutely fine. However, Engine Prime has messed up somewhere and has corrupted itself on that particular song. I know however, I have played multiple genres and had this issue. Do you know of anyway I can find all the faulty tracks within my collection without having to load them all individually? Thanks for the help btw, Charlie

Hello, so far, I don’t know how to find faulty files. I didn’t had many of them that caused an issue. But I know how to fix them - open in any daw and save as a new mp3 or wave - simple.

1 Like

I had the exact same problem.

The tracks run perfectly on the Mac under Music and also in Engine.

It’s very strange that they don’t run on the Prime.

The bad thing about it - you don’t know when that will happen again with which track - when I imagine the live - really a disaster.

To get around that you would have to audition every track on the Prime - not very practical.


What I would do is pass the files onto Denon DJ so they can look at what was corrupted and how the players reacted to this corruption as they should ideally fail to play the track, not reboot. There shouldn’t be any incidence where a faulty track should do that as the machines should be robust enough to gloss over it with a corrupt message.

If you forward the problem file over then they can hopefully build in safeguards. They can’t do much about the faulty track but they can make the machine handle faults better.

Once you have uploaded them there is apps that can fix them. It reports what the issue was too.

“MP3 Scan + Repair” on a Mac works well. There is windows based apps too if you are on that. There is also MP3VAL on Windows but you’ll need the ‘Frontend’ version.

Mac: - MP3 Scan + Repair App Windows:

1 Like

So for my personal case, the file on the computer is working absolutely fine its just when its in engine prime that some tracks just seem to get corrupted by the program upon import. The same track that rebooted my SC6000s I tried to load into the Engine Prime player and the whole program froze and had to be force quit. I think this is looking like a much bigger issue than MP3 being corrupt and more an issue with the engine prime analysis itself. All the tracks were working (and still are working) fine in my rekordbox collection all i’ve done is drag my playlists across. For the faulty tracks, if i remove them from a playlist and then just drag it in again, it works absolutely fine.

Therefore, I can only assume this is certainly an issue with Engine Prime. I’ve deleted my whole library and reimported everything again and it seems to have mitigated a lot of the faults I’ve had so may have just been a bad import. But until this is fixed within Engine Prime as Houseman said I’ll need to click on every track in engine prime and ensure it loads into the software before exporting it to my SC6000 SSD.

If I do however find some more faulty files whilst doing this process I’ll send everything to Denon so they can get to work on a fix for this as its a very large issue. Thank you for your input everyone though, i’ll speak with Denon and update everyone.

Which seems far more likely now to be a corrupt audio file… or rather, at least, a music file which isn’t strictly following guidelines on its header data. Some programs and devices, especially desktop and laptop computers, are far more forgiving of header deviations.

For example, I had some files which had massive album art associated with them, far larger specs than MP3 art is supposed to have; almost a meg, just for a colour picture. My desktop computer opened up the file, played the music and showed the album art, but my phone, my in car head unit player and my primes wouldn’t play the same file.

It’s worth finding the suspect files and stripping off all the MP3 tags and artwork and reapplying those tags and art

1 Like

Totally agree with the stripping of tags. I’ve reduced all of my collection to a nice selected few data fields and removed things like ape and old ID3 info. Some files have multiple album art and programs like Mp3tag are great for removing crap from music files. It’s paid for on Mac but free on Windows.

If you have a backup of the problem files, then run them through one of the mp3 file repairers above (don’t fix an original before forwarding it onto Denon DJ). These apps really do fix almost all of the issues with mp3 files and can do batches so you can just drop a folder in and watch them get fixed all in one go. You shouldn’t even have to import them into Engine again as they make a copy, repair then delete the old file so Engine should still see them as the original.

One of the best pieces of info I read a few year back was the Native Instruments blog on it all. I’ll find it…

I only ever had one and only one crash with Traktor when I used it. I never really used Traktor but I purchased an S8 to play around with at home but one day decided to give it a go in a local club. I played a track that I’d played in Serato DJ a billion times (almost) and Traktor just dumped me onto my desktop halfway though playing it in the club. I never took the S8 out again and it stayed at home.

I found the above article and the Mac repairer fixed the file in question and reported that there was garbage in the header. It was a purchased track too.

1 Like

In an ideal world, EP should be detecting these tracks and alerting the user.

Serato DJ gives an icon and tells you whats wrong with the track.

And if by some chance a corrupt track still ends up on a USB stick, Engine OS should prevent play or grey it out so the party doesn’t stop due to a hardware crash. It may also take it further by sequestering it into a autogenerated “corrupt and missing file” folder.


I checked my allegedly defective tracks with MP3 Repair - no errors!

1 Like

Any foreign characters in any of the tags or the file name?

Foreign :grinning: That depends on the locality :stuck_out_tongue:

Non-english characters should not cause an issue in this age and time. They work fine in other softwares and should in EP and EOS (another ideal scenario).

Is that the cause? I’m not a programmer perhaps someone can enlighten me

Good point… so maybe “remove any letters which are wearing hats or tails” would be better advice.

This is kinda related…