SC5000 screen fully unresponsive

Hey guys,

I’m having a serious issues, and I would love it if you could recommend some troubleshooting tips.

The screen on one of my SC5000s is completely unresponsive. Update patch is 1.5.2.

I’ve tried hard resetting the unit to no avail.

It worked once when I left my thumb on top while it was turning on and it worked perfectly. It used to work perfectly before too.

All buttons and functions work, except for the touch screen. It’s really frustrating.

Thank you all for your feedback!


see here

Is there a moderator that could look into my customer support ticket? I sent it last week. Thank you for your response.

@Reese is one of the moderators here. Not sure if he has the ability to check customer support tickets, but then stranger things have happened :stuck_out_tongue_closed_eyes:

I have a set of the 5000M and 6000m. I have never encountered this issue. I got them close to release date


Uploaded a video of the problem for reference.

No sorry. For support issues I tag @JWiLL as well.

I’ve also never seen this happening to my SC5000’s and SC6000’s; also obtained right after and before release. :relieved:

Hey guys,

So I found a weird fix? Tapping on the screen quickly as soon as it shows the source select screen. Maybe this works for you guys too? I will continue testing this and see how effective it is.

Edit: it doesn’t.

But I found something else that works. Leaving my thumb on the screen during shutdown makes it recognize touch at the next boot up. Will continue testing this hypotheses.

Edit: it doesn’t.