[Resolved] Engine Desktop Fails to copy tracks during Export to Internal SSD on P4


I’ve been experiencing an issue where the Sync Manager is not exporting the tracks to the P4’s internal SSD.

I have all of the tracks local on the laptop that I run Engine Desktop on, the collection is populated correctly and there are no missing tracks. When I sync to the P4s SSD I select all of the playlists and the process seems to run and finishes without errors.

However when I restart the P4 in standalone mode the playlist is visible but contains no tracks. Is this a know issue.

Also is there an option for verbose logging of the sync managers activity so we can see if errors are preventing the sync. There is plenty of available space on the P4 SSD.

Thanks Phil

Did you try formatting the destination drive again?

It’s not something I want to do with 230GB of tracks on it. I’d need to export the entire drive again which would take an age. There must be something not quite right during the export.

Well it appears we have reached an impasse :sweat_smile:

Perhaps other folks may have better suggestions


230gb is not a lot and should pack in less than an hour from scratch.

I did a 730gb transfer to a T7 drive (ExFat) from scratch last night took less than an hour

Thanks for responding to the question, however what you propose is a workaround and not a solution. I’d rather get to the root cause of the problem and correct it. Previously in 1.6.1 I would add files directly to the SSD in the P4 via the desktop software, drag and have them analysed there. Now I’ve built the collection again on a laptop and use the sync Engine to export to the SSD in the P4. This is where the problems are. Can’t have a drive that you can’t put tracks on.

It’s almost going to be the database issue, perhaps during the migration process.

AFAIK there is no database integrity checker or fix

You may want to copy the database folder (minus music files) for both your SSD and Laptop

Upload it to the

Post a link to it and we can tag

Don’t be surprised if the outcome is the same - rebuild


  • Are you able export to another destination eg a USB stick (for testing) ?

  • Did you update the database of the P4 ssd from 1.6 to 2.0 as well or was it created in 2.0?

The first migration from 1.6.1 to 2.0.0 didn’t go well, so I started again from scratch, wiped the SSD, killed my collection removing Engine Desktop and deleting the database folders. So started completely fresh with 2.0.0

Worked fine, no issues although the export is a slow process when you just want to add a dozen tracks into the collection. This issue started last week. There are some inconsistencies that I’ve started to notice. For example when you create a new playlist, sometime it just names it playlist, you can’t edit the name etc. Restart the Desktop software and it’s gone!

Whats the situation with collections and playlists? It seems the integrity isn’t maintained. For example if I remove a track from all playlists, it still remains in the collection, but you can’t see it!

There needs to be an orphaned folder for all tracks that don’t belong to a playlist.

I’m going to delete the database and music files from the SSD on the P4 and export the entire collection again as you’ve mentioned. Before this I’ll run an integrity check on the P4 database (I have a copy of Stellar Repair and it’s worked for me before on 1.6.1).

I’ll report back Phil

Before doing this, i will recommend zipping the database folder and sending it to the devs via the wetransfer.

Let them try and figure it out so they can prevent it from happening again.

I was thinking of something similar but different - an ALL Tracks playlist (containing entire library tracks) for the Sync manager. As it stands sync manager only works for Playlists. Half of my library tracks don’t belong to any playlist meaning i cant export them with Sync Manager.

It should be the first checkable item for the Sync Manager and then Playlist with check boxes as the second thing


I just bought a brand new ssd because I thought it was the eternal hdd. But now it currently is running for 20 hours and is approx 15pct completed on a 300gb export.

That is definitely not expected behaviour.

20 hours?

What spec is your computer?

Are you using USB 3.0 ports and USB 3.0 cables?

Old Windows i7 machine, 12GB Ram, double SSD (upgraded dell xps) external drive is SSD through USB3.0 connection. , high quality cabling

Is the new SSD in ExFat?

Is the new SSD in an enclosure or installed into the player?

What brand is the new SSD ? Model?

Try running a speed checker in the SSD…crystaldisk has a free one.

Post the results

Hi Mufasa, thanks for the reply, it’s not the SSD, it’s ExFat and has been in there for about 6 months and works fine. BTW I’m a software dev (31 years) throughput of the SSD is fine, it’s internal to the P4 so the usb bus speed of the P4 is the limiting factor, but it’s not a factor in this. This is a problem related Directly to Engine Desktop sync.

It would be good if the software logged verbosely to a log file during these operations so we could catch anything that’s not right. It could be down to something simple like unexpected characters in filenames or meta data but without being able to trace this it’s pretty impossible.

To follow up on this, I formatted the SSD (Bad Move) and initialised it again. All tracks copy using the sync manager but the playlists do not. When I eject the drive after the export and boot P4 back into stand alone all tracks are present but no playlists at all.

Should have stuck with 1.6.1 P

Also you can’t create playlists directly on the installed P4 drive via Engine Desktop. It lets you create them, then they disappear.

Ok, I’ve got further on this and have experimented around. I now have 2 laptops with Engine Desktop 2.0.2 running.

The one with my collection on exports the tracks but can’t update the playlists. The second one can export and update the playlists.

On the first one that can’t update the playlist (it can’t do this on any external drive, USB or not), I’ve opened a folder watcher to look for file changes in the database2 folder. No file writes, it reads the contents which I created from laptop 2 but it can’t create any new playlists within the database.

Odd. So makes me think, is there a software conflict. Running Windows 10, also tried running as Administrator with no luck. It appears that this could be a file access error preventing the database from being updated or a conflicting component that is affecting all external device db operations but not the local collection.

Any help on this would be appreciated. P

Video link showing this in action


for testing purposes what happens if you try a new local database on the “troublesome” computer?

(i.e zipping or renaming the engine folders to something else and starting up engine dj with a blank library)

@Reese any ideas?

Tried that, did a complete reformat of the ssd, but the problem isn’t local to the ssd in the P4, any memory stick you use has the same problems. I think its a dependency issue possibly with the Microsoft c++ redistributable. I’ll check the versions installed on the laptop that does sync and the one that doesn’t. I’ve used to same sync targets for both laptops, so I know neither the SSD or the USB sticks have problems.

The ms c++ libs on the problem computer are a couple of versions older, but still the same major release version, I wonder if thats the problem?

Just to highlight the issue here is a video of the process.


You will see that the Drive F is empty to start with, thats the drive in the P4. When I start Engine Desktop it creates the database and empty collection. I then attempt to use sync manager to sync a playlist over. The first time you see nothing happens, I go back to the folder and you see no music transfered.

I click the export button again and this time is copies the files across but does not update the collection with the playlist.

Is there any process logging or do you have a debug version I could run to identify the problem. Thanks P

I did not mean the drive F

  • If you click on “Music” folder is there an “Engine Library” Folder there?

Is D a local drive as well?

Is there music files on D as well?

  • Is there an “Engine Library” Folder on the root of “D”

D is a USB stick. And yes there is an engine folder in the local music folder. If you could specify the location of the library in the software and the default file path we would be in business, but you can’t.

The local collection you see in the video lives in the music folder.

Let’s test something

  • Can you rename the Engine Folder in C Music to something else

  • Eg rename it to “Engine Library 2022”.

  • Start up Engine DJ

  • Should start up with an empty library

  • Now add a test folder of a few tracks from your C music files to it.

  • Export to a formatted test USB

I’ve done that process 3 times now. Still the same problem on that laptop. Just spent yesterday reorganising my entire library onto a removable drive that I will build the collection on from the laptop that does sync as I’m out gigging next week and need the library building. It’s very odd that this doesn’t work on the other laptop.

I’m having this exact same issue on a 2015 macbook pro with a Prime 2. I think it was working properly before the update to 2.0.2? Keep me posted if you come up with a fix…