Reformat drive to exFAT or FAT32 (Internal SSD on SC6000)

the last 2 weeks I’ve been unable to use my SC6000 as when I went to add music I had the following message…

/Volumes/Prime SC6000 is incompatible with Engine OS devices

reformat the drive to exFAT or FAT32

the only issue is, my disk is showing was exFAT format. I’ve wiped the disk and reformatted, but still get the same message, and the disk is 100% healthy, so I’m pretty certain it’s a software problem.

Any advice would be appreciated as its left me unable to use my expensive purchase, which if it is a Denon software issue is not a good look and extremely frustrating. I have a hunch it may be related to a Mac OS update, but still these things should surely be ironed out before?

Thanks in advance

Dan

1 Like

You on that new Ventura?

It is indeed related to Mac OS Ventura. You are outa luck for now until they update the engine DJ software which may be difficult as it’s written in qt.io which I am not sure supports Ventura yet (I’m not 100% certain about this, but am pretty sure) . There was a change in the detection of volume types which engine DJ no longer understands, hence it doesn’t think that the target drive is in the correct format. Ventura has been available since June 2022 for developers to test their software against but I guess it wasn’t deemed a priority.

2 Likes

yes. I’m on Ventura. Denon really should have sorted this by now. but hey.

1 Like

Its ridiculous!! If they don’t sort it soon I might have to get rid of the Numark and go back to Pioneer/Rekordbox

they are gonna come at you in 3-2-1

1 Like

Yes, I do have the new OS, but I also have another Macbook with an older system. I updated my prime 4 to run the latest software, and when the hard drive is in the prime 4 it tells me to format it. The drive is in exFAT.

I’ve tried FAT32 as well. . . I’m at my witts end. . . I don’t want to buy another hard drive when this 1TB is completely healthy. :frowning:

If it’s urgent you can use this tool I wrote:

So, I used a Windows computer to reformat my 1 TB HD to exFAT. My Prime 4 still tells me that the drive is not compatible. I somehow think that this isn’t just isolated to compatibility with Ventura.

Any advice?

Thanks in advance.

This might be a total hack but when I have trouble with drives not working properly while the S.M.A.R.T. status is green (have you checked that?) I use the official “SD Card Formatter” from sdcard.org to reformat the drives (yes, even if it’s not an SD card).

That tool totally ignores whatever is written on the disk (like for example unknown/corrupt file systems) and reformats it to NTFS. After that try to reformat the drive to FAT again. If there was some leftover stuff that triggered the player, it will be gone.

Did you format to ExFat with MBR ?

You can also check this article:

Thank you! It might work. I’ll give it a try~ Cheers!

Thank you! Yes, I’ll try everything I can. I really want it to work. I’m such a huge fan of this system, and I love Denon and Numark products!

Been using them in my studio along with my other gear for over 15 years~

UPDATE! So after reformatting on Windows, I got the same error message. I connected and reformatted again with my Mac, and then connected the HD to the Prime 4. Prime 4 is running Engine 2.3.2 = Error message still appears on the device, telling me to format to FAT 32 or exFAT, but then the HD is recognized.

I really do think this might be an Engine 2.3.2 bug because I didn’t have this issue before.

Thanks to everyone for their help! I’ll keep you all posted of any developments.

1 Like

I have the same issue! My SC6000’s work fine. When I try to plug it into my MAC and use Engine DJ the error happens and I cannot transfer any new music or playlists.

Super annoying I have updated all software versions.

Love Denon Hardware, hate Denon software.

1 Like

Come on Denon. We have been waiting a long time for this fix