Prime Go beat jump on 2.3.0, fix needed

Dear Denon Team, I love how active you are with updates and new cool features. :slight_smile: BUT being able to change beat jump size on the fly on the Prime Go is crucial and a basic, needed function. It’s cool that you have separated loop and beat jump in Engine OS but there needs to be a hardware/button solution for the Prime Go and not only through the settings. I can’t imagine anyone is happy with this change.

Maybe Shift + Load 1 / 2 or something? Or Shift + Cue 1 / 2? Anything. Please change this for the next version. I (and surely many others) would like to use the latest version of Engine OS and not have to stay on 2.2.2 or older.

Thanks.

9 Likes

Yes please, I have also made this v painful realization just today…

1 Like

I’m having the same issue with no way to select the size of the beat jump and another one that I realized when I was on stage. After playing a wile on the battery, I was surprised when I start playing the next cued song that I’ve missed the beat, thats odd for me, but I corrected and went on… Than again, and again, and after that i was paying attention to the display, when I saw that the whole unit was freezing for a split second every 8 seconds or so, not the music, but the unit it self. The graphics on the display, the flashing of the play/cue auto loop and all of the other buttons. When I pressed the play button on this exact moment, the same happened as if i did’t pressed it, or it lagged. When I’ve connected the power supply, the problem was little by little wenting away. A have the Prime 4 as well and thouse little freezeings are happaning too, but, on the display only. All of that started after the 2.3.0 update, and I already updated both units to the 2.3.1 and those issues still the same. Our community needs to have those issues taken cared of. Thanks for the Attention DJ Cadu.

Thanks @DjCadu - this is a different issue but yes I have also heard from others that the user interface and even audio lags or stutters on 2.3.0/2.3.1. I am stuck on 2.2.2 because of the beat jump problem so I can not confirm your error myself. Maybe you should start a new thread with this issue?

I see that many people have “liked” my first post about the beat jump issue, I wish we could get even more resonance and I hope someone from the Engine team could explain what the plan is for the Prime Go and this problem.

All you agreeing with this, please speak up and maybe we can at least get a response from the developers. :pray: Sure, there are not as many hardware knob/buttons available on the Prime Go as on the Prime 2 & 4 but a solution must be possible. Because, I mean, we had it until 2.3.0 happened…

1 Like

Moin @Nonip,

I myself have some difficulties to handle the new procedure for the beat jump.

So phps. you may pls. be so kind as to issue a feature request. With this feature request you will arrest most attention and we all can vote for it, provided we have some token left for voting …

Thanks in advance and have a nice day

Brgds from HAM

BeatMaster

1 Like

Thanks for pointing that out, I wasn’t aware of how it goes. I created a feature request for this now, see link below.

Someone already added a great and easy suggestion on how to solve this issue (see the feature request comment in the link). If we all let the Engine team know we want a solution for beat jumping on the Prime Go maybe we’re lucky to get it in a coming update. :slight_smile:

I am also pinging as many as possible (max 4…) of you who clicked “like” here: @DigitalDeceiver @IndigoDeville @TheMaestroDJ @MiguelPimenta - I assume you agree with this being an issue so please click vote in this feature request:

https://community.enginedj.com/t/prime-go-beat-jump-size-adjustment-directly-on-the-device-bring-feature-back/

Thank you!

Just so that the linked thread does not get buried (I can only assume that Prime Go is not the most prioritized hardware), please consider voting on the above linked feature request @kradcliffe @mrtime @Djscottyb @TsubasaK111 … if you didn’t already, that is. I’m pinging you since you liked this thread. I should have created a feature request in the first place, instead of this thread. Thanks and sorry for spamming you :slight_smile:

I would love to have a feature to be able to beat jump using the 4 pads on each side of the deck. This is a crucial feature on other decks.

Your idea could also be a good solution, please post your suggestion in the feature request thread:

https://community.enginedj.com/t/prime-go-beat-jump-size-adjustment-directly-on-the-device-bring-feature-back/

Thank you!

Yep, Nonip, I will start a new thread about this issue, but for sure, I miss the beat jump sizing, I have many songs that, depending on the public, I have to beat jump up to 16 beats. On the prime 4, it is working beautifully, but it wasn’t integrated successfully to the Prime Go

Let’s make some noise until someone answer our needs!

1 Like

Thank you. Yes, we need some kind of solution. I just don’t know if the Engine team will read and respond, so far there has been no official response in the feature request thread.

You have to wonder who in the development team made the decision to change this wthout asking users first, or at least putting an option in to revert to the previous method for people used to the current workflow.

Doesn’t give me confidence in the direction of future development when things like this happen. Also not to mention the various bugs introduced some of which haven’t even been fixed yet …

Denon keep saying they are listening but it seems they’re only listening to themselves.

I have not lost hope personally. :slight_smile: It is common to change things without asking the community. I just think that they have underestimated how important beat jumping has become in the workflow for many DJs. It is not a secondary function which can be hidden in some settings menu. A few years ago mixers did not even have beat jumping at all, nowadays it is absolutely crucial.

The good news is that the fix is easy to implement, they just have to hear us.

1 Like

Hi Everyone,

Thank you for the feedback. Your concerns have been received, and we are currently looking into a solution that brings Beat Jump size adjustment back to the Prime Go. We’ll let you know once it is available.

10 Likes

This is great news! Thank you for listening to us! I hope it will be a fast fix so we can all update to 2.3+ ASAP :partying_face:

Please also see the feature request here: https://community.enginedj.com/t/prime-go-beat-jump-size-adjustment-directly-on-the-device-bring-feature-back/

It includes several ideas on a solution which might be helpful to your team, for example the one from @addie:

I strongly encourage a checkbox in the settings to link loop size with beat jump size (as I written already in another topic). This way it is possible to keep both options and should make almost everybody happy.

1 Like

It’s a beautiful thing! Thanks guys!!!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.