Prime 2 Tempo control lag

Hi everyone, I hope you’re doing well. A quick question please.

Since new, my DJ Prime 2 has the following temporary control issue of the tempo (speed) adjust slider.

When playing a track, the tempo control slider/lever suddenly has zero effect on the speed of the track playing.

To get this to function, I have to move the slider rapidly up and down. It usually fixes itself in under 30 seconds or so. It’s as if the unit is experiencing massive lag.

During this strange phenomena, no change occurs in audible track speed and no LCD read out changes are displayed.

It can effect either deck and I checked ‘Sync’ button on either deck was off, so it’s not that.

Naturally, this has disastrous effects on the mix, as suddenly as it fixes itself again, the speed heard is massively accelerated or decelerated - so you wreck beat matching and thus any mix if recording, as do to an internal SSD.

Possibly of note, I’ve noticed the ‘sensitivity/accuracy’ of the tempo adjust sliders are not perfect. E.g. I can set one deck to +5.1% tempo, but the other jumps to either 5.0% or 4.9%. It’s very rare the decks display the exact same tempo even with very find hand adjustments and patience. I’ve not experienced this on other hardware.

My question is please:

  1. Has anyone experienced this temporary and intermittent failure of the tempo/speed adjust sliders before? E.g. the literally stop working.

  2. Is there a hardware/software fix for this?

Many thanks for any opinions or ideas and all the best.

This may be related to a concept called Soft takeover

Next time you notice it

Move the pitch fader in the direction you would have if you matched the tempo manually rather than sync

1 Like

Thank you for the replies, I appreciate it.

To help explain better:

The unexplained event happens when I have two songs in the mix playing, beatmatched manually, e.g. ‘Sync’ button is off on both decks. Everything is working fine.

Then after mixing out a track on deck A and now listening into deck B, if I try and manually use the slider with my hand to increase the speed on the track that is already playing, e.g. deck B (BPM), nothing happens.

E.g. if both tracks were at +2.0% and I want to increase the pace of the mix so gradually increase the tempo to ÷3.0%, nothing happens to the audio or BPM read out. It’s as if my hand hasn’t touched the metal tempo slider knob.

To fix this problem, I then hurridly push the tempo adjust slider to maximum limits of adjustment of speed, slow/fast. By doing this repeatedly, eventually, the tempo of the track suddenly is reacting to my input on the tempo slider and the speed changes as it should and it all functions normally again. This ‘self-fix’ is without physically touching any buttons.

In essence, I can only describe it as extreme input lag (up to 30 secs or so,) occuring after two tracks have been previously beatmatched and now one of these tracks still actively playing is being manually adjusted in tempo by me using the vertical tempo slider, but to no avail. NB: This all occurs with ‘Sync’ button off.

I’ll see if I can replicate it and video it. What it would show, if successful, is the metal tempo slider knob not causing a reaction to the Prime 2 unit to being pushed up/down, when ‘Sync’ button is off.

1 Like

Did you try updating the firmware to 2.1.1?

Yes thank you. It still does it to this day.

This issue also happens on the Prime 4, SUPER annoying. My group of friends now have 5 prime 4 units, two of them are original launch models and the remaining have been purchsed throughout the years. I just got mine which marks the 6th unit in our crew which would be the newest of the bunch, still does it. I always have to slide the fader drastically which take a few second, sometimes almost 20 seconds of sliding for it to wake up.

1 Like

It’s supposed to.

It’s called “Soft takeover” or “go fetch” to give it another name.

Let’s say the pitch control is on zero

You press auto sync to mix two songs with different BPMs

The machine knows that the pitch difference has to be say…. + 4.2% to make the BPMs match - but it •cant• move the pitch slider, it only changes the pitch of the Slave deck and the bpm and pitch display.

That means that the pitch control is still on zero but the deck/layer is still playing at +4.2% …. Think of this as the physical control is “disconnected” from the pitch/speed that the tune is actually playing at.

Now at this point •don’t• waggle the pitch slider up and down erratically, repeated, or for 200 seconds,., just slide the pitch slider from where it is (at zero in this example) to the pitch that auto sync had to take it to. (+4.2%)…. Also, the Prime 4 has a green led arrow at each end of the pitch control which illuminates to indicate the direction the pitch slide needs to be moved. When the physical slider is at the same pitch as the auto-sync/other layer pitch number, the led arrow goes out

The same thing happens using different layers with different pitch’s in each layer

Its dosnt need to move the pitch fader to correct for a difference in BPM, fader is an input thats all it can be easily changed through the software.My Serato based Denon Mc4000 does not have this issue because its all done in the software. Its just irritating because even with the SYNC off it does it, why? Im not asking for assistance, that function is so intrusive. The only feature that this controller has over the MC4000 in this specific reguard is the ability to reset the fader position by holding shift. On my MC4000 isnt able to do this so sometimes you run into trouble.

Can you post a video of it happening so we can see exactly what you mean please?

That is what these arrows are for.

1 Like

Im not arguing the feature i just wish you could disable it.

1 Like

It’s obvious by your description neither you (or your 5 friends, two of which had units from 2017?) knew about the feature or how to use it until you posted here.

I sincerely do hope Denon gives you an option to disable soft takeover in some future firmware but maaaybe first try using it properly before coming up with a opinion?

1 Like

Ill absolutely give it a go

I’d consider it to be peer-agreement. One friend misunderstands a feature, talks about it in a incorrect and/or accidentally misleading way to friends, and then all the friends get the wrong idea about a feature - in this case, how soft takeover works, and how bad things would be without soft takeover.

I guess you could say that. We all came from Serato or Rekordbox based units which never incorporated such a feature. Denon does not do a great job of explaining this feature, the arrows arnt labeled in the guide booklet. Even after discovering the feature there a no youtube videos going into depth on the feature. Im fairly new to this forum but it is the only place ive been able to find any for of information on it so i am grateful for that. Tried it out last night, still feels so wrong to me lol a disable function would be much appreciated

That’s not true. This feature comes from the computer dj programs to the hardware, as 4 deck controllers and sync usage forced such a feature to be developed to avoid sudden tempo jumps when using same pitch for synced units or multiple layers of control.

1 Like

Your taking what i said out of context. The units we came from never had this feature, i am not speaking of all Serato/Rekordbox units.

Wow but what you said just gave me the Eureka moment. We all came from 2 channel controller, sense is made. I imagine if i disabled the 2 other decks it would behave as i would want

What unit is that?

Both my Denon Mc4000 and Pioneer DDJ-SZ did not.

You sure about that? the DDJ-SZ clearly has LED arrows next to the pitch fader, which on page 8 of the manual are labelled as ‘takeover indicator’

1 Like