Major Major Problem with 2 day old SC6000. Need advice/help ASAP

Two SC6000s (1.5.1. OS) connected to an X1850 (1.1 OS) I received two days ago. I have been playing on them getting to learn my way around, all good no problems. Today I turn on the players and 1. immediately when I start playing on the right player I notice the jog wheel was not registering my hands on them. 2. I also noticed that When I scratched there was a noticeable clicking noise. 3. Trying to dissect the problem I came across another issue where when I scratch no sound plays at all. Equipment is all grounded. What could be the problem? What should I do? Thanks!

See below for videos of this anomaly.


Sounds like a mechanical issue.

Have your tried changing the tension knob (loose/tight)?

What happens when you turn the player face/jog down on a soft surface and back to normal?

Tried turning the tension knob its worst on Heavy. Will try your second suggestion. Does this happen often that I would have to do that?

No not that I know of. It’s just a suggestion.

Can you lift the platter slightly upwards a few millimeters btw? I can and was wondering if that would be normal or could be related as there are internal gears.

If that was mine, I would not sleep until I received a new one. doesn’t sound like anything that can be fixed on this forum IMO.


Yea sending it back today. Seems mechanical.


Good Luck, hope you get something back soon.

Yeah that s-u-c-k-s man. On a positive note, you’ll be able to use the Dual Layer feature of your remaining deck and still play!

Thanks guys.

If it brings you any comfort I’m having a similar issue with mine (no clicking but the player is confused if it is in Vinyl mode or not, and is not registering hand input on the jog wheel). I made a post about it with a video on their Facebook page. I was hoping it would be something software related to avoid having to send it back but I’ve tried everything I can think of to t-shoot, to no avail. - Marc

Hello djm101, Sorry to hear that bro. Glad to know that it’s not an isolated incident, but bummed out others are experiencing it too. However, it does make me feel good to know that Denon is now aware of this issue and hopefully is figuring out a solution.

Being an early adopter has its risks :weary:

Good luck with everything!

Thanks man, and likewise. Fingers crossed they can fix with a software update.

@Vandetta - I think I made some good progress this morning. I took a fresh SDXC card I had, copied my library to it, and so far the problem went away! I’m wondering if the issue was that the USB thumb drive I was using was not up to par and these units need high speed devices, who knows. In any event, try using an SDXC card instead if you can and see if that helps.

How many problems have been put on this one story? Or did the sdxc card help the platter ?

My issue was the platter slipping out of Vinyl mode. Using this card seems to have fixed it:

How slow was the previous SD card?

No idea, it was not an SD card, but a USB thumb drive.

False Alarm, I’ve been mixing for about an hour now and it’s still slipping on the SD card.

Interesting, ah welp we must wait on Denon. Fingers crossed.

I’ve made a bug report. Devs are aware.