Loops drifting out of sync

I know a few have grumbled about this but I have never really seen an answer besides ‘make sure your tracks are analysed properly’. My tracks all match perfectly in the mix but as soon as I activate a loop (either manually or using auto-loop) they drift out of time after one or two plays. This happens regardless of whether it is an 8 bar loop or a half bar loop and it happens in both the software and on the controller (Prime Go). Hitting sync continuously brings them back in time but it still sounds sloppy. I therefore never trust the loops in Engine when I am recording a mix (whereas on the Pioneer controllers I have 100% faith in the loop feature). Does anyone else have this issue and if so do you have any ideas on how to resolve it? Thanks all in advance for any help!

Can you post a video? in my experience this is caused by either tracks not being consistent in gaps between the beat (causing the loop to be short or long of the end beat) or poor timing when activating the loop, which takes a good amount of practise to perfect. I learnt to loop on the original CDJ-800 that was fully manual so it had to be perfect with the in and out, modern auto loop functions are much more accurate, quantise can assist with this however I dont use it myself.

Edit: or at last provide the 2 tracks you’re struggling to keep in time, where they were sourced etc, that way we can try and work out why it might be drifting.

Thanks for the reply STU-C! Yes I agree in that it sounds like the loop is not accurate but it feels more buggy than that. If the autoloop is set to 4 beats and quantize is active then you expect it to have no gaps but it is usually okay for the first couple of loops then it drifts out - if I do nothing it will correct and then drift out again. I have been DJing for 30+ years and have experience from 1210’s through all incarnations of the CDJ, NI Traktor, Djay Pro and have been a staunch Denon fan for 2 years but the Engine looping has always flummoxed me why it is not as tight as it should be. I will try and get a video together and will play around with the grid markers to see if I can bypass the issue but my point is this: with other software I have never had to do this - if the beat grids are aligned well enough for a tight mix then the loop should just be bang on every time. Thanks again for taking the time to reply - much appreciated. :slight_smile:

I use looping loads at my gigs (quite eclectic mix of should, disco, RnB, breaks, house, downtempo etc) to mix in and out of tracks and ive never felt the Prime 2 is any different than any other gear I use or have used, certainly no noticeable issues that dont occur anywhere else. I currently also use Serato but had a residency at a venue with CDJ Nexus setup for years too so used gear right across the board.

Hello, exactly the same thing happens to me.

I play with loops a lot in my mixes, and with SYNC on, if you loop 4,8, 16, or whatever, it goes out of sync. The same thing happens if I use beat jump, as soon as I use any range, it goes out of rhythm and I have to press SYNC twice (off and on again) for the tracks to match the kick.

That did not happen in 1.X.X or 2.X.X, it is from 3.0 onwards.

Can you post a video showing the problem, with example track names so people can try to recreate.

Okay, tomorrow I record a video in 1.6.1 and another in 3.3.0 on the computer (it happens the same on the computer and in Prime 4)

Make sure to include as much detail as possible so people can see the issue clearly.

If you’re rolling back to 1.6.1 you may run into issues. I wouldn’t go that far back with these firmwares.

There’s been mixer firmware updates and a few other things like database compatibility etc so rolling too far back isn’t advised. It could be V2.0 but I do think 2.3 is one of the earliest from memory. Maybe someone will be along to let you know.

As for the loops drifting out, I’ve seen it reported elsewhere. Check the tunes aren’t vinyl rips and reanalyse the affected tracks in Engine DJ again (right click from the library). If you can get another copy of the tracks to compare (maybe a streaming store or another download). See how it compares to the one that you have issues with.

If you search “Drifting loops) on here you do get a few other hits and there’s some advise but they is pretty much what there is in the above posts.

As Stu said, see if you can record a short video an we can have a look over it all.

Remember if you’re manual looping there’s also the “smart” option in the menu.

1 Like

I seem to remember a change to the way sync works, a couple of years ago now. If you’re still trying to do it the “old way” maybe that’s the issue?

@STU-C hi, here the vídeos of the problem:

Engine Prime 1.6.1:

EngineDj 3.3.0:

It’s not a problem with the tracks, it’s a problem with the EngineDj version.


Its not really clear but aren’t you hitting beat jump there?

Yes, I’m hitting Beat Jump there, to show that in 1.6.1 it doesn’t desynchronize the kicks, but in 3.3.0 it does.

slow down the tempo of the master song. So that the pitch range decreases. + 12.7 percent is quite a lot, if you are going to beat jump. Test and see what happens. I always try to even out the pitch range so that one song doesn’t take all the adjustment.

1 Like

No matter what tempo range you use, even if it goes to 0%, the kicks do not match when using beat jump, it is a problem with EngineDj 3.X.X

Also, that’s one of the tempo speeds I use to play, I use anywhere from 130 to 165, it depends on the style of music I’m playing at the time, and it happens every time.

Ive just been looping one track and beat jumping another back and forth by a range of different beats for about 5 minutes and it never missed a beat.

Are you sure it’s not just your timing that is out? are you using a bluetooth mouse to trigger it?

1 Like

I’m not a fan of wireless, I use everything only by cable, plus it doesn’t make sense, since exactly the same thing happens in Prime 4 in 3.3.0.

The problem is in the track that is active in LEAD, I just tested with the same track, at pitch 0 in the two engine versions in the two trays and the problem is only seen in 3.3.0:

same problem here - beats are matched with sync activated until the loop starts. my current workaround is to always turn off sync before starting the loop.

1 Like

that’s a good shout - I will try that next time mate :+1:

what I also observed with activated sync buttons is the following. when the loop is activated while playing the track, it becomes async. However, if the loop is already activated when the track is started, it remains sync.

can anyone reproduce the behavior?