Issues with my BRAND NEW X1850 Mixer not reading BPM's! Help!

It’s not working always for me too.

If you press the Engine button on the mixer. And the engine connect screen appears on the players, how does it look like?

As well one player that is not assigned?

Noiseriser already stated it, but could you tell us on what channels layers A are and which ethernet you use per deck?

I also wrote up this BPM FX post in the past:

Not really the same but to give an idea.

Yep, it looks exactly the same as what you have in the photo. Only shows the right player connected.

  • Left player Layer A is on Channel 1, Layer B is on Channel 2 - LAN connected to Link 1
  • Right player Layer A is on Channel 4, Layer B is on Channel 3 - LAN connected to Link 4
  1. Left Player Layer A Coaxial Connected to Digital In No. 1
  2. Left Player Layer B Coaxial Connected to Digital In No. 2
  3. Right Player Layer A Coaxial Connected to Digital In No. 4
  4. Right Player Layer B Coaxial Connected to Digital In No. 3
1 Like

This seems to be correct

And yes, I am going by the active layer with the channel fader up in the FX assignment.

Try restarting the left player 1-2 times and if that is not working restart the mixer as well. I know it’s annoying :expressionless:

I will try any and everything necessary to get it working, so thanks. And yes, I have tried every combination of powering off/on and restarting already.

I have the same issue with a brand new X1850 with firmware from the box: 1.3.

I already requested help from support by email. I haven’t received an answer yet.

I reported the missing firmware update too:

Gents, there should new installers soon, but I have no ETA yet.

2 Likes

Good news! Thanks @Reese

The DJ Lab talked about it today as well and had a good found with the IP addresses. That could be the issue?! YouTube

1 Like

Ok, sounds good. I hope we hear something soon. Thanks for the input everyone!

I just watched Steves video on YouTube and I don’t have this problem.

Sorry to hear you guys do.

I use ports 2&3 in a 3-1-2-4 (B-A : A-B) mixer configuration (digital)

Engine connect always works under auto mode and BPM follows without a hitch plus cue buttons light as to my selected deck colours.

I switch on all units same time.

What X1850 firmware do you have?

Firmware Version 1.5

I have 1.3 from the store, seems most users with the issue have 1.3.

I wonder why Denon removed the 1.5 version download link?

Someone has the 1.5 firmware file?

Maybe a 1.6 is in the making :ok_hand::ok_hand::ok_hand:… Shouldn’t remove 1.5 tho. Site Error.

1 Like

Read above please.

Im on 1.5 and have still sometimes the issues.

Lets hope for a quick release of 1.6 :crossed_fingers:

1 Like

I was able to use Steve’s method and it worked, it is just a very involved process just to use my DJ setup. I will see if I am able to get it to work again after I power down and restart.

I am actually thinking about changing my mixer configuration the way you have it @Ravinstomper . I don’t seem to have the problem as much on channels 2, 3, and 4. Only once in a blue moon. But channel 1 the problem is consistent. I pray 1.6 is dropping soon. I have 1.3.

1 Like