Exported playlist not showing on USB drive. Engine not adding either (2.3.X)

When I export my playlist to USB, the sync manager prompts me that it might overwrite data, I click yes, then absolutely nothing. It just says “completed” even though i know I have gigabytes worth of data to move over. This kinda makes my SC5000s useless.

EDIT: before anyone asks. I’ve tried multiple drives and freshly formatted drives as well. Same issue.


I am also having this issue, on two different computers, one Mac, one PC. Everything was working fine two weeks ago. Tried with existing drive that was previously loaded from Engine and again after formatting the drive.

1 Like

A question that may seem trivial, but that other users sometimes forget: after clicking on “Sync Manager”, did you check the playlists you want to transfer from your computer to your USB stick? It only transfers the selected playlists.

1 Like

Yeah I did. I usually export all my playlist on my drive.

I also tried with a freshly formatted drive and I had the same issues. This didn’t prompt me to overwrite, which is what I thought might’ve caused it originally, but still never exported anything.

Strangely, on the freshly formated drive, it would copy over all of the actual songs, but wouldn’t create a database for the tracks.

Even stranger. After I renamed my playlist, it exported the playlist, but had no music in it. I then manually dragged the music over and it finally exported.

Never had this issue before.

I also tried rolling back to 2.2.X but that didn’t make any change. I also rollback all my recent windows updates, since I thought maybe it was caused by the win11 22H2 update, but the same thing happened. It even was happening on a completely seperate PC running win10 that I specifically do not update for reasons like this.

My drives are formatted at fat32 as well incase that came up.

It’s really weird, but also extremely inconvenient when you’ve trusted it for years and you’re 2 hours from leaving for a show and it doesn’t work…

1 Like

Did you try with a new database?

I am experiencing all of this as well!! Denon! Engine DJ Software team! Please help us ASAP!

1 Like

I’m experiencing something similar, where Im unable to add any tracks to new playlists I create. It started doing this suddenly yesterday, but the day before it was working fine. I then decided to try engine on a different mac, exactly the same thing. 2x different mac’s & 2x different drives doing the same thing. How is that possible? and more importantly, how do I fix this?

will be nice if someone can help, few weeks all was working fine , now I make new playlists and I can’t add them to my internal hard drive in prime4. I can’t even make some usb stick with few songs as a playlists. making same with old recordbox… no issues. at this moment I need to make playlists in record box - export them to my rekordbox hard drive and ply from this on party… not nice when I have 1TB in the Prime4…

Same here since 2.3.2 with 2.3.1 desktop can’t transfer to any media device

Me too using engine 2.3.2 and sync manager trying to export playlists from main collection on PC to usb stick, highlight required playlists try to export to freshly formatted usb drive and a few secont later transfer completes, contents of stick is the database folder and no music files, try to export second time, takes a minute or 2, audio files transfer but structure does not, only have main collection available but no playlists. Using windows 11 pro updated to 2H22 today but problem existed before and after system update any help much appreciated

Same ISSUE here.

After format the usb and export whole collection again. All tracks are exported but NO playlists are visible.


1 Like

Have solved issue for me in that my playlist structure is similar to the folder structure on the drive my main collection is stored.

I manually deleted each of my playlists in Engine one by one and re imported them back into Engine from these folders without deleting the original library files (this would have removed performance info from tracks) after this process tried an export to a thumb drive and all worked cue points loops etc stil there and still present and working working.

Have a large collection and this process took me around an hour (Engine analysing files) which is much better than the hundreds of hours it would have taken if I’d deleted my library info.

Hope this helps folks as I said it worked for me

Update time, the process above worked for an initial transfer but on trying a second export, back to the original problem​:unamused::unamused::unamused:

1 Like


still no solution.

how is this possible? Are there more people with this issue?

Anyone help please? nothing changed in my situation.

tracks are exported to usb drive but playlist are not showing on USB… after 3 weeks still no solution


all I’ve been able to do is just manually drag new playlist over 1 or 2 times and it SOMETIMES works. If i rename the playlist and try this, it seems to have better luck

Has to be some form of corruption introduced in an update, because rolling back engine versions doesn’t do anything either. This is really bad


is their a way to do this without nuking what I already have?

looks like i have found the place where we are having the same issue, exporting play lists are not exported correctly, in my instance it creats a database 2 directory and no music folder so wont see any music in the playlist on either the sc6000’s or just reading the HDD, the datas just not there.

Its only doing this on the new crates i have created, (last week early nov )the old ones from last month transfer across without issue. database 2 and music directory.

i have also tried formatting many usb sticks, all working previously and all with the same issue on these troublesome new playlists. Its baffling me what the issue is…

same as this, whole eco system is buggered for anything new

update : now doing this with all the playlist exports, not just new ones. managed to clear down a working usb stick, and thought id just freshly export all the old stuff as a back up and managed to fail exporting anything… this isnt a good place to be in right now.

Having this issue along 2 other DJs I know. This is actually really dealbreaking. After sync is completed the files are on transfered, but not the actual playlist information. it’s one huge collection without playlists.

Is there any way we can help debug this? logs? whatever?

Tried formatting drives, different sticks. A strange thing: first time you sync it completes “instantly” second time you click sync it actaully copies all the tracks, but information about playlist is not transfered

This is actually a HUGE bug that needs attention ASAP :heart: