Engine Prime 1.2.2 Not Working

I’ve got a Windows 10 PC that I use for prepping the music for my stick.

Since the 1.2.2 update, its now now showing in the screen. I can install it, launch it, the splash screen shows but then I’m left with the icon in the bottom bar and when you hover over it, theres just a plain white screen.

Any help would be great.

This sounds like it may be video card related. Can you make sure you have the most recent version of your graphics card drive installed? If that still doesn’t help, check back with us.

1 Like

Cheers Vince. I’ll have a look into that. Im sure its the latest driver. I have a Nvidia 1050i but i’ll go check it out just now :slight_smile: :+1:

Do you use a second monitor sometimes by any chance? I’ve had this happen when on a dual monitor setup and moving prime app to the secondary display, then when the second monitor is disconnected, this happens.

Have a look here. On my laptop I had an Intel card and a Nvidia card. Just needed to start it once with the Nvidia card and from then on it worked…

Hello, I had the same problem with the versione 1.3.3: Engine Prime doesn’t want to start returning a white screen. I have tried all the advices you had given (switch monitors, switch graphic card engine, clean the various directories and reinstalling the software…). Nothing! So I have tried to clean als the Windows Registry, after uninstalling the software. Then I have reinstalled Prime and… wow… It started correctly.

Hover the mouse pointer over the taskbar application icon, right click on it an select “maximize”.

Hi All, I randomly started to get the unable to load due to white screen issue with v1.51 and i finally resolved it. My database was saved onto my USB, so i didnt care about deleting/renaming things on my C: drive but you can make a backup of the Database files in the Engine Prime Folder in your default Music Directory.

Actions Taken:

  1. Uninstall Engine Prime.
  2. Rename ‘Engine Library’ Folder in ‘Music’ Directory to “Engine Library.old”
  3. Go to C:\Users<User name>\AppData\Local\ Rename “Air Music Technology” directory to “Air Music Technology.OLD”
  4. Go Start Run “Regedt32” which opens Registry Editor. Go to HKEY_CURRENT_USER\Software In here, there an ‘Air Music Technology’ folder, right click on this folder and rename it to ‘Air Music Technology.old’. 5 Reinstall Engine Prime and it opened fine.

Just wanted to share the solution with everyone.