Engine DJ v2.4.0 Now Available - Ventura Support, Beat Grid Editor, Relocate Missing Files + More

Probably you have some media (bad/slow stick) or db issues. I have no loading/speed issues on 3 linked SC5000’S on 2.4.0 Try formatting your external media and re-exporting from latest Engine DJ.

Haha, once I watched him rant for over an hour about some TV he bought not having the advertised feature set that he claimed it had. I even commented during the Livestream asking him how this was relevant to his channel. Haha!!

I know that dude is kinda’ crotchety, but he has made a few videos worth a damn, and like I said before, he is a pretty good DJ. He has great taste in House & DnB anyway. But, he doesn’t have the right personality to have a successful channel like Phil, Mojaxx, or Jamie.

1 Like

Yeah that’s half the issue isn’t it, your voice needs to come across in a clear and positive manner and it’s difficult to achieve.

I have listened to a few of his mini mixes before and he does have some good stuff.

Mr clickbate does occasionally find the occasional workaround but is out of his depth when it comes to getting to the crux of most things.

He specialises in “watch til the end (so I get full searchbot points)” and over-the-top gasp-shock-horror style sensationalism. Both of which are tedious to the extreme.

1 Like

This is 4 year old advice that I’ve tried and it never makes a difference. I’ve used 5 different harddrive and thumbdrives, yet the slow loading/searching persists. 2.4 is the worst firmware to date with how long it takes to load and search for tracks.

I just uploaded these for proof. Because these things don’t seem to exist around here unless every single person has the same damn problem:

Slow load 1: Denon firmware 2.4 SLOW LOAD 1 - YouTube

Slow load 2: Denon firmware 2.4 Slow load 2 - YouTube

Slow load 3: Denon firmware 2.4 Slow load 3 - YouTube


I have noticed the same issue as well.

My observation is that

  1. It happens on the networked player
  2. Happens at the first load
  3. It can happen again if say first load I only searched pulled a from a Main Playlist. If I go to a secondary playlist it will happen again.
  4. But following that initial search at main and sub playlist level, it performs as expected for the rest of that evening as song as I don’t switch to another source drive.

Hopefully they can improve on this.

I have tried with 20gb collection on 256gb SD and 400gb collection on 500gb SSD…similar outcome.


hi guys, just bought a MacBook Air m2 with Monterey os , when I try to install Engine dj v2.4.0 it says I need rosetta. i was under the assumption engine dj had m1/m2 support ? why do I need rosetta ?

Needing Rosetta is not a defining factor in whether the software is supported or not, if it works with Rosetta it works, so nothing to worry about.

ok tnx installing now !

Serato has been running on it since the M1s first appeared. Im not saying its ‘optimised’ but its all we got for now :slight_smile:

That’s an issue for quite some software companies, they use that term in an inaccurate way.

Basically any X64 application (minus some really specialized stuff or games which require certain APIs etc.) runs on M1 thanks to Rosetta. And it’s one of the reasons why I love ARM Macs, after being quite skeptical about the Intel->ARM switch first. I even managed to run a 32-bit legacy indie app (Spek) from 2013 (!) with a Github 64-bit fork from 2017 on it with zero issues.

The correct term for full / optimized support should be “native M-Chip support” which equals universal binary. And only this should get advertised by app developers. As Stu said, Serato (still) lacks it as well. Oh, same for Rekordbox and Traktor. Which is quite sad after >2y of time - otherwise my 16" M1 Pro has such raw horsepower that Serato runs flawlessly on it. I don’t even require wall power, 7hrs+ on battery is no problem.

To give you an idea of the mentality of these software companies. EA are releasing their ‘next gen’ golf game in March at 30fps console… this is so their game can still be compatible with last gen consoles at minimum expense to them.

I’m this case it’s just easier for them to keep using Rosetta as it’s the path of least resistance, all about the $$$$

I thought I read a while back Rosetta 2 was being removed in some regions? Maybe Apple are infringing on something? It could mean some areas could not get M1 support.

Just found it: Rosetta May Be Removed From M1 Macs in Some Regions on macOS 11.3 - MacRumors

Looking at it, it was almost two years ago. I’m not sure if anything came from it.

1 Like

As far as I’m aware Engine DJ v2.4.0 does have "Native M-Chip support” - Activity monitor shows it as Apple ‘kind’ as apposed to Intel which Serato shows.

Engine DJ is not requiring Rosetta 2 to run. We all remember the speed boost we got when Engine DJ switched to Apple Silicon. There may be some scripts which are running during installation which are requiring Rosetta but that is all.

Denon DJ did a good job compared to other companies like NI for Traktor Pro which is sill not a native app :slight_smile:

BGE doesnt work, not at all