Engine 2.2- sync and manual playlist updating no longer work

After updating Prime 4 and Engine to 2.2, Sync feature completely fails. No new tracks or playlists are added to the Prime 4, despite receiving the “export completed” message. I even tried manually dragging a new playlist from Engine into Prime 4 and it refuses to add it. Can only successfully manually drag SONGS from an existing folder in Engine to an existing folder on Prime 4.

3 Likes

I have the same issue…. This should be a P1 issue!

i cant even create a playlist and drag songs into it. Whats going on?

i can create the playlist folder, but i cant drag or add any songs to it at all. absolutely atrocious!!!

Yes, atrocious is the word. I wasn’t able to do my show Saturday night since I couldnt load any of my show prep.

Are you using a PC with Windows 11 OS ???

same here cant add songs to playlists, rolled back to previous version

Nope, still on Windows 10. Thanks.

Samen1, I’m likely going to roll back to 2.1 too. Never performed a rollback to a previous version before- did you just run the 2.1 installs (OS and Prime 4) like normal and they override 2.2 seamlessly? Just curious if it went well or if there’s anything i need to be careful about when rolling back. Thanks.

You all had at least the version Engine Dj Desktop 2.1 before the update ???

first delete the 2.2 version and reinstall 2.1 , tested the SD card on prime GO updated to 2.2 and it works there

DjMell26, i had 2.1 on OS and the Prime 4 prior to updating to 2.2 last week.

Has anyone heard from Denon anywhere else about looking into this issue yet? Cant afford to miss another show this weekend but if theres no remedy coming soon, Im going to go back to 2.1.

I opened a post with the solution! I formatted both the internal ssd of the prime 4 and the ssd card of the mixstream pro and also an external ssd that I used to backup! then I re-exported the whole library again on all external ssd devices etc! without making any changes to the mac library! now everything has become much faster than before to export! it took me all evening but now everything is back in place!

I appreciate you taking the time to respond with your solution, DjValeno but that is too extreme for me to undertake to accommodate a Denon update. Unless Denon can provide a fix in the next day or so, im going to try rolling back to 2.1. Im also on Windows rather than a Mac, so no guarantee that your solution would work the same for me, but again, i do appreciate your time in responding!

if you want to see if it works take a new usb or format one you already have! and try to export some playlis! it’s easier than downgrading! do not you think ? I re-exported all my playlists to three external devices in one night! and that’s 500 gb of playlists!

Ok, ill have to consider that temporarily, though since I’m adding new music every week I’d be stuck with this manual workaround with USBs repeatedly in meantime… but im glad to know this is another option! And that it worked for you, even with that large amount of GBs!

you did not understand and the definitive solution, if you do as I told you everything will work as before! I tried, after you have formatted and re-imported the whole library it goes back to working as before, and you can add new music every day if you want! because this procedure solves the problem I have already verified you can go back to adding music whenever you want! hope you understand!and as if the problem were the compatibility between the old library, ie that of version 2.1 and passing to 2.2 creates compatibility problems! then by recreating the external libraries everything falls into place

Ok, got it. Thanks for the clarification!

Is it safe to use 2.1 on computer to prepare everything and 2.2 as OS on the players (sc5000M)?

Updated everything to 2.2 but the software was :-1:t2::-1:t2::-1:t2:. Not able to make playlists, move/copy songs. Downgraded on the Mac to 2.1 but no time to do it on the players.