Engine 2.2- sync and manual playlist updating no longer work

My button loop triggers don’t work as of 2.2.0. Anyone else?

You and me both, Kurt. I turned over my log and db files to Denon on Monday so hoping to get an answer soon. Extremely frustrating not being able to import new playlists, etc. Im guessing Logan will share the findings in this chain but I’ll do so if he doesnt. What we need is a fix to be rolled out since its clearly a widespread problem.

This sounds like the same issue I’m having in mac. Shockingly bad to have not caught such an obvious issue before releasing the update… And even more so the fact that it’s still not fixed a month after release.

This is the sort of thing that sets Pioneer apart. People love them for the rock solid reliability and right now Denon are unfortunatley doing a great job of proving themselves to be on the opposite end of that spectrum.

Although I agree that this problem should be sorted out asap I disagree with your Pioneer comment, they too are having a lot of software problems with their latest update and also on their hardware, the RX3 is an absolute nightmare at the moment! Just go on their forum or Facebook and read the comments :stuck_out_tongue_winking_eye:

It’s one thing for new hardware to have some bugs right on release, but it’s something entirely different to release updates for an entire ecosystem that removes basic functions to the point that people are rolling back.

Edit: I’m literally using rekordbox for prep and organization instead of engine(because it isn’t working properly). So In other words… Their competiton is currently a solution.

1 Like

On a positive note, I did hear back from Denon a couple days ago and they do have a fix for this that they say is “imminent” but no specific date is being shared. They are currently testing it so Ive decided to hold out for the fix rollout instead of going back to 2.1 since the fix should be available soon. It’s mind-boggling to me how this problem wasn’t discovered by negative testing before rolling out 2.2. Makes me wonder if any testing is happening before any of these updates, given they broke the various sound effects several versions ago too.

1 Like

Thanks for sharing!

The latest update v.2.2.1 did not solve this problem. I am now back to v.2.1.0 Are there any users with better results? To reformat my disks and create a new DB is really a bridge too far for me. I’ll stick with the 2.1.0 version for now. Hopefully in an upcoming update there will be better control (testing) than what we’re dealing with now. This should never happen again Engine DJ.

I wasn’t even aware that 2.2.1 had been released. I normally get an email informing of updates, but not this time. I’ll download it later today and report back here tonight on whether I had better results than you, DJ Manis.

Solved it for me.

Edit: actually it didn’t. Auto sync is working again with external drives and I am able to create playlists and add tunes via direct import (from finder) but rekodbox/serato/itunes import still isn’t working.

It appears to have worked for me. Sync placed new folders and tracks onto my Prime 4 SSD and histories were successfully saved to my computer. I dont use any of the other sources you mention (Rekordbox, etc.) so can’t comment on those.