Denon sc5000m stuck on Engine OS Screen will not update

Receiving an error Whenever I tried to update the firmware The player is stuck on the Engine OS screen

That is the screen that says it is waiting for Your pc to start updating.

1 Like

nah…now the 2nd unit screen is blank…these units are defective… The Denon Tech Support Team claims it probably a hardware issue…SMH I have had these less than a week… It has to be a way to reset these back to original specs without opening these up…I tried holding down the “media eject” / “Layer” and “Preference Utility” buttons while powering them on and…nothing…same result. Im am sooo upset…I spent too much money for this to happen.

I have sc5000M’s, when Engine OS logo and a microchip is on the screen - that is a mode to upload the firmware on the deck from the computer. If computer does not see tge deck via usb cable, than it will not update. If the decks are bricked - than only service.

For the 5000’s it’s:

  • SOURCE + EJECT + LAYER > Power ON.

Try powering OFF by holding the power button for more than 5 seconds. After that draining it’s power completely (power ON a few times without power cable).

The one that’s already in update mode, can you connect that unit to a computer and update from there? Perhaps trying another USB or computer entirely.

Do you maybe know which firmware version were on these?

Okay and the other one?

Which one is fixed now?

the one that was blank in the original picture…the one on the right.

1 Like

A’ight. What is the one with the computer mode icon doing now?

it’s back to being a blank screen. I have a return and replacement order in with my dealer now. Hopefully by the end of next week I will have new ones.

I just had an issue with the new feature OTA updates going from 1.6.0 to 1.6.1 . The players got stuck at the same screen. I connected a PC with the USB 3.0 cable supplied and ran the PC updater software to update the firmware and recovered the players.

1 Like

I will keep that in mind in the future