Denon prime 4 touchscreen becomes unresponsive?

I just got prime 4 and It has happened to me twice now that the touchscreen becomes unresponsive, I am not sure if it happens upon boot up as I use the buttons to load tracks to the decks and then I go to search and I can’t search because hitting search does nothing, I then go to to shut the unit off and I can’t even do that because when the prompt comes on to turn off the unit I can even say ok the touchscreen is unresponsive. I have to do a hard shut down of the unit, hold power until the unit turns off. I haven’t used the unit during an event yet as I am a mobile dj, but this kind of scares me, what happens if this happens during a set and I have the turn the whole thing off? Has anyone else experience this, is there a fix? I am running Engine OS 2.4.0.

Mine did this when staring cold. 1st cold boot and the touchscreen did not respond. When left on for a minute and then forced shutdown and boot afterwards and everything worked fine. It seemed like it needed to warm up for the touchscreen to work. I have contacted the store and they advised me to send it back.

The same thing happens to me, when it doesn’t go the first time what I do is turn it off and then it usually goes, after this it doesn’t fail again, but it makes me very angry that it fails like this… today I updated it to version 3.0.0 Let’s see how it goes…it’s still under warranty but I’m too lazy to send it and have them return it just the same so it doesn’t fail them.

Confirmed when the screen is cold is blocked, but when heating later goes perfectly and does not fail at all … that could not be fixed with an update? … From what I see it happens to more people … and bothers a lot.

Did the upgrade to 3.0.0 fix the issue?

no way…!!! The fact is that it only happens the first time you turn it on, then it goes perfectly… it’s a very rare thing, and it seems that there are more cases.

It sounds like the screen digitiser isn’t liking cold temperature. Are the units within the spec temperature tolerances? My Sony XM3s have a touch area that fails a lot in the cold apparently.

It could be a hardware issue but maybe they could counteract it with a shaft ware tweak. Maybe it will be something for support and direct them here so there is others kept in the loop.

The funny thing is that you keep it on for a while and when you reconnect it it goes great… and to say that during the summer months it never fails, that’s why it must certainly be when it’s cold.

Unresponsive screens happen once every few weeks on one of my SC5000’s as well. Restarting the device fixes it. It’s unacceptable Denon never caught this stuff prior to releasing their products though.

Hi, I have recently sent my prime 4. To a tech to get it serviced, all 4 channel faders changed… Tech, did the service plus changed the faders. Came to test, and there was no lcd, touchscreen still work as he reckons. So had to replace lcd screen at a ridiculous cost. Lcd screen purchased from Inmusic as an original part. On new lcd the touchscreen isn’t working so now can’t even try to load my sd card or anything as need touchscreen to get throu, changing settings. Dj profile, ect. Only way I could check all faders worked ect was to just run plain mp3 files from USB and let the prime anylise ect. And use central selection knob. I didn’t realised I used the touchscreen so much, till it came back and I couldn’t do anything. So basically I am asking do you think my problem is the same as this thread…? Secondly do you think there is anything I can try to resolve this before I send it in to inmusic…? I think I have covered, the situation any questions please ask all i would like is my prime back to everything working. The 18 months I had it before I broke the channel faders, weres amazeballs lol. Not 1 single issue, and I brought it 2nd hand.

My prime 4 if I leave it on for a while, then I unplug it from the current and when I plug it back in it works fine, what I have clear is that it doesn’t work when it’s cold… last summer it was great for me… it’s Something very rare and I am surprised that Dennon does not do something if there are enough cases.

Hi Thanks for your reply I give it a bash… I have got a ticket pending… So if this doesn’t resolve then I will have to send it in… This never happened on my old screen… Just seems well weird…

This fix doesn’t seem to be working for me… I leave it on for a bit more and try again… Tried different kettle cables and different sockets… The unit is on 2.2.2… Would that make any difference, at all tried to update it with USB but it just won’t have it… Its on 2.2.2 cause that was the last update that was avaible before I broke the last fader and couldn’t mix any more lol…