Decks Freezing!

Hey all, I’m having a really irritating issue with my P4…

I will load a track onto the deck and press the play/pause button. The Green LED will go solid green to show the track is playing but the track does not play. Press the button again and it will go back to flashing green.

This seems to be a problem with both decks 2 & 4 and is really frustrating! The led ring around the jog turns white whilst it does this (It must be thinking that I am touching the jog wheel?)

I have a feeling this is a known issue by Denon but as it stands I do not feel confident using the P4 at any gigs (not that I have any at the moment, stupid coronavirus)

This is an intermittent problem but still and annoying one… so far not very impressed by the whole denon system, engine prime is pants and the P4 isn’t filling me with confidence!

More details need to be given. What is yours music source ? Like a flash drive (what brand) or serato or (heaven help us, Virtual dJ) streaming’s , or internal SSD, external HDD, Weere you recording artist the time? What length are the music files ? What else was plugged into usb holes

Crazy Long files can cause issues , like trying to play back last weeks 5 hour recording as a cheat track this week. Slow/cheap/knock off flash drives can grind to a halt, and charging a iPad from usb holes won’t leave much current in the usb piers for much else usb to carry on working . I’m not aware of any major denon prime 4 playback issues, just a few individual owner ones. Does this happens on all files played? Make a note of which tracks freeze and see if those same tracks always always freeze - it’s seldom, if ever, truly random

Only issue is that denon only release the really needed firmware and software updates when Haley’s comet is passing and when the release has been signed off by both Santa and The Tooth Fairy

I found one other instance of it - 17 days ago, hardly an epidemic, and the problem went when the OP got his Prime4 swapped out for a replacement.

If it were some hardware or firmware fault then rather the every prime 4 and every prime 4 user would be a hollaring.

My Prime4 only exhibited “won’t play” in the two instances above, a 80 minute non-stop track i was trying to load and also when A friend had a knock off Not-Corsair flash stick

Music source is from a USB 3.1 Drive - 128gb, Sandisk - up to 130mb read speed

Wasn’t recording and I was just playing standard 3/4/5 minute tracks

I don’t charge anything from my USB ports

Can happen with any track I load in, regardless of wether it’s been played before or not

I have contacted my supplier to get a replacement but with the current situation, it could be a while before I can get a replacement!

Hello @djwdiscos,
First would be good to know some things: Do You have stickers still on the jog wheels? Did You tried with a vinyl mode off? Does the problem still show up in different locations (like other house, club, etc)??

This looks a bit like a jog wheel grounding problem.

Hi @NoiseRiser

Yes the stickers are off, so far only happened at home but I’ve tried with different ring circuits in my house and it still happens

I did try with Both vinyl & CD mode, CD mode will not acknowledge any touch on the jog except for +/- adjustments

I have noticed that calibrating the jog wheel touch sensitivity will fix the issue so I guess that’s a temporary work around whilst I investigate this further with my dealer

The grounding problem you mention, would that be hardware of software, I presume hardware but I could be wrong!

Seems like you’ve found an earth problem in your house. Some houses share one earth to all floors so trying upstairs against downstairs won’t always bring different results on earth amount.

Try a friends house.

Also check extension cables . Maybe the cables you use at gigs are earthed really well but the one used at home is poor earthed

This is not related to software and does not have to be your device hardware as well.

Could be also bad grounding at home. I had this issue with my SC5000 players when I bought new house and moved, the electricity there was made in oldschool way, and grounding was bad. I improved the grounding by driving 3 pcs of 1.5m long steel rods to the ground and connected them with special grounding wire (6mm^2) to the main grounding - this solved my grounding issues in the whole house and improved the overall house electric system.

But this does not have to be the case in Your scenario. Check some other locations not only Your own building.

If it’s a grounding issue, should it not affect the whole unit rather than deck 2/4 ?


The jog wheel ring being white means the deck isn’t “on air”. It changes colour when you move the channel slider up? Is your USB FAT32 or ExFAT?

USB is FAT32, has been since December and have never had a problem with it

Fader doesn’t make a difference, jog wheel thinks I’m touching it I think

I had a similar experience to you and it turned out to be the way I’d built and exported the library to the Prime 4. Coming from Rekordbox, Prime Engine was a new experience. In the end I rebuilt the library from Prime Engine and transferred it to the SSD I’ve installed.

1 Like

Hi @djwdiscos - Sorry to hear of the issue with your PRME 4. Could you send me a PM with your contact info and I will have a team member in your area reach out to help.

1 Like

Hi @JWiLL I have the same issue my prime 4 will stop and play at random times mostly when its playing on vinyl mode, when is not in vinyl mode i still see the led light switching white and green but the sound won’t stop.

Probably poor earthing at the location or maybe something resting on the platters on power up

1 Like

Problem: The Engine Prime Library file is SUPER sensitive to hard-disconnects from devices. Mine got corrupted and made it so that some (not all) tracks would play but then freeze the decks.

Solution: Deleted my “Engine Prime Library” folder (on the USB) which ultimately meant all the stored metadata (Engine Prime Crates/Playlists) was deleted. I had to create new Crates and re-import my music BUT the metadata appears to have been cached by Engine Prime so no re-analyzing required.

Approx time to fix all depends on how well your library is organized on your external storage device. Mine was about 20 minutes. I hope this helps for some of you!

That’s why there is a EJECT MEDIA button. To prevent any data loss or file corruption.

Maybe the solution for some is purchasing a power conditioner to make sure clean power is getting to the device?

hard disconnects could be solved by adding a small UPS as I have seen from a youtube post. This prevents loss of HDD or tracks in the event of a hard disconnect.

I’ve been experiencing the same issue, the tracks freeze and crash the system. Very embarrassing. I’ve reanalysed all tracks through engine and onto a internal ssd drive with no USB attachments. Some advice would be appreciated

1 Like

My solution to all of this was to turn off Vinyl mode on the platters. That way the platter doesn’t react to any electrostatic “ghost touches”.

1 Like