Corrupted database during First import

Hello to all, I have this problem with Engine DJ. I have bought a Denon Prime 4+ in October 2023. I put a 1 tb ssd inside to store my music and using it during my dj set. But I was never able to load the music because the database got CORRUPTED during the FIRST IMPORT. In October 2023 I had a macbook pro with M2 max (64GB of ram and 2TB ssd). Now I’m using a macbook pro M3 max with 96GB of ram and 1TB ssd. The music is stored on an external Crucial 2TB SSD. Having the problem I tried and transferred the music to a new 2TB SandDisk SSD. But here too the database is corrupt. Then I tried a 2TB hard drive but nothing. I have problems with any version of Engine Dj, in the video the version is 3.3.0. I have also guarantee the Full disk access on the Mac. I have tried to import single by single mp3 and compose the playlist directly on Engine Dj but nothing! How could I solve? All ssd and hard disk has formatted in ExFAT. My actual version of macOS is: 14.2.1

1 Like


I don’t have library because I have to create the first library but I have the problem during the first import

It does not matter.

  1. Once you run Engine DJ it automatically creates an Engine Library folder in Mac>Music and another one in the root of the external SSD that your music is on.

  2. So remove the Engine Library folders.

  3. if you did it correctly when you start up engine dj…it will not contain any music

  4. Now connect the external drive with your music.

  5. Then you can proceed to add the music files to Engine DJ

I have already done it every time my backup broken. It isn’t the problem. If you need I’ll can record another video while I’ll do it but the problem is always the same :frowning:

Sure a video will help.

BTW do you unmount/eject the installed/internal prime4 drive before disconnecting the USB cable?

I just watched your video in the first post.

your drive is exfat .

Could you try a smaller folder?

Could you try turning off autoanalysis in the engine dj?

My music is not on the ssd of prime4 because I haven’t been able to synchronize yet since the import is missing. In the video my music is on my external ssd drive. yes my drive is exfat. yes I have tried also putting single mp3 by single mp3 but I obtain the same error.

“Could you try turning off autoanalysis in the engine dj?” I can try later immediately.

I suggested that because i can see that the import works but the database error occured during the analysis stage close to the end of the video you shared.

Maybe its a particular file causing the issue.

Can you check the logs, you can open it and see if its telling you anything

Hello, Disabling autoanalize, I can import the track without problem. The problem, instead, appears during the analyze of the tracks. In my mega there are the log

1 Like

I will have a look at it tomorrow, i will let you know if i can make sense out of it.

Ok thank you

Hello @Logan @Katerina @MikeC

Could you please assist

@rohs_dj does the drive/files work without issues in rekordbox/serato?

There is a feature in serato that detects corrupt files

  1. import files to serato
  2. analyse
  3. sort by the first column
  4. if there are any corrupt files you will see a lighting bolt icon in the first column :zap:
  • You dont need a paid sub/licence to use serato

  • To run analysis dont connect the prime4 to mac

1 Like

@mufasa is correct here, we can see the corruption to the database file happens during track analysis.

It looks as though the corruption happens as this track is being analysed (from reading the log file):

“093 Disco Fever - Raffaella Carra Hits Non Stop Megamix_ Festa _ A far l’amore comincia tu _ Rumore _ Tanti auguri _ Maracaibo _ Felicita ta ta _ Ballo ballo _ Che dolor (Dance Remixes).mp3”

Can I suggest separating this track from the rest of your music, then analysing the remaining tracks to see if the issue still occurs?

Alternatively I would try renaming the file to have a shorter name, since this track title is over 180 characters long it could be causing issues in the database.


Hello MikeC, Thank you for your time. I immediately try to rename this song and I’ll start again the analyze. Do you know some macOS commands to rename automatically all the filename that are long more thank 180 character?

Thank you

Hello mufasa, According to you is better to analyze my entire library with Serato to understand if there are other corrupted files?

You could use an application like Kid 3 to bulk edit tags in your tracks, but I’m not aware of any app that will simply restrict the length of your existing tags though.

As Mike suggested with super long file name, Better to start with sorting that out first.

I dont know what the text in the file name mean to you, but i will suggest you have a careful think about whats the best way to name your files before anything.

I also use Kid3 but my files are name “ARTIST” - “TITLE” eg Rema - Calm Down.mp3

I use the id tags for every other information relating to the track.

Dont think your file is corrupted, just too long - some dj program may accept it, whilst others may not.

That music was an old music. So I deleted it. I have analyzed the library with Serato and some mp3 files are corrupted but if I play them, I don’t notice any problem. Do you suggest to delete them?

Another information. Is there a way to import the music with the rating that already exist? Because I have seen that I have to rate the music again in Engine Dj and this will take me days of work. Consider that in October I had just finished rating around 12 thousand songs, I was importing a new library and everything gets corrupted. Days and days of work wasted. Then I did it for the second time because I didn’t understand what the problem was and after another few days of working on the rating, the corrupt library again XD. Import a new playlist and everything gets corrupted. So many days lost. So, if exist a way to import my library with the rating will be wonderful.

Hello MikeC, I have had again Corrupted Database now. Here there is the log: 7.08 MB folder on MEGA