Converting library to 2.4.0 problems

so, i have a new macbook and installed engine dj 2.4.0 I came from 1.6.1 no problem there , they started as soon as i put my usb in the macbook to convert my library. it says my drive is corrupt and that the database is created on a newer engine dj version?? when i acces it via engine dj it is all blank. if i put the usb in to my old mac with engine prime , it reads just fine and works . any thoughts on how this is possible ? attached is a screenshot

What is happening to you is normal!

You cannot upgrade from Engine Prime 1.6.1 to Engine Dj 2.4.0.

You have to rebuild your entire library with Engine Dj 2.0 and then once upgrade to 2.4.0.

During the release of version 2.0 of Engine Dj, there was an almost complete overhaul of the software creating a new database, which is not compatible with the database from previous versions Engine Prime.

It will therefore be important that there is consistency with the software version and the OS version in the Prime player.

It should do the database conversion automatically. From version 1.6 to 2.0 there was a process that converted the old database to the new one. It was stored alongside it.

Try installing Engine Dj 2.0 and see if that converts the database. It could be a large jump so try that first. It will add a “Database2” folder to your drive. This is your new database.

I’m sure someone will come along soon and chip in.

Could you have had two different versions of Engine DJ and Engine OS together, saving on the higher version number (OS version?).

just installed v2.0.0 , same result when inserting usb . same message as screenshot. absolutely no idea whats going on here

Yeah that doesn’t seem right. Hopefully someone can jump in soon.

Have you thought about deleting the Engine Library folders and maybe Engine Library Backup (if there was a backup) “the Engine Library folder must be in Music on the PC or Mac” you will also need to format your Prime to delete the database/library that was previously created with Engine Prime.

done all that , completely wiped everything and installed back , no dice …

Found a workaround, not hreat but it does the job. I took a fresh usb and copied all the playlists to it in engine prime 1.6, then put it in new mac with engine 2.0 Now playlists are visible and accesable. Then copied all to external ssd . Only downside is that i can not have the files on the mac itself

I think there is a problem on the use and it’s a shame!

Uninstall Engine Prime and remove all traces of Engine Library in Mac vote which is in Music. Format your USB device dedicated to your Prime.

Install Engine Dj Desktop 2.0 and create your new library, install 2.0 update on your Prime.

Once done all that… export your entire library to your dedicated media either by dragging and dropping or using Sync Manger.

What OS is installed in your Mac?

Completely wrong. I updated from 1.6 to 2.4 and have no problem with database. Only difference is playlists instead of folders.

Not really !

You were just lucky it worked for you the first time! There are quite a few users who have found themselves with a corrupted database.

Many users who upgraded from 1.6.x to 2.0 encountered different problems, so it was best or even advised to start from scratch for better database stability.

Go to the Denon dj Prime France facebook page and you will see a large number of complaints! I was an expert in the group and I left because there were a large number of people who preferred to complain than to listen to advice on use and optimization.

Start from scratch when you have a 10k entries database ?! Are you serious ? Who’s gonna spend thousands hours to redo harrassing job of cues, loops that was already done ! Denon “experts” have made many mistakes, and one was not to choose the right database system from the beginning of engine.

No ! We don’t spend hours!

By dragging / dropping I created a library in 5/10 minutes at the most and the same for exporting with 9k of music! I don’t know how you go about spending hours???

Latest mojave installed on mac m2 Got it ging now , solution mentioned in my previous post. Still need to figure out how to get the files on the mac itself rather then on the external ssd . Glad i did not loose a couple of thousand tracks

I think you are wrong, you should not have Mojave in MacOsX for your Mac M2?

To take screenshots, press the keys simultaneously as in the image below:

What file are you talking about??

sorry , operating system i have is monterey