Connecting X1800 to PC (Windows10)

Hey Guys,

I recently bought the SC5000M +X1800-Bundle and been very happy with this upgrade to my Pioneer DDJ 400 I used before.

Now I feel a bit confident in recording a Mix and tried several times to connect the Mixer to my PC using USB-Port 1 or 2 on the top right of the mixer. I plugged in into USB2.0 and 3.0 Ports of my PC and tried to connect it to my Windows10-Laptop as well, but it won’t connect or being recognized on both devices.

There is literally nothing happening, when I’m connecting the Mixer via USB. I tried to connect with the latest Drivers installed, without Drivers installed.

The Driver Panel tells, that the Mixer is not connected.

My SC5000M‘s and the X1800 came out of the box with actual firmware versions 1.4 / 1.2.

Factory reset did not bring any change.

What am I doing wrong?

Thx for your help!

Check the cable? Check the device manager? Get asio 4 all driver.

What software You want to use for recording?

You will find the master output on the channels 9 and 10. I think that is information that you will find in the amnual.

Downloaded Audacity, but didn’t start trying recording a Mix, cause Windows is not recognizing the Mixer when I’ve plugged it in.

Can’t choose it as recording device in Audacity.

Usually, when plugging in an USB-Device, there should be a Notification by Windows, right?

I checked the cable and was trying out another one.

What version of Windows are You running?

Windows 10 Pro, Version 1903

Did You tried to reinstal the drivers? Reboot the pc after this?

Yes i did, but even without a driver installed, there should be a notification in windows after plugging in the USB-Cable, or am I wrong?

It may be that the notification sound is disabled or not triggering property. The only way to be sure you have a connection is to check in device manager.

I did check in device manager, but there’s no device called x1800 or something similar

If you tried 2 laptops, tried both of the USB ports and in Windows you see no (X1800/unknown) devices, I would say the mixer is defective.

Contact support or better yet your reseller.

Have you check the settings in the Utility?

I did, but I’m not sure if everything is set right. Is there any setting needed for using the USB Port?

As far as I know it should be plug and play. But I have a macbook, so hard to tell how windows is talking with it :confused:

I think it may have been @Reese that posted this before, and apologies if i am wrong, but ensure that you allow the microphone to have access under windows.

This was absolutely bugging the t1ts out of me until i did this and then i managed to get Windows 10 to record through Audacity on channels 9 & 10.

An alternative is to record direct from USB using a host cable to your mobile, i have an Android and i purchased a USB to C cable and record directly using an App called USB audio recorder.

If i get the chance tomorrow i will post some pics of my soft end.

Yes I was, but that computer did see the device in basis and error 9999 was shown in Audacity:

1 Like