4.0 kills Wi-Fi

After installing Engine DJ 4.0 the Wi-Fi is dead on my SC6000M. The same for my cousins Numark GO. U can not turn it on in the Wi-Fi menu anymore. It’s all grayed out. If I go in the Device menu, I can turn it on, but nothing happens. But I can see all the Wi-Fi networks. I try to reset my router. Then my Wi-Fi worked a little. But after re-powering the unit, it’s all gone. Lukily I not updated my Go yet. Anybody else experiencing the same problems? Now I have to try to downgrade an install it true USB-drive.

try a factory reset - does this fix the issue?

1 Like

Thanks for feedback! I tried to reset the player and the router. I actually fixed the problem, but after rebooting my SC6K the Wi-Fi is gone once again… Very strange.

reboot or factory reset of the player?

Factory reset first. Logged in and tried I some tunes from Beatport. Everything worked fine. And then I turned it off/on and the problem is still there.

I tried this on two of my four 6KM’s and no issues :(. I’ve updated, rebooted, set them up to use Wifi, disconnected ethernet, rebooted, wifi connected. I rebooted two times and they automatically connect.

There are two ways to get to the wifi screen. are both of them inaccessible?

Can you share a photo of wifi disabled screen?

As u can see it’s turned on in the Device page but off at the Wi-Fi page. When I turn the player off/on the Wi-Fi is off at the Device page as well

Update: Tried with my phone as network. Everything is working fine. As soon as I tries to login to my house-network the Wi-Fi is turning off.

I wonder if your access point is somehow antiquated?

Maybe, I acually was thinking the same. But strange it happens on this update. The rest off my units in the house are still working. TV, phones, Xbox etc I think I try to update my GO as well to see if the same happens.

Have you done the “forget this network” / re-register to see if it fixes the issue?

1 Like

Yes I have. But as soon as I connect to it, it turns off on the player. I will try too take it to another network this week to see if it will work. If it do, I have to buy I new router in the house.

Have you tried updating your access point?

This is happening to me on my mixstream pro go aswell, again.

Started happening on 3.4 so I downgraded to 3.2 just to get wifi working, decided to give it another go (reported on this forum) & strangely enough wifi started working again on 3.4.

Now I’ve updated to 4.0 it’s not working again, downgraded back to 3.4 still not working, downgraded back to 3.2 working again.

Tested 3.3 not working.

Looks like I’m staying on 3.2.

Another thing is you get a controller update with updates 3.3, 3.4 & 4.0 I wonder if this is causing issues with some random devices.

3.2 uses controller version which is where the wifi works fine.

All drives removed, tried all available update methods where possible, usb, pc, (wifi working pending) factory reset countless times.

Remember the days when you just bought a bunch of new records & put em on your 1210s.

1 Like

This was my thought too. That controller update seems to remove the WiFi functionality on some units but not others.

If there’s a small hardware revision in some devices (different WiFi chip, supplier or config) then this could be affected with the controller update should it not include the right update files.

It makes you think if there’s different modules in these units that need updating, so are all firmware update files present for all variants to get the update? If some files are missing then only one type of module gets updated, leaving the other type without a firmware or driver. This would be something for the team to establish.

I always try to hammer home when some people say “well my unit is fine so it’s not the hardware or they will all be doing it!” the fact these devices go though revisions or have components sourced from other vendors.

A good example was the white Prime 4. Same model just white. It turns out the screen was different as this had an issue where the screen couldn’t be dimmed in the settings so an update had to come out to fix it. To look at it you couldn’t tell.


100% this, and something like a wifi chip is prime candidate for a parts change, vendors go out of business, stop certain lines etc etc. Look at the bluetooth (also part of the wifi chip), some models cant support having bluetooth due to a parts change across devices.

1 Like

I wonder if they’re looking into this, I wonder if they will look into this, an update/patch without the controller update included would be a good place to start to see if that’s the issue with some devices, or release the update & controller update separately.

I wonder if theres a way to rollback the controller update only?

Couldn’t of been the Bluetooth module that got knocked out could it, I find that more useless than the wifi.

Well there’s no point activating my free trial of beatport or beatsource yet or signing up to any streaming service for that matter until it’s fixed, my amazon music free trial is going to waste unless I downgrade to 3.2 just to use it, but I like some of the new features on 4.0.

If it has been raised as a ticket and highlighted on here, someone will be looking into it id say Andy.

Ok lovely, good to know.