[1.6] Right Click -> Analyze tracks not doing anything

Hi All -

I’ve just dragged some new files from a folder into Engine Prime. I have Auto-Analyze on, and the files didn’t analyze. I selected them all and right click->Analyze files and nothing happens. Dragging files individually into the player does cause them to be analyzed, but you’d have to do it 1 by 1.

Using Mac0S 11.2.1 on an M1 Mac Mini

Anyone else seeing this behavior and have a workaround?

Thanks, Matt

Denon staff commented yesterday , or the day before that Mac M1 is not compatible with Engine currently.

There could be something else going on too of course but the M1 in your supplies specs made me remember the announcement from denon about M1

Thanks @Nitebeatz - I thought that might have something to do with it, but seems weird that this function would be the way that a problem shows up :slight_smile: Everything else is working just fine!

If You have some data already in these files, maybe click - RE-Analyze??

If reanalyse does not work, you can try with a fresh blank database.

Rename your Engine Folder to something like Engine Folder Archived. Start up Engine Prime and you will have a blank slate add all your tracks and analyse

Sometimes there are gremlins between software updates

I did try Re-Analyze with the same result - nothing happened. Thanks for the suggestion!

@mufasa That’s hardly a solution.

Last time my DB went t**s up it took the guts of two days to rescan everything and create new memory sticks. I never even bothered setting cue points or I’d still be going months later.

I’m still on my original VirtualDJ database since 2007 and it’s been through god knows how many updates.

The way Denon have programmed the DB is not great. It’s far too fragile and does not self heal.

Unfortunately I’d lose all my cues, then, which I’m not willing to do.

It’s a test.

You can always revert back to your current database

I understand but it is what it is. I go through Builds steady for testing purpose and have run into this situation where things just stop working eg Analysed track not showing the grid dot, analysis not working etc

Sometimes a simple restart of the PC is a solution some times it’s a database rebuild

hey @mufasa , i’ve just encountered this issue too (1.6) midway thru analyzing my collection. imported a new folder which worked fine, but just didn’t analyze. tried right-clicking analyze - nothing. tried re-analyze - nothing. tried ejecting drive, restarting PC etc… nothing. tried that twice.

above you say “If reanalyse does not work, you can try with a fresh blank database.” – does this mean everything i’ve analyzed since last Friday will be lost? i just want simply to analyse files and install this SATA drive :frowning:

If You follow Mufasa’s steps, You can see, that he was asking to make the current data base “invisible” for Engine Prime only for a matter of test. Rename the data base file and start engine prime - it will creat an empty data base. No files in it. Then You can safely do any tests to rule out the problem.

As I seen in Your topic, it looked like You have problems with Your computer’s OS

Cheers mate. Yeh initial issues were with a Mac… this PC has been flawless tho. Will try the rename and see what’s up… ta

1 Like

this (from 2019) is obviously the issue bc im trying to analyze a SATA SSD with my whole collection on it… and the drive is FAT32 w/ 4GB limit. wish i had known the Denon DB could potentially get that this big or at least a warning with the formatting info in manual that when formatting a drive for HUGE collections that there could be potential issues w/ db size exceeding FAT32 limitations. now i have to reformat, recopy, reimport & reanalyze again. smh

FAT32 is a not recommended not only for Engine, but in general… I have a lot of files exceeding 4GB, so non of the drives I own, are formatted in this standard due to the 4GB limit… Didn’t thought about that someone can have it on a SSD or HDD…

yeh because Mac is my default, FAT32 was just my format for years simply for cross platform use and never thought to use exFat… anyway live & learn. shrug

1 Like