[1.5] Serato files unavailable

Fresh install of Engine Prime 1.5. Have my Serato library (v2.3.5) in order and all files work just fine in Serato but when trying to import them from Serato to EP, the files are just red and can’t be loaded/analyzed. Doesn’t even properly see where they’re stored, on my data drive in my laptop.

The format of your “Data drive” might be the issue here to test:

  • Drag & drop a track in the explorer from the drive into an EP test crate
  • Quit EP
  • Start EP

If the track stays in the test crate then that’s not the issue

if the track disappears from the test crate and/or is not available, then it’s the format of the Data drive, the safest bet is to reformat it ExFAT

I’ve dedicated a large portion of my latest AMA streams to explain this all. MacOS is my OS of choice, but EP behaves identically on Windows. (link start at the correct time in the stream) Ask Me Anything Denon Prime Special collection management and conversion for DJ’s

Thanks for reply, I’ve already tried that as well as a full import, quit, and start. The track doesn’t disappear but does remain unavailable.

I’m on Windows 10 1909 and my data drive is NTFS and BitLocker encrypted as this is my laptop that I also travel with. It auto-unlocks when logging in so it should be fully accessible to EP or any application that needs access to it. No other DJ application has issues reading the files or Serato database (Rekord Buddy windows beta also works with it fine), just EP.

EP can access my iTunes library without issue as well as work with the files. Those files are in the same location and same files as what Serato uses so it’s very specifically an issue with working the Serato database than the drive format. I don’t wanna have to redo cues for thousands of songs.

I don’t think reformatting to ExFAT will solve the issue and there’s no practical way for me to reformat the drive right now.

I’m on MacOS, but I happen to know a thing or two about this stuff so here is my educated guess

not NTFS but BitLocker is your problem. EP should be able to read from NTFS internal drives just fine, however BitLocker makes the drive appears as either “removable” or as a “fileserver”, which are both incompatible with EP.

Why does it work in the iTunes part? The iTunes (or Rekordbox/Serato/Traktor) bridge in EP is not the actual EP collection but an intermediate database.

For more detailed info I refer you to the video link.

That’s odd that EP would see a BitLocker drive as removable when it’s on an internal fixed disk. I’ll try decrypting the drive and see if that fixes it. Denon should work on getting compatible with BitLocker drives.

Not really odd if you think about it, you want to “lock” the drive=unmount it to the os. Or it could be BitLocker making it appear as a server volume (same problem)

Again it’s an educated guess, since I’m a MacOS user. But I’ve been vocal about EP inflexible storage locations for more then 3 years now. same issues with my AppleShare FileServer, NAS, CloudDrives etc.

I have the same problem since they released 1.3.4, but nobody will help me. I don’t have record box or any other dj software. I only use Serato Pro, Soundswitch and Engine PRIME. If I install 1.3.3, it works fine. If I install 1.5 without uninstalling 1.3.3, it will show the files fine. Once I refresh Serato crates in Engine PRIME, pooof, it all goes away. My music is in my D drive and version 1.3.3 reads it fine. 1.3.3 creates an engine library in my music folder where my music is at in my D drive. 1.5 creates one there as well, but it also creates one in my C drive under no particular folder. I think that is where the problem is. I tried moving it to my D drive, but it will just create another one. Here is a link of a quick video I did of the problem. It was a quick video so please excuse the background noise. https://youtu.be/Rvl_VaZtYkk Hopefully someone can help here. I’m running windows 10 pro.

P.S. I also tried dropping music straight from my music folder in the D drive to the Engine PRIME collection by creating a test crate. Song imported fine, played well and previewed well. I closed Engine PRIME, opened it again and song file was still there. So from what I understand, the D drive is compatible with Engine PRIME. I didn’t doubt this as it worked fine on version 1.3.3 as previously mentioned. Here is a quick video of that https://youtu.be/zwWKb-be4Ag

What drive is throwing up the incompatibility window when you start up EP?

Quick video you said :grinning:

I actually watched all 15:58 minutes of it.

File a bug report and include the video as well.

That doesn’t look right.

So, decrypting my data drive didn’t resolve the issue (it took literally all day since it’s 2TB). When updating library the color will change from red to white then back to red. Also seems to think the files are on my C drive when they’re on my D drive. I can’t see this as anything other than a bug with 1.5. Uninstalling 1.5 and using 1.3.3 didn’t help. 1.3.3 crashes when refreshing Serato library and installing 1.5 over it results in the same.

Let me start with the same remark I did last time, I’m a MacOS guy and just trying to help/investigate. The described symptoms are 100% identical to when EP accesses tracks stored on a non supported volume. Indeed the reported drive will in that case be the drive containing your user “home” folder (~/). In your instance the C: drive.

EP excluding certain volumes from being part of the collection is something I’ve been vocal about since the release of version 1.0.

Some questions: Is the D: drive a partition of the C: drive or a physical drive?

Did this work in EP 1.3.X ? Version 1.5’s databases are 100% backworth compatible so renaming the app “Engine Prime” to “Engine Prime 1.5” and installing EP 1.3.X will give you the opertunity to test this.

Here are some other things to try / consider:

most likely candidate

Now you’ve made the partition appearing in the clear you’ll need to reset the EP databases.

  • Quit EP (important!)
  • in the folder ~/Music/ (your user’s Music folder) rename the folder named “Engine Library” to something else (e.g. “Engine Library broken”)
  • at the root of the D: drive rename the folder named “Engine Library” to something else (e.g. “Engine Library broken”)
  • Start Engine Prime (if done correct, it will be 100% empty)
  • run the “test crate procedure” as I explained in a previous answer. Odds are high that this time it sticks.

I don’t know a thing about DiskLocker but I do know a thing or 2 about volumes/drives/partitioning. The fact that you “decrypted” the drive doesn’t necessarily changes the fact that the D: drive is still controlled by the DiskLocker driver instead, of being a generic MasterBootRecord controlled volume.

D: drive is a physically separate drive from C and this was a clean install of 1.5. I got my gear literally this past Friday.

BitLocker decrypting the drive turns off BitLocker on the drive and it is no longer controlled or otherwise managed by that built-in software. There’s no special driver or anything blocking its use by other programs. It is still a generic MBR controlled volume.

The test crate works fine and has worked fine. EP can work with data on the drive just fine whether I drag n drop from explorer or import from iTunes before and after decrypting it. This issue is very specifically reading and working with the Serato Pro 2.3.5 database. Which it still fails to do.

Have you tried what I suggested: rename the EL folders and try to import the Serato database again?

Yep, did not work.

The C drive is. My music and Serato Pro folder is in my D drive. What I should of put was a very bad taken video instead of quick, lol. My bad. Can you please tell me how to file a bug report? I have never done one of those. Thank you in advance and hope those 15:58 minutes I took from your life were not that horrible :stuck_out_tongue_winking_eye: :grin:

EP can read my rekordbox.xml (5.8.5) file just fine. Recognizes the drive location of the files just fine. Going to try rebuilding Serato database, again, to see if that helps.

Edit: rebuilding and re-importing Serato did not work.

Did you empty Serato completely (rename the 2 Serato folders) and then basically the same thing as with EP, test crate in Serato populate it with some tracks from the D drive. Clear EP database (nothing in it!) and try to import that test Serato crate

is the in EP reported drive still C instead of D for those tracks? and is that the same when you import the RB XML?

Did you empty Serato completely (rename the 2 Serato folders) and then basically the same thing as with EP, test crate in Serato populate it with some tracks from the D drive. Clear EP database (nothing in it!) and try to import that test Serato crate

Yep, did all that. Same red results and showing C: as the file location for files.

In the RB XML it’s showing D:, I can import a song and it works just fine.

I have one other idea. Currently, my user “Music” folder is redirected to my actual music folder on my D: drive instead of its default location under my user profile on the C: drive. This usually isn’t an issue for 99% of applications but in the past I’ve experienced issues with Adobe applications and default folders being redirected anywhere but the default (especially to network locations). Maybe that’s tripping up the Serato database read? Seems unlikely given everything else but worth a shot.

I think you’re getting somewhere now my friend :slight_smile:

I would focus on the Serato Library and see if it creates actually 2 Serato folders on your D: drive,

one in the symbolic link folder you’ve set to ~/Music/ (which if I understand you correct is at the D: drive)

one at the root of D/

then it makes sense this throws off EP when it tries to import the Serato library.

I returned to work today so it’ll have to wait until I get home (my laptop is off so I can’t remote into it from work to test). Will update as soon as I try.

1 Like

How would you fix this? I’m ok with computers, but not great :grimacing: If you can share that info, it would be highly appreciated it.