X1850 SC6000 (brand new) engine connect wont work

So I bought an x1850 mixer earlier in the week, been spinning some vinyl using an old pair of 1210’s and was enjoying it.

Decided to replace a failed pioneer digital controller with a pair of SC6000’s, which arrived with mismatched firmware so updated both to 2.3.2

I noticed the mixer was 1.6 and 1.7 was out so I updated that too, then went about testing everything.

I can not for the life of me get engine connect on the mixer to work, I’ve also now seen it reboot its self on a few occasions (never seen before on v1.6) - really not a good start, immediately thinking of returning the whole lot. very disappointed.

I’ve got player 1 connected to link port 2 on the x1850 (ch 1/2 BA) and player 2 connected to port 3 on the x1850 (ch3/4 AB).

I’ve tried defining the player id’s to match the port number, no different (I dont think this is needed anyway?) I’ve tried swaping the ports around, so player 1 connected to link port 1 on the x1850 (ch1/2 AB) etc. Nothing will make engine connect work, I press the button and the light gets a bit brighter but nothing actually happens. I hold it and see the version number but nothing else or anything on players.

I’ve tried all manner of power on sequences and reboots. The SC6000’s link with each other, but no matter what I do engine connect on the x1850 does not work.

Am I doing something wrong here? I’m rather concerned about the reboots I’ve seen the mixer now do post 1.7 upgrade.

if you press the engine connect button then the cue mixer buttons should change color according to how the players are connected to the mixer via lan ports (the LED on the button should light up), if you press and hold the button then the players should show the layer assignment dialog.

For example, I turn on the mixer first, wait for it to initialize, then player 1 and then player 2 after a short period of time. Also, in the mixer settings, I have cue connect set to auto.

Another thing to consider is that pressing the button again turns off engine connect, so to close the channel assignment dialog on the player, you need to use the close button in the interface or press engine connect 2 times (the first press turns off engine connect and hides the channel assignment dialog, the second one turns it on again)

Thanks for replying, it’s good to know how it should work.

Sadly I think the mixer is now dead. It’s hard resetting its self every 2-3mins. The fault prior to this seemed to be as if the mixer wasn’t communicating at all on the network, the switch worked, but its as if the mixer wasn’t connected to it. I think its more likely the mixer it’s self is the fault now given the boot looping.

Annoyingly I have no way to know if this was ok on v1.6, I assumed it best to update (which had no problems) seeing as the players needed it to work together. I do know I got a good 12hrs of play time with just 1210’s as input, prior to the sc6000 connection and firmware update.

I’ll get onto the retailer and see if I can get a new one shipped. Not the best start having left pioneer due to firmware issues they said couldn’t be fixed. Hopefully this is just bad luck DOA rather than firmware issues again.

Does anyone have the v1.6 update for the x1850 available? I’m curious if a downgrade would work, it may still just reboot even in firmware update mode so fail to update.

Really curious if this is a v1.7 bug or a hardware issue, it ‘seemed’ ok on v1.6 but it could have already been on its last bit of life due to hw issue and the update was a coincidence.

Have you tried updating to 1.7 again? Maybe something went wrong the first time. I upgraded from 1.6 (HW: 1.4) to 1.7 and so far everything works. Also try disconnecting all devices from the mixer and see how it behaves.

This is the same hw 1.4, I was just going to give a second update of 1.7 a try, it didn’t say it had any issues during the update the first time though.

I have tried with everything bar power disconnected and it still does it. It’s stopped doing it every time now, left it to loop and its been up for 5mins or so now without a reboot.