x1800 update failed and no way to recover

tried to update the firmware of my x1800prime following some tutorials and now i cant update at all. when i start the update with the firmware updater it stops after 2-3 seconds and displays a message that the update failed due to the device not being found. it then tells me to scan for device which does nothing. the only way can start the update again (which will stop after few seconds same issue) is by restarting the mixer. I have restarted pc, reinstalled updater, tried different cable and usb port but no luck so far. anyone got ideas?

What sometimes helps is while the “receiving update” message, disconnect and connect the USB cable on the mixers end. Seems to be helpful when the second part of the update process is initiated.

I have gotten it past the part where the updater stops after a few seconds using a differed windows pc but the mixer never goes past “Data receiving” with channel 1 and 2 fully illuminated and channel 3 having one single blue led on. the updater on the pc goes all the way trough the loading process till you get the message that the mixer will power cycle and then click next. I have tried this about 5 times by now. same outcome every time.

It’s a long process - make sure your computers (either of them) aren’t set to power off the usb ports to save power after x mins , avoid usb hubs and try a different usb port on the computer

Also , I vaguely recall that only one of the mixers two usb ports can be used for firmware updates , so it might be worth checking the firmware update instructions on that - people don’t usually have any issues with firmware updates on the mixer so I expect it’s something local

yes its only meant to work of USB1 port. just very strange that the mixer will get stuck at the same part every time. with or without usb cable plugged in. yet the pc program loading bar goes all the way to the end taking like 5-7 minutes when its plugged in till i get the next screen that tells me to please wait for the mixer to restart which is still stuck at the “data receiving” stage. when i watched a YouTube video about how to update the mixer in the video had the channel LEDs go up like loading bars during that process before finishing.

loading bar on updater program for windows

what the mixer looks like. display reads “data receiving” but also states that when no usb is plugged in so looks like its not receiving anything

Been a long time since I updated an X1800, but it used to be a two part update which could be done separately, so you could skip the first part.

Need to check.

attempt number 20+ mixer is finally doing something different. will let yall know how it goes in the next few minutes. (actually have loading bars going up on the mixer) I have done nothing different to the previous attempts so no idea why i got further this time.

the update was successful. now I actually did do something different without realising. I used USB2 port for the successful update by accident. this mixer got serviced by local dj gear shop (or so previous owner told me) and they must have done some connections crossed over? the tutorials all stated only usb1 slot works for updates but this mixer only works with the usb2 slot. thank you for everyone that tried to help me, really appreciated.

1 Like

Had similar doing mine last year think it is the order you do it in. I cant remember if I tried USB 2. looks like is is at the bit were the mixer is waiting for the file and you hit update on the app. Pretty sure did everything the same too possibly did fresh reboot of pc/laptop before trying again. Few nervous hrs trying on laptop and PC but had similar with 70k film cameras firmware so like you did not give up easily, Is certainly at the point it updates or does update or fails think reboot refreshing Laptops USB’s helped it communicate with the mixer. Certainly worth persisting glad you sorted yours