Wow, my SC6000 just died.....or, at least I think it's dead anyway

So, a couple days ago I was playing for about 2 hours at home. Everything was operating flawlessly. My dumbass forgot to shut the players down prior to powering off my power conditioners (where ALL of my gear is plugged into). Anyway, both players popped up the warning that power was lost and that they were shutting down. I thought nothing of it. I mean, this was the “wow” feature that the SC decks are known for. Business as usual, I assumed. Granted, I haven’t improperly shut down my gear except for once before just to demo that function to a friend, and that was on the other deck, not this one. Anyway, so I go to fire up my SC6000s today and they both turned on, but one didn’t completely boot up. All the lights were on, but it never got past the splash screen with the Denon logo and the firmware version number (2.0). So, I tried pressing the power button to do a hard reset. Nothing happened. I tried again to press the power button, only this time I held it in. Still nothing. It just won’t power down. Next, I decide to cut off the power to the unit by unplugging the AC cord. It takes about 30 second and finally shut down. I immediately began looking on the forum for any posts of people experiencing something similar. I’ll admit, I didn’t look deep enough, but I did find a thread about someone not being able to shut down because of some issue related to their internal SSD. So, I took my SSD out, unplugged everything from the back (RCAs, Ethernet, USB), then plugged the AC cord back in to see if it would cycle properly this time. Nope, still no dice. So I repeated everything I had already done (hard reset, etc…) in an attempt to get it to power down. Only this time when I held the power button in, the screen flashed, and then these Red vertical lines started to appear. Then, what appeared to be a Boot Loop started, and each time the logo would reappear on the screen it was accompanied by more and more vertical red lines. It did this for a while before I decided to just pull the AC plug again and make this post. I think the unit is dead :weary:

Anyone ever see or hear of this happening to another deck? Prior to that improper shutdown a couple days ago, this unit operated flawlessly. This unit was the replacement unit I was sent by InMusic for the jog issues I experienced back when I first purchased the SC6Ks.

This is soooooo messed up! The first hard-reset results… The second hard-reset results…

1 Like

It might be that only engine os is corrupt. Did you try to boot it with a flashdrive containing the engine os file and perform a fresh install?

You could try this @blackavenger, but maybe the unit doesn’t even get to that. To boot into update mode:


Maybe @Anthony_DDJ can assist.

Thank you. I tried it, but it didn’t work. The update mode logo popped up along with all the vertical red lines flashing on the right-hand side of the screen like in the videos I’ve shared, but nothing happened. Oh well, I suppose this is at a warranty repair stage now. 'Effin blows!

@JWiLL - I tried to call Denon DJ Support - Tel: (401) 658-5766 several times today. A message states that office hours are from 10:30am to 6:30pm EST. I REALLY need to get this shipped back and repaired. I don’t have time to waste.

*edit - I finally reached someone with customer service. Hopefully, they get on this quickly. Either way, I don’t think you need to do anything now. Thanks anyway.

Well, my SC6000 is on it’s way Denon DJ to be repaired. I’ll keep Y’all updated on what ended up happening. But, I just have to say, as far as customer service is concerned, I really don’t understand the complaints I’ve read online (forums, reddit, facebook, etc…) about InMusic having poor customer service. This is the second time I’ve needed their help and they have been understanding, professional, and most importantly expeditious!!


Really cool to hear that mate

1 Like

Same for me with the German customer support. :100: :+1:

1 Like

Well, after them only having it for a week (6 days), it’s on it’s way back to me. I’ll let Y’all know what caused the issue. Must not have been too serious. That’s a relief.

Well, the new unit arrived yesterday. Yup, I said, “new unit”. Unfortunately there wasn’t a repair slip in the box, because apparently whatever happened was so bad that they just replaced the unit with a brand new one. Still, I wish there would have been something in the box to indicate what happened. Perhaps some insight that could prevent that from happening again. Then again, it was probably just a fluke accident. Shite happens! That said, I’m thrilled to have gotten a new unit. For that I am SUPER appreciative! Again, a testament to how GREAT InMusic/DenonDJ’s customer service is. I am sooooo much happier in this ecosystem than I EVER was with Pioneer DJ. Gonna’ mark this topic as resolved. No point in discussing it any further seeing as how I don’t have any indication of what caused the problem.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.