Usb update not worked 1.6

Hi all, trying to update using usb and get this message. Any ideas?

To perform an update:

  1. It is important to connect the Prime GO to the mains, otherwise the update cannot be carried out.

  2. With your PC or Mac … download the Firmware either the version for a USB stick or the installer utility version “I highly recommend this one” and open the zip (Windows) or dmg (Mac)

  3. For an installation with a USB key … “once the file has been decompressed” place the file on the key, then connect your USB key to the Prime GO and start it, go to the Utility menu and click at the bottom REBOOT and let the installation take place.

  4. For an installation with a PC or Mac, once the file is unzipped … open the application and connect the Prime GO to your computer / mac with a USB A to USB B cable once do this go to the UTILITY menu. of Prime GO and at the bottom press REBOOT and in case you may need to click the vers button in the installation utility on your PC or Mac, then let the installation proceed.

Yep i did all that. For some reason it wouldnt load via a usb. Uploaded via mac instead. All sorted.

A USB? So when you said you were trying to update “using USB”, you didn’t mean via a USB cable to your computer? I was going to say that the screen you showed is the normal update screen, which is correct for updating via USB.

I guess your phrase “a USB” means a flash drive.

Yeah correct. I tried to upload with a usb flash drive and got that message. In the end i found a printer cable and managed it that way :+1:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.