USB Tracks red, but still load and play

Hello. I am a new user, and just purchased the Prime Go. I was able to figure out how to import my music collection into EP. I was also able to export the tracks onto a SSD/USB. The problem I am having is that many of the tracks are showing up red, but only on the USB drive. They still load and play though. These are NOT the red (missing files) that show up in EP. What can I do to change the all-red files so the track IDs are white, and my Camelot keys are color-coded. I have a photo of my Prime GO LCD screen to show what I am talking about, but as a new user, I am not permitted to upload a photo!

  1. Connect the SSD/USB to computer.

  2. Launch EP

  3. Click on the DRIVE to show just the contents of the drive. The drive collection will be on the right Panel.

  4. Select all the tracks and re-analyse

If that does not work.

  • Reformat the USB/SSD to exfat and export a few tracks again to test.

if that also does not work.

Rebuilding your main collection database ---- by

  1. quit ep
  2. disconnect the usb/ssd
  3. renaming your Music > Engine Folder to Engine Folder 2021.
  4. start EP
  5. you will have an empty library
  6. add songs again
  7. export to freshly formatted usb/ssd


Thank you very much for your informative reply. I am trying the first suggestion and re-analyzing the tracks on my SSD. There are just over 10,000 tracks, so it is taking a bit. If that doesn’t work, I will try your other suggestions. I’m sure you knew this from my post, but here is what my SSD looked like on the Prime Go LCD screen. Prime Go USB

If you are viewing the contents of the usb ssd in EP, are they red as well?

i would have done a quick test by re-analysing just a few tracks instead of the entire 10k

When viewing the usb ssd contents in EP, none of the tracks were red. They were only red when the usb ssd was plugged into the console and viewed there on the LCD screen. Easily more than 50% of them were red.

You are right. I should have tested a small batch first. Oh well, it still worked, and I thank you for your help. All tracks are showing up properly when plugged into the Prime Go now.

great stuff

mark it as solved.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.