“USB Corrupt” Issue after 1.3.1 update?

Hey guys. Having an issue after updating firmware to 1.3.1:

My USB stick now says “USB is Corrupt and may not work properly” when plugged into my SC5000M’s. I rolled the firmware back to 1.2.2 and this issue goes away; songs and playlists all work perfectly. This issue is ONLY present when running 1.3.1 and works on Engine Prime (Windows) the entire time.

USB is a Lexar 3.0 128GB Thumbdrive (ExFAT) Both players were updated via USB.

As of right now I’m running 1.2.2 with no issues but would like to solve this problem, as there are several new useful features in the latest release.

Thanks in advance!

Hi, maybe you can pdate the Motherboard’s Chipset Driver to solve USB corrupt issue

Step 1: Go to the Motherboard’s manufacturer website and find the latest Chipset Driver and then download it, follow the tutorial to update the driver. If you don’t know which manufacturer is, simply review from your computer’s document.

Step 2: Restart the computer and check whether your USB malfunctioned issue persisted or not. While for recovering files on corrupt USB, you can download the Bitwar Data Recovery tool first to keep your files safe. Hope it can help you anyway.

But it wasn’t his computer motherboard that was giving the error message, 5 months ago.

Maybe he was trying the usb3 stick on the front usb sockets which are usb2 only

Maybe jugh is a spambot for the app download suggested and can’t twll the difference between standalone devices and computers lol :stuck_out_tongue_closed_eyes:

I am actually still having this issue. I have contacted Denon support and have received no response after numerous attempts. Starting to become very disappointed with the Denon brand as a whole. Anyways, hoping someone on here could offer some info/help towards this frustrating issue.

USB- Lexar 3.0 128GB (Approx. 8000-10,000 songs)

Currently works with SC5000M v1.2.2 with no issues. Update the players to 1.3.1, plug the same USB in, and the players say “USB Lexar is corrupt.” I have tried all (3) USB ports on the players with the same issue. I even tried updating the players to the latest BETA firmware, and the issue still occurs. Revert back to 1.2.2 and they work great again. *Please note I do not use my Lexar music USB to update the players, I use a different blank USB.

This is very frustrating as I would like to take advantage of the numerous improvements in v1.3.1, without having to completely wipe my USB drive and start over again. Any help towards this issue would be greatly appreciated, as my attempts to reach out to Denon have failed multiple times.


Try updating the players with USB3 cable method. Utility settings will be reset, but update works better at the moment.

Could it be that your usb stick database was made with an old version of engine Prime and the players won’t read the old version or , the other way around.

When I’ve tried the beta test firmware , the players have updated the music database on my drives so something is changed on the databse. Maybe you are getting the error message from that ?

I will try the USB3 method mentioned above, that is the only thing I haven’t tried yet.

I am running the most current version of Engine Prime and noticed after the latest update, it also updated my USB drive once plugged in. Therefore I do not think that is the issue unfortunately.