Upgrade went wrong

Hi. I tried to upgrade my Prime4 this morning with 1.5 firmware. Looks like it has been done only partially as only booting screen show 1.5.2, but then all buttons lights are off and I can’t access to any menu as the view button doesn’t work either. Is there a way for me to force the upgrade again ? or to reset the Prime 4 ? I have a party tonight and I’m stuck if I can’t move forward Thanks so much in advance for your help Gilles

Hello @pommier Welcome to the forum.

Did You tried to power ON the device while holding Eject? This should start the update mode.

Trying it. thanks so much @NoiseRiser for the tip Unfortunately, doesn’t work

  • trying to do it via Computer : transfering, seems to work, but then same situation, all pad, buttons, lights down…
  • if only via Prime4, then stuck on the screen with the upgrade logo at the bottom, but nothing happens

Any other suggestion ? Thanks for your help

Try via USB uploader. Load onto USB root and not in a folder so prime 4 reads it.

Issue is that I can’t do it via USB, it is not working anymore. Controller, mixer and displays did not come online during boot

Ohhh nooo… The usual problems! :cry: :sob: :scream: :confounded: :triumph: :angry:

Use SD Card instead of usb. I had also a problem updating from USB. But SD Card worked for me.

You can also try the public beta 1.6 it is a usb/sd image. just download it, and unzip it. then copy it to sd card and do the power/eject update mode. It then asks from where it shoul update. there you choose sd/usb.

hold my thumps for you.

1 Like

hello DjAj,

what is the usual solution ?

If the problem is not solved by updating the firmware, the only solution is to contact Denon DJ technical support, or contact your dealer (if the equipment is still under warranty).

Thanks @DjAj Still expecting to be called back by Denon Support to come with a solution :frowning: